Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Scheduled backups failing in SD! v2.1.2 (

Codeus 06-17-2006 09:35 AM

Scheduled backups failing in SD! v2.1.2
Hi there,

I use SuperDuper to perform a weekly, scheduled backup of my 10.4.6 OS X Server boot drive to a compressed image file on a different partition every friday night.

The backups are performed while logged out having set them up as 'root' cron jobs. They have been working perfectly for a month or two.

After upgrading to v2.1.2 and modifying the scripts and / or creating new ones. SuperDuper fails to run the scripts while logged out. The SuperDuper window pops up behind the login box, sits there for a few seconds and then closes again instead of running the backup.

I tried a clean install by deleting the following files: -

rm -rf /Applications/SuperDuper\!.app
rm /var/cron/tabs/root
rm -rf /var/root/Library/Application\ Support/SuperDuper\!
rm /var/root/Library/Preferences/com.blacey.SuperDuper\!.plist

..and then reinstalled v2.1.2, re-registered etc, but this gave the same problems.

Finally, i repeated the above procedure to delete everything and then re-installed the previous version (2.1.1). This worked perfectly again.

Any ideas / anyone else having this problem with the new version?



PS - Great product, great support - I recommend anyone who hasn't registered to do so!

PPS - Any ETA on a full-command-line interface? Would be a HUGE plus to Network administrators!!!

dnanian 06-17-2006 09:56 AM

This isn't something we've heard of before, and it's a case we don't test, Codeus. But, if I had to guess, the script driver is hitting an exception, perhaps because Finder isn't running or can't be launched.

Does this happen with runs that were scheduled with 2.1.1 running under 2.1.2?

Codeus 06-17-2006 12:27 PM

Hi Dave,

No, provided the script was configured under v2.1.1. It still works with the 2.1.2

Only scripts which are updated or created under 2.1.2 seem to fail this way.

I kinda figured this wasn't exactly in the 'design-spec' from previous posts on the topic of root-schedules but it is massively useful and would be a shame to lose!

All the best.


dnanian 06-17-2006 02:37 PM

Really, I can't think of any reason why 2.1.2 would work where 2.1.1 wouldn't, given the same scheduled item. Perhaps you should try recreating your LaunchServices database?

Codeus 06-17-2006 04:17 PM

Hi Dave,

I tried recreating LaunchServices (lsregister -kill -r -f -domain local -domain system -domain user) but I still get the same result.

SuperDuper pops up behind the login window, finder loads but the countdown before scheduled backup window never pops up, SD simply dissappears at that point.

Thanks anyway for your suggestion though. Your responses are much appreciated.


dnanian 06-17-2006 04:24 PM

Do you get anything in your System or Console logs? And, does it work for the non-root user, or if root is logged in?

Codeus 06-17-2006 05:08 PM

Nothing in console.log.

System.log shows the following: -

Jun 17 22:00:00 database CRON[1330]: (root) CMD (open file:///var/root/Library/Application%20Support/SuperDuper%21/Scheduled%20Copies/Erase%20database_boot_image%2C%20then%20copy%20fil es%20from%20boot.sdsp/
Jun 17 22:00:01 database crontab[1333]: (root) LIST (root)
Jun 17 22:00:01 database /private/var/root/Library/Application Support/SuperDuper!/Scheduled Copies/Erase database_boot_image, then copy files from boot.sdsp/Copy LaunchApplication(/System/Library/CoreServices/System
Jun 17 22:00:01 database /private/var/root/Library/Application Support/SuperDuper!/Scheduled Copies/Erase database_boot_image, then copy files from boot.sdsp/Copy LaunchApplication(/Applications/Utilities/SuperDuper!.app)
Jun 17 22:00:09 database /private/var/root/Library/Application Support/SuperDuper!/Scheduled Copies/Erase database_boot_image, then copy files from boot.sdsp/Copy LaunchApplication(/System/Library/CoreServices/


Incidentally, I just tried this on another machine (this time with 10.3.9 Server) and that fails in the same way, again, it works fine with 2.1.1.


dnanian 06-17-2006 05:50 PM

Does it work if root is logged in, Codeus?

Codeus 06-18-2006 05:59 AM

Hi Dave,

Yes, scripts under root run fine if logged in.

Same script then fails after logging out. As I mentioned, it appears to be at the point when the 'Scheduled backup will start in xx seconds' box would normally appear.

dnanian 06-18-2006 07:30 AM

Well, a lot of stuff happens in the schedule driver before that comes down, but the *interface* to it hasn't changed between 2.1.1 and 2.1.2. The script itself changed significantly, though... but you're using the old script.

Do you have Growl installed?

Codeus 06-18-2006 03:22 PM

No, no growl installed

dnanian 06-18-2006 04:03 PM

Perhaps that's the problem, maybe the growl check in the application is failing. That would certainly be unusual and unexpected, especially since you indicated it works when logged in.

I wouldn't expect it to quit, though. It would just fail.

Anyway, we'll try to take a look. If you could, please use the "Send to shirt pocket..." button to send the log from the successful, logged-in, scheduled run into the support email account. I'd like to take a look at the log for the 2.1.2 run. Thanks.

dnanian 06-18-2006 04:33 PM

Do you see any crash logs or anything else for SuperDuper in /Library/Logs/CrashReporter? Or does it look like it's exiting cleanly?

If the latter, could you install Growl for this machine? If we're getting an exception, it'll be posted as a growl event...

dnanian 06-18-2006 04:43 PM

OK -- I see I totally mis-read your 3rd post. I read it as 2.1.1's script doesn't work with 2.1.2 but does with 2.1.1. That's not at all what you said: you said 2.1.1's scripts do work with 2.1.2.

That means the problem's in the script.

OK -- I've sent you, offline, a replacement template to see if it works. Check your mail...

Codeus 06-19-2006 04:02 AM


The new template fixes the problem!

The logged-out-scheduled-root-backups now work 100% again, thank you!

I am really impressed that you were so helpful with this and actually worked through it over the weekend too.

Many many thanks.


All times are GMT -4. The time now is 09:43 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.