Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   First three luck (

frenchfries 08-13-2004 06:25 PM

First three luck
I never have problems with software, so this was a bit shocking.

I tried to create a copy of my disk three times, but I get strange errors each time. The program does not handle these errors at all (forget "gracefully"). I was forced to retry. There is no pattern that I can see in the errors. I'm sure I did more damage to my hard drive by trying to back it up.

Here are some log dumps:

[first try ended in:]

|04:00:29 PM|Error| SVUclone: Error creating directory /Volumes/iBook Backup/System/Library/Frameworks/Scripting.framework: Bad file descriptor
|04:00:32 PM|Error| : Bad file descriptor

[second try was not much better, this time I chose to fix permissions:]

|07:49:59 PM|Error| SVUclone: Error creating directory /Volumes/iBook Backup/Library/Caches: Input/output error
|07:49:59 PM|Error| : Input/output error

[last try--no fix permissions, already fixed:]

|12:02:29 AM|Error| SVUclone: Error creating directory /Volumes/iBook Backup/System/Library/Frameworks/Scripting.framework: Bad file descriptor
|12:02:30 AM|Error| : Bad file descriptor
|12:02:30 AM|Error| ****FAILED****: result=256 errno=22 (Unknown error: 0)

Anyway, after partitioning my drive and trying this three times, I'm not very hopeful for SuperDuper. I bought the program before even trying it (go figure), and, frankly, I can copy my own files using the finder, and they always seem to work.

Any insight would be lovely. If not, I'll look for another backup program and hope you enjoy my donation.

ps-I made three partitions, one is 11 GB to back up my 10 GB iBook disk. I chose the simplest copying options (after actually reading the manual--which I also never do). The partition is formatted as a HFS+ Journaled (there is no mention of "journal" in the pdf manual, so this better not be the problem).

dnanian 08-13-2004 06:57 PM

OK -- this is more than a bit strange, but I'll do my best to try to figure out what's going on here. But, before we get to that, there's no reason to think we're going to keep your money if you're unhappy. We stand behind our product and our service, and will continue to do so!

So, let's try to figure out the issue. (Note that it's often better to write to, rather than start a thread in the forums... not so much because we mind diagnosing things here, but more because gets automatically logged in our bug database, which allows us to easily track problems and follow-up with people. Just a note for the future!)

I don't have much information about your system, but it sounds like you're backing up an iBook on its own drive... I hope I'm correct there. The HFS+ Journaled is just fine, no problem at all, and won't be the source of something like this.

It does sound, however, like there might be a kernel extension, or something similar, interfering with our copy operation (although it's rather interesting that two of your errors are with the same framework). Could you describe the system a bit more completely for me? Do you have Norton AntiVirus, or any other 3rd party product that contains kernel extensions, installed on this system? (A System Profile report, sent to, would be awfully useful here.)

I'm sorry to start this generally, but "bad file descriptor" -- while I understand what it's saying -- is a new one to me. But, I'm sure we'll get to the bottom of it.


phils902 08-21-2004 09:00 PM

Me, too!
I also have been having the same problem. I've tried multiple times, repaired permissions, etc., etc. The latest log file shows:

|08:38:21 PM|Error| SVUclone: Error creating directory /Volumes/KMBS/System/Library/PrivateFrameworks/SystemUIPlugin.framework: Bad file descriptor.

The one before this I didn't write down completely, but it was an I/O error with respect to IOBluetoothUI.framework.

The ones before that I didn't record.

This is on a G5 dual 1.8GHZ with 10.3.5. I've run DiskWarrior to clean things up. I unchecked the "ignore permissions on this volume" for the target drive.

The source drive is a standard 75GB HD. The target is a 160GB LaCie FireWire drive.

Norton AntiVirus has been disabled.

I thought maybe registering would provide access to something that might help, but I can't see anything different. So I'm wondering if I made the roght decision.

I'm on an extremely tight deadline (have to have 10 clones ready in 3 days, or I'm toast.

Please, please...What's going on and -- more important --- how do we resolve these issues?

Thanks for your prompt reply.

dnanian 08-21-2004 10:02 PM

Phil -- I'll do the best I can: please send the SuperDuper log (found in Library/Logs off your Home) and a System Profiler report to support -at-, and I'll take a look...

All times are GMT -4. The time now is 01:56 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.