Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Sandbox/Disk Utility (

bill s 09-18-2005 05:35 PM

Sandbox/Disk Utility
I just upgraded to Tiger on Sandbox only. When attempting to verify permissions on Sandbox I continually get an error message:

Disk Utility Internal Error
Disk Utility has lost its connection with the Disk Management Tool and cannot continue. Please quit and relaunch Disk Utility.

I get the same message regardless of launching Disk Utility from Sandbox or Macintosh HD which are different versions.

There is no problem verifying/repairing Macintosh HD or Backup.
Could this possibly be something related to the Sandbox/ file sharing method?

dnanian 09-18-2005 06:24 PM

You definitely shouldn't be launching the one from Macintosh HD -- you should run the one from Applications/Utilities. What's weird, Bill, is that Applications/Utilities is *not* shared. The whole thing is copied, and thus would be updated by the installer directly.

I've upgraded to Tiger (literally) hundreds of times on a Sandbox, and haven't seen this before.

When you boot to Macintosh HD, does Disk Utility work properly? And, did you use Software Update to update your 10.4 (on the Sandbox) to the latest release?

bill s 09-18-2005 08:38 PM


I booted from Macintosh HD and got the same result. I didn't use Software Update to upgrade to 10.4.2. I haven't used Software Upgrade since I started using SuperDuper several months ago.

dnanian 09-18-2005 09:14 PM

Same result as in the same error? I don't understand how that could be!

Have you done anything unusual here that you're not mentioning? If you were booted from the sandbox, I can't see how the system files on the original drive could have been changed!

bill s 09-18-2005 10:48 PM

What I meant was that when booted from Macintosh HD I got the same error message when attempting to verify Sandbox permissions. Macintosh HD permissions verify/repair are normal. I didn't do anything unusual. Just upgraded from new CD and downloaded & installed 10.4.2 combo update. Updated some application programs also similarly. Everything else seems normal.

dnanian 09-18-2005 11:40 PM

Searching around a bit with Google shows that this is a pretty common error when Disk Utility has a problem -- I don't think it has anything to do with SuperDuper! at all. Try running the following at a Terminal command prompt:

sudo diskutil repairPermissions /

When you do that, what output do you get?

bill s 09-19-2005 07:47 AM

Here is what I got.

Last login: Mon Sep 19 06:44:51 on ttyp1
Welcome to Darwin!
[ip68-100-12-211:~] juliusso% Started verify/repair permissions on disk disk1s5 Sandbox
tcsh: Started: Command not found.
Determining correct file permissions.
buffer overflow!
[ip68-100-12-211:~] juliusso% Determining correct file permissions.
tcsh: Determining: Command not found.
[ip68-100-12-211:~] juliusso% buffer overflow!
tcsh: buffer: Command not found.
[ip68-100-12-211:~] juliusso%

dnanian 09-19-2005 09:11 AM

Um: I don't think you did the right thing there, Bill. You want to copy and paste just this line:

sudo diskutil repairPermissions /

into Terminal. You seem to have copied and pasted something totally different -- the output from a repair permissions operation.

bill s 09-19-2005 09:36 AM

I thought that's what I did.
I just now did what you prescribed, copied & pasted:

Last login: Mon Sep 19 06:45:46 on ttyp1
Welcome to Darwin!
[ip68-100-12-211:~] juliusso%
[ip68-100-12-211:~] juliusso% sudo diskutil repairPermissions /
Started verify/repair permissions on disk disk1s5 Sandbox
Determining correct file permissions.
buffer overflow!

dnanian 09-19-2005 10:37 AM

OK, Bill.

The implication here is that you've got either a bad executable file or receipt, and that's what's causing the trouble. When the repair permissions part of OSX reads it, it gets confused and fails... and generates an error.

When the Disk Utility version sees this happen, it fails with that weird "disconnected" message. But the cause of that message is the failure of the underlying tool, and that cause of that is some file on your drive that's corrupted.

Figuring out what is going to be a challenge, though. We pretty much know it's not an OS executable or receipt, because it happens on both your upgraded sandbox and on your original drive (right?). So, it must be a 3rd party receipt or application.

The first thing I'd do to diagnose it would be to run Disk Utility or Disk Warrior on the drive and repair it. If that doesn't help, more radical steps will need to be taken.

bill s 09-19-2005 10:47 AM

Thanks Dave

I'll try to repair the disk. If not successful, I guess the best bet would be to erase Sandbox and reclone it. Then reinstall Tiger, etc. Do you agree?

dnanian 09-19-2005 11:00 AM

I don't think so, because I think the problem originates on your Macintosh HD: you said it also happens when booted from there, right?

bill s 09-19-2005 11:12 AM

Yes it happens when I boot from Mac HD to verify/repair Sandbox. At the same time, when booted from Mac HD verify/repair of Mac HD or Backup performs normally. Do you still think the problem is on MacHD?

dnanian 09-19-2005 11:21 AM

OK, that's different. This ONLY happens when you repair permissions on Sandbox, whether from Macintosh HD or from Sandbox?

If that's the case, I'd recreate the Sandbox and check it with Repair Permissions. If it's fine, reinstall Tiger on it. Then, immediately -- without updating -- check it with Repair Permissions.

Finally, use Software Update (don't do it yourself) to update Sandbox and check again.

bill s 09-19-2005 11:24 AM

Ok Dave. Will do.

Thanks a lot.

All times are GMT -4. The time now is 12:08 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.