Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   SD takes an hour to ignore a large file?! (

cmarcus 11-19-2007 08:53 PM

SD takes an hour to ignore a large file?!
I'm trying to configure SD to ignore my Parallels disk image (of Windows XP) because I don't need to back it up. I've set up SD as follows:

Copy Script:
Include Script File Name: Backup - all files.dest

Script Commands: ignore Users/jmarcus/Documents/Parallels

When I run the backup, here is what the relevant portion of the log says:

| 11:49:54 AM | Info | /cores
| 11:49:54 AM | Info | /Users
| 11:50:01 AM | Info | Ignoring /Users/jmarcus/Documents/Parallels
| 01:03:29 PM | Info | /System
| 01:04:05 PM | Info | Ignoring /System/Library/Extensions.kextcache
| 01:04:05 PM | Info | /Desktop Folder

You'll note that ignoring the Parallels folder takes over an hour! As you can imagine, I'd much prefer to have the backup complete an hour earlier. Any suggestions on how to do this correctly? (Not sure if it is relevant, but the folder is about 18 GB in size)

dnanian 11-19-2007 11:18 PM

Sounds like the folder isn't properly specified, or there's another location that's being copied...

cmarcus 11-20-2007 11:49 AM

So how does one properly specify the folder?

When I added the folder to ignore to this script I used the Script Commands tab, navigated to the folder, clicked the "Add Item" button, and confirmed the Command was set to "ignore". I'm not sure how else I can specify a folder to ignore.

What does "another location being copied" mean?

cmarcus 11-20-2007 11:58 AM

I solved my own problem - I tried editing the file path in the Script Commands tab. When I added /* to the end of the path, it behaved as expected, quickly skipping the 18GB contents of the folder. Not sure why I couldn't just select the folder in the file navigator below and have SD ignore it - perhaps this is a bug?

To recap, this setting fails to quickly ignore the folder:
ignore Users/jmarcus/Documents/Parallels

But this setting works as expected and quickly ignores the folder's contents:
ignore Users/jmarcus/Documents/Parallels/*

dnanian 11-20-2007 12:33 PM

Could it be that it was removing the contents of the destination the first time you ran? Those two commands should mostly be the same except that one would copy the folder itself, and one wouldn't (but would ignore the contents, except for hidden files).

All times are GMT -4. The time now is 08:33 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.