Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   no default application to open xxx.dmg file (

Allar 12-09-2009 12:17 AM

no default application to open xxx.dmg file
I just cloned my snow leopard machine, with a couple of minor issues. It came up with "no default application to open xxx.dmg file. Finally when the .dmg file mounted, it's icon is the same as the hard drive, instead of an icon like a disk drive. Wondered why SD wouldn't find the app to open .dmg. I don't know which app does it either.

dnanian 12-09-2009 07:47 AM

Your 'launch services' database is likely being rebuilt, since the association between .DMG and the disk image mounter is established by that...

Allar 12-09-2009 08:38 AM


Originally Posted by dnanian (Post 28299)
Your 'launch services' database is likely being rebuilt, since the association between .DMG and the disk image mounter is established by that...

So is it a matter of letting the clone work for a while and SD would find the path to open .dmg? I remember having to "find" an app to open the .dmg and I simply chose "all applications" and the it worked though the icon of the .dmg remains like the mac harddrive and not like a external disk drive.

Also, exactly which app opens .dmg files,,,I seem to recall ?? Diskmounter from the past

Many thanks as always for your responses

dnanian 12-09-2009 09:00 AM

It might be easiest, now that you've overridden the default, to use Onyx or Cocktail to rebuild your launch servies database. That will restore the default settings and fix your icon.

Allar 12-09-2009 08:18 PM

The problem appears to be fixed but has brought in other issues.
I ran Onyx on the Macintosh HD not the clone (or was I supposed to run it on the clone?)
After running Onyx and the rebooting from the clone all was well until I went to the prefs to select the Macintosh HD to boot from and it was not there :eek:!! I then chose to restart holding down the option key and then saw both drives with the Macintosh HD highlighted on the left and the clone not highlighted on the right with the pointer frozen on the screen. I hit the return key and it started up from the Macintosh HD. Obviously concerned not seeing the Macintosh HD, I repaired disc permissions on the Macintosh HD and it shows this :mad::

Permissions differ on “usr/share/derby”, should be drwxr-xr-x, they are lrwxr-xr-x
Repaired “usr/share/derby”

Warning: SUID file “System/Library/CoreServices/RemoteManagement/”…has been modified and will not be repaired

What does the permissions log mean and how to deal with it?
What else should I do "to live happily ever after" :)
Many thanks for your help

dnanian 12-09-2009 09:06 PM

That permission diagnostic is normal and expected.

The fact that your drive is not in the Startup Disk preference pane sounds like you have it mispartitioned...

Allar 12-09-2009 09:22 PM

The partitioned drive did show up in the startup disk preference pane, it was the Macintosh hard drive (the drive on the Mac) that did not show up. I would think that if the partitioning was an issue, it would be the partitioned drive that wouldn't show?

Hasn't happened again, just wondered what, if anything to do before moving on !

dnanian 12-09-2009 09:49 PM

All drives are partitioned. It sounds like your internal drive isn't properly partitioned.

Allar 12-09-2009 10:16 PM

Since this happened once and hasn't happened again, would you recommend that I repartition the internal drive?

dnanian 12-09-2009 10:59 PM

Check in Disk Utility what partition scheme was used (click the drive hardware, NOT the volume, and look at the lower right side of the window).

Allar 12-09-2009 11:04 PM

GUID Partition Table

dnanian 12-10-2009 07:49 AM

OK. That's the right partitioning. No idea what happened that time, but I think you're fine.

Allar 12-10-2009 08:23 AM

Thanks. The only issue that persists is when I hold down the option key on startup, most of the time (90%), the pointer (mouse) is frozen in the same part of the screen, yet I can use the r/l arrow keys to choose the drive I want to start up with.

dnanian 12-10-2009 08:27 AM

Not really something we have any control over: that's part of the EFI BIOS... perhaps Apple can help there.

Allar 12-10-2009 08:34 AM

Appreciate all your help and patience, even to those of us, like me, who know little of this technically.
Enjoy the holidays, and a happy healthy New Year to you and your family.

All times are GMT -4. The time now is 07:38 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.