Shirt Pocket Discussions

Shirt Pocket Discussions (https://www.shirt-pocket.com/forums/index.php)
-   General (https://www.shirt-pocket.com/forums/forumdisplay.php?f=6)
-   -   WD My Passport Studio Drive won't boot (https://www.shirt-pocket.com/forums/showthread.php?t=4846)

2stepbay 12-14-2008 12:29 PM

WD My Passport Studio Drive won't boot
 
Hi

I recently purchased a portable Western Digital My Passport Studio Drive - 500 GB, 800/400 fw. I have partitioned the drive into two partitions - one for SuperDuper, the other for storing images. The drive itself is GUID partitioned, per Disk Utility, and each partition is Mac Os Extended (Journaled).

No problem creating the SuperDuper clone, or backing up. However, today, I attempted to boot from it. While it is recognized in System Preferences>Startup Disk, and I can select it, the partition will not boot. As an alternative I started up holding down the option key. Only the main HD appears.

Appreciate any guidance to get this to work correctly.

dnanian 12-14-2008 12:35 PM

Is this for the iBook or the iMac?

2stepbay 12-14-2008 12:39 PM

Hi

Settings are now correct.

This is for a new MacBook Pro, 2.53 ghz, 320 gb hd.

dnanian 12-14-2008 01:12 PM

If it's showing up in the Startup Disk preference pane, it should show up at Option+boot time too, unless -- perhaps -- it's not spinning up properly.

2stepbay 12-14-2008 03:22 PM

As I think back, I have been able to boot from this drive. What has changed in the interim is the latest Apple firmware changes for the MPB. Is it possible that a change in the firmware would affect the booting of the drive?

I backed up the drive last night for the first time since making the Firmware changes to the MPB. BU ran with no problem. This AM was my first boot from the clone subsequent to the Firmware changes.

dnanian 12-14-2008 04:04 PM

It shouldn't affect the booting of the drive, but it's certainly possible that it's changed the way external drives are detected, or timing values, etc. Haven't had other similar reports, though.

2stepbay 12-14-2008 07:27 PM

Would that be an Apple issue or Western Digital?

I tried the drive on the iMac - same "non response".

Perhaps creating a new clone might help. Thoughts?

dnanian 12-14-2008 07:41 PM

It's hard to say whose fault it is, especially if you indicated it was working previously. If it shows up in the Startup Disk Preference Pane, and you're sure it's properly partitioned as GUID, creating a new copy won't make any difference.

2stepbay 12-14-2008 10:22 PM

Hi Dave

Found this post on a MacWorld review of the new WD drive:

"If you intend to make a SuperDuper or CarbonCopyCloner bootable backup, be aware that Western Digital does not support booting from external drives - any of them.

I bought the 320 GB Studio version and was dismayed to find that it would not boot in FW 400 or FW 800 mode, but would in USB mode. I would assume this is a chipset issue, since it does boot in USB. I have other external drives from other manufacturers and some I've assembled myself, and all boot perfectly in FW and USB.

I use a TimeCapsule for automatic and routine backups, but like to make weekly bootable clone backups in case I need to get back up and running quickly in case of total drive failure."

Yep, the drive only boots in USB mode. No problem in FW800 prior to the recent updates. So something changed in the recent firmware update, perhaps affecting the drive's chipset.

Rather sucks that I can BU my drive in SuperDuper in FW800, but can't boot from it. I'll contact WD and Apple tomorrow and see what they have to say (I'm not optimistic here about either party acknowledging the problem):mad:

dnanian 12-14-2008 10:26 PM

As I've said in many, many places, I'm really not a fan of WD's external drives... at all. Don't recommend them.

TMay 12-16-2008 09:17 AM

Just a quick note in case anyone reading this thread might get the wrong idea. There is no problem with booting from external Western Digital drives regarding the RAW drives themselves. The problem is in the interface firmware which WD uses in their "complete" external solutions.

I boot three different machines from WD drives, both 2.5" and 3.5", in OWC/MacSales cases, without issue. These cases all use variants of the Oxford firewire chipsets, and are one reason that OWC externals are on the SuperDuper "approved" list.

dnanian 12-16-2008 09:26 AM

Right: that's why I said "external drives". :)

george 01-07-2009 09:17 AM

for what it's worth...(knock on wood)
had success backing up to/booting from a WD Passport (III) Studio 320Gb unit purchased last month from Apple Store.

Using the Firewire cabling (not yet tried USB cable) i've seen no problems using this drive as both TimeMachine/SuperDuper volumes, partitioned GUID 100/220.

MacBook (late 2006) 2GHz/2G OSX10.5.6

flick 02-09-2009 01:40 PM

Guid
 
My WD Passport works fine when holding the option key at startup as long as its reformatted GUID.

(WD Passport 2.5" on MBP 2.4Ghz with latest firmware)

flick 02-10-2009 04:31 AM

Dont forget when you power up holding the option key (ALT) wait until you see the startup disk options before plugging the drive in.

If the drive's connected before system powerup it doesn't spin up until later in the boot process and won't be detected as a boot device.
;)


All times are GMT -4. The time now is 02:29 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.