Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Backup fails, can not copy some airport file (

nielsb 06-19-2006 01:40 PM

Backup fails, can not copy some airport file
OK, so I am a complete newbie in the Mac World - just took delivery of my MacBook a couple of days ago. So coming from the Windows world where I have used Acronis (equivalent to Ghost). I browsed for some Mac software that would do something similar and came across SuperDuper.

Anyway, I installed SD and tried to make a complete backup. Unfortunately this has failed every time I've tried it. It fails when it tries to copy a system file:

I have tried to do the backup to various devices, but the error happens at the same point, so by now I have ruled out a device error. I have also tried to let SD do a permission repair before doing the copy, but the error still happens. I've read the User Guide about trouble shooting, but being new to Mac - at this stage I don't really know what to test (apart from doing a complete re-install of OSX).

Any ideas?


dnanian 06-19-2006 01:45 PM

What exact error does it give, Niels? (Copy all of the lines that indicate an error into a reply -- it should say something about an I/O error...)

nielsb 06-19-2006 02:33 PM

OK, so the last lines of the log is as follows:
| 09:13:33 AM | Info | /Applications
| 09:22:39 AM | Info | /automount
| 09:22:39 AM | Info | /Network
| 09:22:39 AM | Info | /cores
| 09:22:39 AM | Info | /Users
| 09:23:03 AM | Info | /System
| 09:24:01 AM | Info | WARNING: Caught I/O exception(22): Invalid argument
| 09:24:01 AM | Info | WARNING: Source: /System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AppleAirPortBrcm4311.kext/Contents/MacOS/AppleAirPortBrcm4311, lstat(): 0
| 09:24:01 AM | Info | WARNING: Target: /Volumes/OSX32MBBASE/System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AppleAirPortBrcm4311.kext/Contents/MacOS/AppleAirPortBrcm4311, lstat(): 0
| 09:24:01 AM | Info | Attempting to copy file using copyfile().
| 09:24:18 AM | Info | Attempting to copy file using ditto.
| 09:24:34 AM | Error | ditto: /System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AppleAirPortBrcm4311.kext/Contents/MacOS/./AppleAirPortBrcm4311: Input/output error

I hope this helps?!


dnanian 06-19-2006 02:55 PM

That certainly looks like trouble on the source volume, but it could be that it's repairable.

Please boot from your Tiger install DVD (or the system disk that came with the Mac) and run Disk Utility from the Installer menu (the bold one that says "Installer" next to the Apple menu at the top of the screen -- note that it might say "Utilities" on yoru copy). Then, use the First Aid tab to repair the internal drive, using the buttons on the right (NOT Repair Permissions on the left). Repeat until no problems are found, then boot back to the drive and try again.

nielsb 06-21-2006 02:36 AM

Thanks for the suggestions, unfortunately it didn't help. I guess the only resort is now to do a re-install.

Thanks again!


dnanian 06-21-2006 08:47 AM

That what it looks like, Niels. Somehow, that file is damaged badly enough that it can't be copied.

All times are GMT -4. The time now is 04:33 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.