Shirt Pocket Discussions

Shirt Pocket Discussions (https://www.shirt-pocket.com/forums/index.php)
-   General (https://www.shirt-pocket.com/forums/forumdisplay.php?f=6)
-   -   Encrypted backups still not smart updating in Catalina 10.15 (https://www.shirt-pocket.com/forums/showthread.php?t=7190)

iith096 10-26-2019 12:59 AM

Encrypted backups still not smart updating in Catalina 10.15
 
1 Attachment(s)
FYI: It seems that encrypted backups that were encrypted after first performing a full un-encrypted full initial backup in SuperDuper! 3.3 Beta 2 (v119.3) (choosing erase first as recommended in the attached screenshot) still fail in later subsequent smart update attempts.

Hopefully this can be resolved, since I would prefer to secure my external backup images at rest with encryption.

Thanks.

dnanian 10-26-2019 06:26 AM

This is fixed in the next beta. If you're desperate, write to me at support...

iith096 10-26-2019 12:30 PM

Dave, no worries, I can wait for the next beta. Thank you for the quick response.

dnanian 10-26-2019 12:55 PM

Shouldn't be too long to wait.

iith096 10-30-2019 12:53 PM

Encrypted backups not booting
 
Unfortunately, encrypted backups will not boot in Catalina 10.15.1 and Beta 119.5.

The backup job processes as normal however when you try to boot into it, all you get is a black screen with the white apple logo.

I ended up wiping the disk with disk utility and formatting it back to un-encrypted APFS so I can maintain a workable backup in the interim.

I would like to maintain a form of a "3 2 1 backup" strategy with offsite backups, and leaving them offsite un-encrypted is not wise. Hopefully this can get sorted out. Thanks.

dnanian 10-30-2019 02:55 PM

I've just re-checked this case, and it's working fine here...I haven't tried an OS upgrade in between copies (just because I have to go back to 10.15.0, which I'm in the process of doing), but I can't reproduce.

Are you sure you waited long enough?

Probably want to move this to support email so we can go through the various things...

iith096 10-31-2019 11:46 AM

Dave, I will try testing again this weekend and see what happens. Thanks.

dnanian 10-31-2019 11:50 AM

Note that I'm in the process of testing an "upgrade" update to the backup while encrypted...

iith096 11-02-2019 08:20 PM

Dave,

Unfortunately, I tested encrypted backups again this weekend and the issue is still there. The image will not boot. Only get a white Apple logo on a black screen with no further activity.

I tested this by taking a known good bootable un-encrypted backup image (Samsung EVO 1TB SSD in a 2.5inch disk enclosure if it matters) and booted into it and encrypted it with Apple Filevault allowing it to fully complete (over two hours). I then attempted to boot into it and it failed to start. I then restarted and booted back into the internal Samsung EVO 1TB disk and initiated a SmartUpdate backup and allowed it to complete thinking that perhaps the encryption process changed or damaged the backup somehow. I then attempted again to boot into the encrypted backup and it again failed to boot with only a white Apple logo and nothing further.

So, not sure why this is not working. My MacMini is a (Late 2012) 2.3 GHz Quad-Core Intel Core i7, 16GB RAM, Samsung EVO 1TB SSD, that was formerly running Mojave which was upgraded to Catalina 10.15.1 using a normal in place upgrade.

Hopefully this gets sorted out. Overall, SuperDuper has always been great.

Thanks.

dnanian 11-03-2019 08:07 AM

Please contact me at support. This doesn't correspond with our own experience, and there's obviously something unusual going on.


All times are GMT -4. The time now is 05:53 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.