Shirt Pocket Discussions

Shirt Pocket Discussions (https://www.shirt-pocket.com/forums/index.php)
-   General (https://www.shirt-pocket.com/forums/forumdisplay.php?f=6)
-   -   SD & Growl notification issue (https://www.shirt-pocket.com/forums/showthread.php?t=6936)

Budgie 05-04-2015 09:45 PM

SD & Growl notification issue
 
Hi
Got a strange event happening, I have growl set up to send an email to me only if
a scheduled copy fails, nothing else.
I am getting an email stating the below, yet when I log into my server, I am not presented with
SD showing the red failed area, in fact SD has quit as it should, I have checked the log
and that says Copy complete, this is quite odd behavior, does any one have any suggestions
as to why this may be happening?

ďCopy of Macintosh to BATCAVE (Backup) failed. SuperDuper! got an error: Connection is invalid.Ē

dnanian 05-04-2015 10:11 PM

Hm. Have you tried deleting and recreating the schedule?

Budgie 05-04-2015 10:18 PM

hey Dave

no, I will delete and recreate the next one which is scheduled to fire at 3pm today and see if that does it, plus ill delete and recreate the schedule with the issue, ill have to wait for it to fire tomorrow.

Budgie 05-05-2015 04:44 PM

ok, I deleted all of the scheduled backup's, and the problem is still happening
error: "Connection is invalid.Ē, yet the copy is completed with no issues.

My before copy always repairs permissions. I have checked all the logs
and they are fine.

The server has been rebooted, have run Disk Warrior, and done a fsck -fy

very strange, is any body else seeing this issue?

dnanian 05-05-2015 04:46 PM

"Connection is invalid" should have gone away in 2.7.5; I haven't heard of people having it recently. That's what you're using? Basically, it means that SuperDuper! quit before the schedule did, which shouldn't happen.

Budgie 05-05-2015 04:51 PM

using 2.7.5 (v95) OSX 10.10.3, OSX Server 4.1

dnanian 05-05-2015 05:48 PM

I don't know why you're be getting that. I'm not seeing it at all...

Budgie 05-05-2015 06:08 PM

ok, well iím not sure where to go from here, I guess my work around for now is to not have SD quit after the scheduled copy is completed, and have a on idle apple script running in the back ground that will quit SD only when itís process becomes idle.

dnanian 05-05-2015 07:02 PM

A scheduled copy automatically quits if SD! wasn't already running. There's no need to set a "Quit" in Options.

Budgie 05-05-2015 07:54 PM

interesting, that my 11am scheduled backup has not done it, so this is random

dnanian 05-05-2015 08:00 PM

Random and extremely uncommon...

Budgie 05-05-2015 08:03 PM

my mum always said I was special, ill keep monitoring it

Budgie 05-05-2015 09:36 PM

1pm backup sweet...

Budgie 05-07-2015 07:33 PM

ok, all backup's have gone ok since yesterday, until now, just had the same error thrown, this time I was watching the end of the backup, SD finished and quit, then the growl notification came up with the error: Connection is invalid, is there no way to stop this happening?

dnanian 05-07-2015 07:43 PM

Do you have a lot of scheduled backups, and have all of them been deleted and recreated?

Budgie 05-07-2015 07:53 PM

I have 15 scheduled backup's all backing up to external drives.

Smart Update BATCAVE (Backup) from Macintosh repeat's it's self 5 times a day at varying intervals, these schedules were all deleted yesterday and new ones were created. (these are the only ones that throw the error)

The remaining ones fire on MTWTF twice a day, once in the morning and once in the evening, and have never thrown this error, and have not been recreated.

dnanian 05-07-2015 07:56 PM

So, a single copy scheduled at a given time throws that error?

Budgie 05-07-2015 07:59 PM

it seems like that, the ones that seem common are 11am and 1pm

dnanian 05-07-2015 09:05 PM

I just don't see why it would make any difference. I'm unable, at present, to reproduce.

Budgie 05-07-2015 09:16 PM

hmm, ok Dave, interesting, I will go back to the start, and delete all schedules, uninstall SD, reinstall SD and redo all the schedules and monitor it over the week
and see what comes of it.

Budgie 05-14-2015 03:49 PM

ok, I have deleted all schedules, uninstalled SD, run disk warrior, and tech tool pro,
re-installed SD, setup new schedules, and the problem still randomly occurs, and it
seems that the 1pm schedule is the only one that repeats itís self.
I no I can probably move it to 1.05 or some thing, but that is not fixing the problem.

Itís not the end of the world, more a consistent annoyence.

dnanian 05-14-2015 03:50 PM

I've been trying to reproduce the issue, but haven't been able to yet... perhaps create them one at a time and see where it starts failing for you?

Budgie 05-14-2015 04:20 PM

I have re-added the schedules one at a time, to see if other factors
are adding anything to the problem and it has come down to
the 1pm schedule that seems to be the issue.

My set up is as attached screen shot, the external drives
for the BATCAVE backupís are never unplugged, yet the external
drives for the PREPRESS SERVER backupís are rotated out daily

The drive for the BATCAVE backup is in good health as I have
tested it to confirm it isnít having issues.

dnanian 05-14-2015 04:31 PM

Which means that some of these schedules are failing daily?

Budgie 05-14-2015 04:36 PM

only the 1pm one

dnanian 05-14-2015 07:33 PM

No, I mean for missing volumes.

Budgie 05-20-2015 09:33 PM

have tested all volumes through a weekly rotation, and the only scheduled backup that continually throw's this error is the 1pm one, everything else runs like clockwork..... maybe because it's winter here now :rolleyes:

dnanian 05-21-2015 08:19 AM

So...the 11am one no longer fails? Just the 1pm one?

Budgie 05-21-2015 03:20 PM

it appears to be so, haven't had any other issues apart from the 1pm one.

Budgie 05-27-2015 04:49 PM

yesterday had a 3pm scheduled backup throw the same error

dnanian 05-28-2015 12:05 PM

So.....it is random and inconsistent, basically.

Budgie 05-28-2015 03:18 PM

in a nut shell, yes..

dnanian 05-28-2015 04:52 PM

But when you it does happen, the backup is fine, you just get a weird Growl...?

Budgie 05-28-2015 05:05 PM

yeah, the backup is perfect, log shows everything is good, booting from the backup drive is good, just the weird Growl...

dnanian 05-28-2015 08:15 PM

I keep trying to reproduce, but the only way I can is by manually quitting SuperDuper before the schedule has a chance to do so...

Budgie 11-25-2015 05:36 PM

1 Attachment(s)
Just an update to this issue, which hasn't gone away, I have OSX10.11.1 on a 2.3ghz 4gb ram Mac mini, server version is 5.0.15 and SD has been updated to 2.8, which means I had to recreate all of my schedules, heres a screen shot of the latest growl messages.
The backupís are complete and working.

dnanian 11-26-2015 08:37 AM

"Can't get current settings" isn't good. Drop me an email and we'll try a full uninstall/reinstall.


All times are GMT -4. The time now is 06:33 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.