Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Another "can't boot from cloned drive" problem. (

robgo 02-06-2008 09:03 PM

Another "can't boot from cloned drive" problem.
I'm using Tiger on an iMac flat panel, running off several external Lacie firewire drives (not at the same time, of course), as the SMART status of my internal drive failed quite some time ago--everything got backed-up thanks to SuperDuper. I'm a registered user of SuperDuper, love the program, and haven't had any problems until yesterday.

I cloned the external drive I use the most to a partition ("backupboot") on another drive so I could partition this "main" drive, using Apple's disk utility, just 2 partitions, the same way I partitioned my other drives. Then I cloned this "backupboot" to the new partition of this "main" drive. It mounts just fine, all the data is there, I can drag it out, etc. But when I select it in preferences (it is there, and can be highlighted, and the computer says it will start-up on this drive when I restart), and then restart, the computer will not boot from it. It always has in the past, so it's not a problem with the drive.

And when I press "option" after restart, it does not show up to select.

I looked around a bit, and looked in the drive folders of both the drive I'm running off of now (also cloned some time ago with SuperDuper), and this newly partitioned drive, and noticed the folder called "System" on my current drive has a "X" icon on it, but the folder called "System" on this newly cloned drive (partition) does not. Now, according to some sites, the lack of the "X" means the folder is not "blessed" as a start-up folder (but then why would it show up in preferences?). But for the life of me, I can't figure out their instructions for getting it "blessed".

I searched the best I could here, and couldn't find an answer.

Any suggestions?

dnanian 02-06-2008 09:20 PM

The "X" is assigned dynamically by Finder when it's actually the startup drive, so that's not an issue: the folder is blessed if your copy was successful.

Are you sure that the drive is properly partitioned using either GUID or Apple Partition Map?

robgo 02-06-2008 10:42 PM

Yes. Apple Partion Map
Copy / pasted from disk utility:

Disk Description : LaCie Group SA Total Capacity : 76.7 GB (82,348,277,760 Bytes)
Connection Bus : FireWire Write Status : Read/Write
Connection Type : External S.M.A.R.T. Status : Not Supported
Connection ID : 58629422072480183 Partition Scheme : Apple Partition Map

Thanks for the answer about the "blessed", that makes sense, good thing I didn't try mucking around with that.

dnanian 02-06-2008 10:52 PM

Is this an Intel iMac or a Power PC? If the former, the drive should be "GUID", not "Apple Partition Map".

Also -- is this a "Porsche Design" drive? LaCie has indicated in the past that these drives don't always work properly during boot when Journaling is on. Why that would be, I don't know.

You can also see if this works:

- Disconnect all external drives.
- Get to the "Option+Boot" chooser
- Wait for it to become "idle"
- Connect the external drive
- Wait for it to spin up
- Click the "refresh" arrow
- If it appears, immediately select and click "boot arrow"

robgo 02-07-2008 09:07 PM

It's a Power PC
It's a Power PC, so I believe Apple Partition map would be correct.

I tried your suggestion a few time, and it didn't work, that drive just doesn't show up on the option-boot menu. Shows up immediately when connected while another drive is the boot drive, though. And I have a large video file on there, and it plays just fine.

Repaired permissions, used disk utility (showed no problems), zapped the pram, even used DiskWarrior.

It's not a Porsche design drive. It's been my main drive for over a year, always worked. Like I stated, it's not a "crisis", the data is still all there. If I can't get it bootable, I'll just have to figure out how to get my Firefox and Safari bookmarks off of it.

ummm...speaking of journaling, I have journaling turned off. Was turned off when I cloned it, and turned off when I cloned it back after partitioning it. Now you'll probably yell at me and tell me it says somewhere in BIG LETTERS that journaling must be turned on.

At least that's another thing to try.

dnanian 02-07-2008 09:11 PM

No, I'm not going to yell anything at you: if the drive is configured as proper for boot, and shows up in System Preferences as a legit choice, I'm not sure what else I can suggest other than the above.

robgo 02-09-2008 03:27 AM

Okay, got the drive to boot, BUT....
I got it to boot BUT:

Let me back up a bit, so things don't get confusing.

This isn't written as a complaint, I love SuperDuper, it's a great piece of software. This is the first time I've had a problem with it, and as I've said, all my data is intact, nothing is lost (if I can find my old Firefox and Safari bookmarks on the drive that won't boot.)

This is just for documentation purposes, and/or "thinking out loud" on my part.

I have three external firewire drives that were bootable:

"main" -- Lacie, 80 gb, no partitions, been using it for over a year as my main disk, since the SMART status started failing on my internal drive, and SuperDuper successfully backed everything up. (Internal drive is pretty much fried now).

"backup" -- a Maxtor, 160 gb, partitioned backupboot, backupmyvideo, backupnetvideo, etc.

"rugged" -- a Lacie "rugged drive", 160 gb, which I love the look, feel, and tiny size of, purchased in December, 2007. Partitioned ruggedboot, ruggeddata, ruggedvideo. Except for trying it out when I first got it, this is my "almost brand-new drive that I'll never really use unless I really need it." The video and data partitions are empty.

Since I use it so much, I wanted to partition my "main" drive into "mainboot" and "maindata". The reason I wanted to do this was because, being a privacy freak, every couple of months I use the Apple Disk Utility to wipe the free space on my drive, using the 7-pass-overwrite. Last time I did this on "main" drive, I think I started at midnight, and it wasn't completed until about 4:00 p.m. the next day. Way too long. If I partition the drive, I can do the 7-pass-overwrite overnight on a partition.

About this time, I turned off "journaling" on my drives, as i do a lot of video work (transferring old VHS to DVD, etc.), and heard this would help.

So I use SuperDuper to clone "main" drive to "backupboot", which used to be bootable. Journaling was off on all drives. Then I partitioned "main" into "mainboot" and "maindata", then, with journaling off, cloned the new "backupboot" to "mainboot". I should have checked first, I suppose, to see if the new "backupboot" was bootable, before I cloned it back, but I didn't.

Now, "mainboot" won't boot. Which is why I started this thread. All the data is there, it mounts fine. Just won't boot. Turns out, "backupboot" won't boot, either, but mounts just fine (lots of data on the other partitions). "mainboot" and '"backupboot" both show in "preferences-startupdisk" and you can click either of them on, and it "says" the system will boot on either when you restart, but it doesn't. You get that off-white screen with the grey apple in the middle, and the spinning-sprocket-of-death. When you hold down option as you restart, they won't show as a choice. Yet they still mount just fine if you select "ruggedboot".

Switched firewire cables, did the stuff mentioned above, nada.

So tonight, on a lark, operating off of my almost-new, almost-never-used "ruggedboot" I again partitioned "main" into "mainboot" and "maindata", knowing it would erase all the data (no worries, data is still on "backupboot") AFTER turning journaling ON everywhere. THEN using SuperDuper I cloned "ruggedboot" to "mainboot."

Good news: "mainboot" now boots, and boots, and boots, and boots. So it's not the drive.

Bad news: wasn't really anything at all on "ruggedboot", it's pretty much an empty drive/partition, except for the basics. So now "mainboot", being a mirror of "ruggedboot" is pretty much empty, too.

So did it successfully clone with SuperDuper, and become bootable, because journaling was re-enabled? I don't know. Could be. Next "experiment" would be to clone back "backupboot" to "mainboot" with journaling turned on everywhere.

Another possibility: my iMac flat-panel Power PC, operating with Tiger, has only 2 firewire ports. When I purchased my Lacie Rugged Drive in December 2007, I also purchased a Belkin 6-Port Firewire Hub. It has a power cord, to give it a boost, I guess, but I've never used the power-cord, no need to as far I could tell, huge video files would transfer with no corruption. I wasn't using the Hub when I used SuperDuper to clone "maindrive" to "backupboot". I had to use it, though, to clone "backupboot" BACK to "mainboot". I was running off "ruggedboot", which took one of my computer's firewire ports, so I had to plug in the Firewire Hub, to plug in "backupboot" and "mainboot" at the same time, and use SuperDuper to clone BACK "backupboot" to "mainboot". Could be that's what went wrong? (rhetorical question, really).

I'll do more experimenting, see if I can figure it out.

My two hypotheses so far:

1. SuperDuper MAY not clone a bootable drive successfully, resulting in a working BOOTABLE drive, IF journaling is not enabled.

2. SuperDuper MAY not clone a bootable drive successfully, resulting in a working BOOTABLE drive, IF a firewire hub is used. Perhaps there's a slight defect in one of the 6 hub ports, connection at the time of the clone, etc.

Quick question: my "ruggeddrive" is partitioned into "ruggedboot" "ruggedvideo" and "ruggeddata", the latter two completely empty, 49.55 GB each. Would there be any problem with me cloning "backupboot" to, say, "ruggedvideo", thereby having two BOOTABLE partitions on the same drive? I'm guessing there would be no problem, but thought I'd ask. I could do this without using the hub, then check if it was bootable, and then, if so, clone it back to "mainboot", without the hub, and check if "mainboot" was then bootable, with all the data/bookmarks, etc. that were there when I started the whole process. Of course, I guess that wouldn't really answer the question "was it the hub or was it journaling was turned off the first time?"

dnanian 02-09-2008 03:56 PM

We don't really "know" if the drive is journaled or not, and it doesn't make a difference to us if it's journaled. I think that might be a red herring...

No problem making more than one backup of the same drive.

TMay 02-09-2008 09:58 PM


About your hardware (hub) question.. I am not familiar with all of the external drives you are using. Does each (all three) have its own power supply, or are any bus powered?

Even if none are bus powered, I'd certainly factor in to your experiments trying with the 120 power supply plugged into the Belkin hub. I have had occasions with both USB and firewire hubs where the added power would do the trick.

If any of your drives (even one) is bus powered, I would DEFINITELY try with the power in to the Belkin, or even with power directly in to the bus powered drive, if you have a suitable adapter.

This is probably also a red herring, but can't hurt to try.

All times are GMT -4. The time now is 10:03 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.