PDA

View Full Version : Undefined Symbols Error


mheathcott
11-28-2005, 07:48 PM
Hi there. I have tried off and on to use your product for the last several months, mostly unsuccessfully. It seems that there's always some problem or another that prevents a complete copy of my hard drives.

Anyway, I just upgraded to the new 2.0 and was hoping that it would finally work for me. No such luck. I get this error:


| 05:41:03 PM | Error | dyld: /Applications/SuperDuper!.app/Contents/MacOS/SDCopy Undefined symbols:

| 05:41:07 PM | Error | /Applications/SuperDuper!.app/Contents/MacOS/SDCopy undefined reference to _copyfile expected to be defined in /usr/lib/libSystem.B.dylib

Can you tell me what I'm doing wrong? I'm not registered yet, but I don't really plan to register until I am certain that this sucker is actually going to work for me! Thanks!

Maxwell

dnanian
11-28-2005, 07:52 PM
Alas, this is a bug that we've got fixed in 2.0.1, due soon. Basically, we encountered an I/O error while copying one of your files. We backed off our normal copy and tried an alternate -- copyfile -- but copyfile isn't in the referenced library under 10.3.9 (even though we built with compatibility, go figure).

Anyway, we've worked around the issue, and the update will be released within a day or so.

Sorry for the trouble in the meantime... let me know how your copy works out when you get the update, and if you have problems, please contact support. We can't help you if we don't know what the problems are!

mheathcott
11-29-2005, 12:09 AM
Thanks so much for the quick response. I'll be on the lookout for the update! FYI, one of my other drives copied beautifully, I love the new interface with all the green when it works out right! :D

dnanian
11-29-2005, 12:28 AM
We figured that would be a big hint that everything was OK (along with the checks for the colorblind)!