PDA

View Full Version : What have I done wrong?


Tricia Henwood
11-13-2005, 08:58 PM
Hi,

I'm using SuperDuper 1.5.5 (v.74). Recently, I've changed my system around a bit because my 12 inch Powerbook had a hard drive that was on the way out. Here is what I've done -

I bought a Mac mini to use while the Powerbook was having the hard drive replaced. Before I gave up the Powerbook I installed Tiger on the Mac mini, updated it to 10.4.2 and then used the Migration Assistant to copy all files from my 'old' (i.e. Powerbook) system. When I received the Powerbook back from Apple I used a firewire cable to connect the mini and the powerbook and used Target Disk Mode to copy everything back from my Mac mini to the Powerbook so that each system is the same.

I now intend to use the Powerbook (with its new hard drive) as a portable only and will continue to use the Mac mini as my desktop computer. I have updated both systems to 10.4.3.

Previously, I used SuperDuper to backup to a clone of my Powerbook on an external firewire hard drive. However, I thought that it would be a good idea if I could 'backup' from the Mac mini to the Powerbook as well (say on a weekly basis) so that the Powerbook is always the same as the mini.

I tried to do this a short time ago by using the firewire cable to connect my mini to my powerbook. I then started SuperDuper but got a message saying 'Cannot locate Macintosh HD' and 'Cannot locate clone'.

Is this because the Powerbook has a new hard drive and the Mac mini has never been backed up using SuperDuper? Have I tried to do something idiotic? Is there something very basic here that I'm missing?

I'm afraid that I'm not very technical, but it seemed logical to me that what I wanted to do would work :confused:

Cheers
Tricia

dnanian
11-14-2005, 08:36 AM
A few comments, Tricia.

First, it's important to note that SuperDuper! is a "one-way" copy program -- it doesn't sync. So, if you make a change to the PowerBook and then copy from the Mac mini to it, you'll lose that change. (That might be obvious, but it's important.)

If you want to keep the two machines in "sync", you probably only want to do that in specific folders -- Documents, say, and your Desktop. To achieve that goal, you might want to use a program like FolderShare, which is free, and works quite well -- see http://www.foldershare.com.

As far as SD! is concerned, you haven't done any thing wrong. It just sounds like the old "memorized" drives are different than they used to be, so SD! can't automatically restore them. Just click "cancel" to the prompt, and re-select the new drives, and things should be fine.

Does that help?

Tricia Henwood
11-14-2005, 10:42 PM
Many thanks for your response, Dave. I wasn't planning to make any changes to the PowerBook but to simply have it 'mirror' the desktop system on a, say, weekly basis.

Yes, you're right - it really is only the Documents folder that needs to be backed up.
I am assuming that I will still be able to back up to my external firewire drive as well as to the PowerBook, but maybe the assumption is incorrect?

This morning I again connected the Mac mini to the powerbook by firewire and then ran SuperDuper.

At first I thought my problem might be caused by the fact that both hard drives were called 'Macintosh HD' so I renamed the PowerBook hard drive Macintosh HD 1, shut it down and re-booted then re-connected the firewire cable and started SD! Still no luck, I'm afraid. It allows me to choose Macintosh HD as the drive that I want to back up but the only options I'm given under the drive to back up to are Macintosh HD (which is greyed out) or Disk Image...

I'm sure it's something very simple that I'm missing here but, nonetheless, I am missing whatever it is.

Thanks again for your help.

dnanian
11-14-2005, 10:49 PM
It sounds to me like you're not really hooked up in "FireWire Target Disk mode", but rather with "FireWire Networking".

Which computer do you want to act as the "source", and which as the "destination"?

Tricia Henwood
11-14-2005, 11:24 PM
Whoops, I didn't realise that I had to be in 'Target Disk Mode' - I want the source to be the Mac mini and the destination to be the PowerBook, so I assume I start up PowerBook (destination) while holding down the T key, or do I have it wrong (yet again)?

Cheers
Tricia

dnanian
11-14-2005, 11:29 PM
That's exactly right, Tricia.

Tricia Henwood
11-15-2005, 03:12 AM
Hi again Dave,

Well, I thought I had it nailed but, unfortunately, I struck an error while backing up in Target Disk Mode.

The error message I received was -

'An error occurred while Verifying that permissions are enabled for Mac HD PB. Would you like to view the log file?'

I clicked Yes and looked at both the Console.log and SuperDuper!.log files. Basically it seems that the problem was that it was not possible to disable 'Ignore Permissions'. I'm afraid that I couldn't work out how to attach these logs to my post and I believe they're too long for a cut and paste.

Any ideas what the 'Ignore Permissions' might be about?

By the way, I changed the name of the Powerbook's hard drive from Macintosh HD to Macintosh HD PB.

dnanian
11-15-2005, 09:36 AM
Ah, no problem. We've covered this common error in this FAQ entry (http://www.shirt-pocket.com/forums/showthread.php?t=318).

I would actually rename the PB's HD back to "Macintosh HD". You can't copy to the boot volume, and it'll be the only selectable one in the destination pop-up, so have no fear.