PDA

View Full Version : leave my ignore permissions as I set it, please


rossb
11-10-2005, 03:06 PM
Hi,

I have recently set up SD to backup a company file server to an external hard disk. This was working well until I had to make some changes to the server file share points. I wont go into details, but suffice to say, all three disks that I am backing up NEED to have file permissions ignored. I'm sure you can set-up groups etc., but I don't have the time to spend countless hours trying to figure out how the hell you do the most simple of things in NetInfo Manager. I don't need ownership, it gives no benefit to our system, & so I'm not going to spend hours trying to set it up between multiple Macs & a file server. I'm a Mac user, not a Unix user.

Now, every day in the morning nobody has write permission to the file server, because permissions have been flipped back on each night when SD backs up. Nobody can get any work done until the settings are changed back on the file server. So… I have disabled backups, of extremely critical files, for now.

I read another post on the subject & it was suggested the poster shouldn't be disabling permissions in the first place. Have you ever considered what SD should & shouldn't be doing? Because it seems to me that in making a backup of a disk, an application should not for any reason alter the source disk. This is bad practice on your part, not the users. I understand why you have to turn it off before backup… but why on Earth have you not written the code to turn it back on after?

You suggested a customisation script with a terminal command. I have very little knowledge of shell scripts or how to make one, and I couldn't find anywhere the relevant parts of the User Guide. I doubt I will be able to write this code myself.

… So how about providing the customisation script yourself, as I gather it is something a developer will be able to do in minutes? Otherwise, can you point me to clear instructions on how this is done?

This is hardly an advanced option I am asking for--to leave my disks as they were before you backup them up.

& please incorporate this feature properly in the app for 2.0!

Otherwise - fantastic app, wonderful interface, & a pleasure to use.

thanks,
Ross

dnanian
11-10-2005, 03:27 PM
Thanks for the suggestions, Ross. We'll take a look at changing this behavior in the future.

If you'll contact me at support, I'll try to put together a little script that'll correct your ownership state automatically.

j.a.duke
11-24-2006, 11:24 PM
Dave,

I've got a second partition in my machine that has Ignore ownership set, however, everytime I use SD to back it up, it resets the checkbox.

Suggestions on how to fix this?

Thanks.

Cheers,
Jon

dnanian
11-24-2006, 11:52 PM
Alas, we always turn ownership on -- it's the only way to guarantee that permissions *are* respected... why do you need ownership off?

j.a.duke
11-28-2006, 11:09 PM
Alas, we always turn ownership on -- it's the only way to guarantee that permissions *are* respected... why do you need ownership off?

I haven't ever had permissions set on my data partition, since at one time I was logging in as different users and needed access to everything without any hassles so at the moment nothing has the "right" permissions and I find it a pain that I need to manually unset the checkbox after a backup.

Dave, can't you whip up a nice fluffy script that would do this? I don't know enough advanced applescript to do this-I've read through your script to reset the volume icon and can't figure out how I might hack it for this. And my usual trick of recording an app doesn't work really well for the finder. If you point me in the general direction I'll try.

Thanks.

Cheers,
Jon

dnanian
11-29-2006, 12:15 AM
You can run the following shell script:

#!/bin/sh
vsdbutil -d /path/to/the/volume

You'd save that (with the appropriate path and/or placeholder for the source or destination drive [see the User's Guide for the parameters]) as a text file, turn on its execute permissions (see the "icon" post in this forum for the technique) set that to the "after copy" shell script.

TMay
12-08-2006, 11:31 PM
Well, I'll be damned.....squeakier wheels than I finally get the grease. About time, and.... (Well, you know how i feel about this.) --Ted-- :D :D :D
(Sorry to "up" a ten-day old thread.)