PDA

View Full Version : one of three accts not copied


jmilt7
10-30-2005, 08:44 PM
Cube, 10.4.2, 1GB RAM

I read the manual and did a check here at the discussions but could find nothing that addressed my problem. I did a simple copy/clone (back up all files). I have three accounts (users) on the computer. After the back up, two of the accounts (users) were there, the third was not. What am I doing wrong? I should add that the first time I tried to clone I got some kind of permissions error that was fixed by following the directions in the FAQ forum under the topic ""Could not disable ignore permissions" when backing up on Tiger" and doing the fix of typing in "sudo rm /var/db/volinfo.database" in the terminal. That seemed to fix that problem and I was then able to clone, but again, not able to clone the third user. Do I have to go into that user account and do the terminal thing there, too? But then why didn't I have to do that for the second account?

Hope that made some sense.

Thank you

Jonathan M. Miller

dnanian
10-30-2005, 09:58 PM
Is the third user File Vaulted?

jmilt7
10-31-2005, 10:30 PM
Just to be clear as I am not that familiar with FileVault, I assume you mean if FileVault is turned on. No, it is not on any of the accounts (users).

dnanian
11-01-2005, 09:40 AM
Yes, that's exactly what I mean.

I'm unaware of any situation or case where a single folder or directory would be mysteriously missing during a backup. So, when you look in the /Users folder on the backup drive, it literally has a different number of files than it does on the source? Or, are you determining the status of the accounts by what's visible in the login screen when you boot from the backup?

If the latter, it's possible that your NetInfo database is damaged, and doesn't copy properly. If so, we can step you through reconstructing it, but it'd probably be better to do it through email...

jmilt7
11-01-2005, 10:51 PM
I am looking at the users folders (and others, but I will get to that in a minute) on the drive itself. That is, I have a La Cie Firewire drive connected. I ran Superduper (by the way, I am a registered user). Immediately after, that is when Superduper was done (didn't shut down, restart or anything), I opened the firewire drive and looked inside to see that everything copied over. Like I said, I have three accounts (users), me, my wife, and a third, kind of a general one that anyone can into. My wife's account is not there. But also, I just noticed, the "Shared" folder in my original drive in the Users folder is not on the clone (firewire drive) either. At first, I was mostly concerned about not having a back up of my wife's account, so I wasn't paying much attention to anything else. But now I have looked at other things and while it appears that most everything was copied over (albeit, I haven't checked every folder and ever file) I also noticed two folders on the clone (firewire drive) at the root level that are not on my original drive root level: Network and dev, neither of which have anything inside of them. I don't know if that is the way it is supposed to be but I thought I would mention it.

Thanks for your interest in this.

dnanian
11-01-2005, 11:14 PM
Those two root level folders are absolutely normal (and are hidden when the drive is the boot volume). Don't delete them! :)

So, assuming you're using the straight "Backup - user files" script, try booting from the LaCie. Log in as your wife. Is her home folder there?

jmilt7
11-03-2005, 11:08 AM
She had to work last night so I was unable to log in (I know it might seem funny but I don't know her password. She prefers it that way and I don't really care as I know she isn't doing anything wrong. She just likes her privacy). However, I booted off the clone/LaCie and her name was at the log in screen. Then I selected my account and opened the LaCie and Users folder and her account as well as the "Shared" folder were there. So I booted the Cube again, connected the LaCie and checked and all the accounts were in the Users folder. So I don't know why her account and the Shared folder weren't there when I looked immediately after cloning. I swear they weren't there :).

So I guess all's well that ends well. Although I should boot into her account on the LaCie, hopefully tonight, just to make sure.

Thanks for your time and concern.

Jonathan M. Miller

dnanian
11-03-2005, 11:12 AM
Glad to hear it, Jonathan: you would have had a really unusual, unique and disturbing case here had they not been there!

Sometimes, when it doesn't copy the files itself, Finder doesn't update like it should, so logging out/in, restarting Finder and/or restarting the system will show things that aren't there initially. This sounds like one of those cases.