PDA

View Full Version : Problem transferring to setup new laptop


conejo
11-04-2017, 09:29 AM
We got my wife's new Macbook Pro. Did a fresh backup in SuperDuper to a partitioned external HD, plugged it into the new laptop, selected that partition as the source for transferring stuff, and am getting an error message that the partition is a case sensitive file system while the new laptop is case insensitive.

So, now what do I do? Is there some way to create a new backup on the external hard drive that is case insensitive? Never seen this before. I upgraded her to High Sierra on the original machine a week ago hoping to avoid any compatibility issues with the file systems and now this.

dnanian
11-04-2017, 10:37 AM
So...you formatted your backup as case sensitive?

conejo
11-04-2017, 11:05 AM
well, apparently. But I've never seen that as an option. And this is interesting, it listed the partition holding my laptop's backup as case sensitive, as well. I brought up Disk utility on my laptop and my file system is case insensitive. So how am I ending up with backups that are case sensitive? I just attached the hard drive to my laptop and brought up SuperDuper and I don't see any case options. In the Advanced options tab, the only thing checked is to copy ACLs, which I did not enable. And I have no idea what those are.

dnanian
11-04-2017, 11:12 AM
It sounds like you must have formatted case sensitive. Can you send the log from the backup to me using the "Send to shirt pocket" button so I can see tie details, and we'll continue via support email once you've done that. Thanks.

conejo
11-04-2017, 11:25 AM
thanks, just sent it. and just confirmed in Disk Utility/Info. On the line that reads "is case sensitive" the value is "no". So not sure how my backup is case sensitive.

dnanian
11-04-2017, 11:31 AM
You confirmed the source. But the destination has been case sensitive since September 9th, at least (that's as far back as I could go)...

conejo
11-04-2017, 11:33 AM
Yep, but how did that happen? And more importantly, is there a way I can now for my laptop's backup create a fresh back to that partition that is case insensitive? Is it something superduper does or did I make it case sensitive when I initially created the partition?

dnanian
11-04-2017, 12:15 PM
It's something you did when you created the partition with Disk Utility. It's not something we did.

You can certainly format the drive case insensitive and then copy it again...in fact, an erase-then-copy backup will make it case insensitive (assuming both drives are the same major format - e.g. HFS+) for you.

conejo
11-04-2017, 01:23 PM
cool, I'll try that on my partition. On my wife's, we can get around the data migration issue. She has no music, contacts or photos, just documents and bookmarks. I can manually move those. Thanks for your help.

conejo
11-04-2017, 01:24 PM
one question: how can I tell if a backup on a partition is case sensitive or insensitive? I'm guessing I need to boot to that partition and then run disk utility from that and check, correct? Was hoping there might be some simpler way but I'm guessing that's it.

dnanian
11-04-2017, 02:20 PM
Look in "Get Info" for the volume in Finder.

conejo
11-04-2017, 04:53 PM
ok, I did an erase and full backup option in SuperDuper and the resulting partition is still case sensitive. Says it's "Mac OS Extended (Case-sensitive, Journaled)."

I'm assuming at this point I need to reformat that partition in some way. I upgraded to High Sierra a few weeks ago, under format that just says "APFS". I'm assuming that maybe the fact that the source is APFS has something to do with this.

So, direction on where to go from here? I copied my wife's Documents and Desktop folders from her old machine to a Misc partition on this drive. Once I setup her laptop and move those folders back, I can reformat and repartition the entire external drive as APFS, if that's possible.

And if so, best app to do that with? Can Disk Utility do it?

dnanian
11-04-2017, 04:54 PM
Is the source case sensitive?

conejo
11-04-2017, 04:56 PM
As I wrote above, no. In Disk Utility for the line "is case sensitive" the value to the right is 'no'. The source is APFS and my resulting backup is Mac OS Extended Journaled, case sensitive.

conejo
11-04-2017, 04:57 PM
and sorry to be such a pain in the ass on a beautiful Saturday. At least it's beautiful here in Austin. I appreciate your help, Dave.

dnanian
11-04-2017, 05:02 PM
Ah. So, as I indicated in my most recent blog post, if the major file system type (e.g. APFS, HFS+) isn't the same, we just reformat the drive and retain its format.

So, that just erased, it didn't reformat. You'll have to reformat it yourself to be case insensitive (or APFS case insensitive)...

conejo
11-04-2017, 05:14 PM
So can I do that in Disk Utility or do I need another app to do this? Looks like the next step in DU would be 'erase', the 'partition' option is greyed out. I'm assuming that means DU only 'sees' something it can partition if it's blank. And, can one partition of several be reformatted while leaving the other partitions alone, or will it need to do the entire disk and all the partitions at the same time?

dnanian
11-04-2017, 05:44 PM
You do it in Disk Utility. See the "Murtaugh's Lament" post at the blog.

conejo
11-04-2017, 08:27 PM
ok, I tried to follow those instructions but things aren't cooperating. I erased the entire external drive but it didn't allow me the option to select GUID and then APFS. It only gave me 4 options: mac os ext journaled, then the same with case sensitive, ms-fat and exfat. That's it. I went ahead and erased everything, blowing away the existing partitions and using mac os ex journaled, thought maybe it would let me format to apfs while creating new partitions, but no joy. The partition button is still greyed out.

Am I doing something wrong? Now I'm nervous because I don't have a currently cloned backup of my laptop.

dnanian
11-04-2017, 08:28 PM
You must be. If you turn on all devices, then select the physical drive hardware above the volumes, then click Erase, your should have the options to use GUID/GPT partitioning and APFS.

conejo
11-04-2017, 08:36 PM
Ok, I think I figured it out. Needed to erase at the whole device level and it's under the boot record where I can select GUID. Did that, then was able to use the context menu to convert to APFS and now I'm creating partitions. Will report back but hopefully I'm good now. Thanks again.

dnanian
11-04-2017, 08:41 PM
You shouldn't need to convert to APFS: you should have been able to erase as APFS...?

conejo
11-04-2017, 08:59 PM
wouldn't let me erase as APFS, don't know why.

then creating the partitions was a pain in the ass. Now I remember why I used some other app years ago when I first created these partitions. Tried to create 3 partitions, each with unique names, 500 gig, then 2 with 250 gig. Failed the first time, some weird error message. Second time created 2 partitions, one 800 gig, one 200 gig. Erased again, started over, first try fails, second try I get what I want but it's weird. In Disk utility and in Super Duper, it sees one of the partitions as having 800 gig when it only has 250 gig. If I bring that partition up in Finder, it sees it as only having 250 gig.

Always hated Disk Utility, tonight is no exception. But I think I have workable partitions so I'm running a cloned backup of my laptop right now. Will sleep better once that's done, haha.

dnanian
11-04-2017, 09:03 PM
Me too. :-)

conejo
11-04-2017, 11:24 PM
ok, backup completed. Too tired to boot to it to test, will do that tomorrow. But when I view that partition in Finder/Get Info, format simply says "APFS", which I assume is intrinsically case insensitive. So now if I get a new laptop in a month, I can successfully migrate my data.

thanks again for all your help, Dave. You, and your product, are a godsend, sir.

dnanian
11-05-2017, 01:22 AM
Yes, that’s what it would say. Good - glad it got done.