PDA

View Full Version : Permissions problem


fork
02-04-2016, 02:07 PM
New iMac with El Capitan 10.11.3. Superduper 2.8. Been using SD since time began. Everything on the iMac was installed fresh. I did an SD backup to a USB key before I started adding apps and stuff, and that worked fine.

I just attached a new USB3 external HD with partitions and backed up both the iMac internal Fusion drive and an SSD external where I keep my files, each to separate partitions. Afterward the source drives permissions changed, eliminating my "Me" account completely and forcing me to enter a password for everything. But the backup drives still had the correct permissions. I did fix it but now I'm gunshy of doing another backup.

I noted that the most recent download on your main site was the same 2.8 that I have. But I did see a November link on your blog to a beta version 2.8.1.

Is this the fix? Or did I miss a setting I now need for El Capitan?

[so far, I really hate El Capitan - both my 2011 MBA and my 2008 MacPro running Yosemite are snappier (in the Finder) than the brand new 27" iMac running el Capitan]

dnanian
02-04-2016, 02:13 PM
We do not touch the actual permissions on the drive, "fork". Did you have "Ownership" off on this (I assume non-boot) drive?

fork
02-05-2016, 01:16 PM
We do not touch the actual permissions on the drive, "fork". Did you have "Ownership" off on this (I assume non-boot) drive?

Before the backup I never looked at permissions on either drive and didn't manually change anything.

Both the Fusion boot drive and the external SSD started requesting permissions whenever I did anything (like open a file or copy a file) immediately AFTER I used SD. Get Info showed that my (Me) account was not owner of either drive. I do not know what their statuses were before - had no reason to look since everything had been working up to that time.

After the nags started, I added Me back as owner of both drives, and everything now works without any permissions nags - though I did notice that after a reboot, the Me account on the boot drive no longer has the Read and Write permissions I gave it, just Read. But I do not get asked to provide permissions to Finder copy files as I had been asked after the SD backup.

As I mentioned above, the first time I used SD 2.8 with this iMac two weeks ago, I backed up to a USB thumb drive, and everything worked normally. Only after I backed up both drives to partitions on a new external USB hard disk did the anomaly start. I also use SD to backup my older Macs running Yosemite, and I have never seen this behavior before.

dnanian
02-05-2016, 01:26 PM
We really don't know what the drive you're working with is, so we don't care if it's a thumb drive, a regular drive, etc. But it sounds like you were relying on "ownership off" for the drive, and ownership gets turned on when you back up with SD...