PDA

View Full Version : iTunes Library, playlists gone missing!


camner
09-27-2005, 12:34 AM
I have been running off my Safety Clone for a while and wanted to go in and install on my "main" drive the items that I've installed on the SC that seem to be working well and then I'd planned on recreating my Saftey Clone. I booted up off the main drive, iTunes opened (it's a login item) and I noticed that the iTunes window was empty! No playlists, no library, no nuthin'... Boot off of the SC and everything is there.

So, I don't want to create a new SC for fear of everything disappearing! I don't know how this happened, but given that I have a working iTunes on my SC, is there a file (or files) I can copy from the SC back to my main drive to restore full iTunes functionality before "recloning"?

dnanian
09-27-2005, 10:11 AM
That's rather strange: your iTunes library is stored in your Home folder, which is shared between the two volumes. I can't think of any reason offhand why it wouldn't be there on your original volume.

Are you, perhaps, running entirely different versions of iTunes on the SC and the regular volume?

camner
09-27-2005, 01:28 PM
You hit the nail on the head! I had upgraded iTunes on the SC. Once I upgraded iTunes on the main drive, the playlist reappeared. Thank you!

(One wouldn't think a .1 version upgrade would cause that effect, but who knows?)

dnanian
09-27-2005, 01:59 PM
You can never tell what's going on... a small increment in a version number definitely does not indicate a small change internally! :)