View Full Version : Toaster drive won't release after clone

12-25-2015, 11:52 AM
I use a "toaster" drives in 2 different Voyagers, both DH's and my SD clones are on the same one. Lately after cloning with SD the "toaster" drive won't release from the Voyagers (either one). It seems that SD is continuing to "work" even after I am notified the clone is finished. I set the backup for ejecting the external drive after SD is completed.

If I remove the toaster drive manually, I get a notification that the disk was not ejected properly.

This has happened the last few months. Any idea what may be going on?


12-25-2015, 02:35 PM
El Capitan is much more aggressive about indexing and the like. Try adding the drive to the Spotlight Preference Pane's "Privacy" tab.

12-25-2015, 08:41 PM
I don't understand, Dave. In the Privacy Pane in Spotlight, adding a drive to it, seems to eliminate Spotlight from searching for that external drive (as I read it) - don't I want spotlight to FIND the external drive (the Voyager drive which contains my SD clones:confused:).
Am confused....

12-25-2015, 09:18 PM
Well, what's keeping your drive busy is Spotlight. That's why it won't eject. Adding it to the Privacy tab will help prevent that. If that's not what you want, then you'll have to wait until everything stops working on the drive before you eject it, or shut your system down and then eject. Don't force eject.

12-28-2015, 08:13 PM
I did as you suggested by adding the SD clone to the Privacy in Spotlight. Then made the SD clone. However, when the toaster drive did eject, the SD clone was no longer on Spotlight privacy.

Obviously I would have to add it each time I make a clone. That is a PITA.....is there any way to make this setting permanent so I don't have to go through this every time I make a backup clone? This will certainly impact my consistent use of SD.....

Is there any other way to accomplish this so that ejecting of the clone will happen seamlessly as it used to????


12-28-2015, 10:31 PM
I don't know what you mean. The privacy setting is actually stored on the drive. So, if it's ejected, it won't appear...but will if you reattach.

12-29-2015, 02:41 PM
oh - I didn't know that - there was no place to "save" the setting. Will check this out again. (I just went back to Spotlight after ejection and the setting wasn't there) Will try again when I do another clone. will let you know.

thanks for the suggestion and info.

01-08-2016, 05:31 PM
Just tried your suggestion for the "automatic" ejection of the "toaster drive" - unfortunately, no joy. As I told you above, I have 2 clones on this same drive, DH's SD clone for his iMac and my SD clone for my MBPro.

When SD finished copying just now, I received the usual pop up that said, SD completed clone ok. Then there was also the normal SD screen which showed all completed and green and check mark for completion of the clone. The toaster drive (with its 2 clones) showed on my display screen.

One clone was DH's which I didn't access this time, the other clone was my own just copied with SD. I rt. clicked on mine, selected eject and it disappeared from the screen, however DH's clone #2 would NOT eject! I tried logging out as suggested in the Mac help menu, logged back in - no joy.

DH's clone still showed. So, then I turned off my MBPro, turned off my Voyager, removed the "toast", and rebooted. That did remove the SD clone for DH but that doesn't address the question of why these clones will not eject after I select this option in the copy menu.

Any thoughts on this would be appreciated...

01-08-2016, 05:34 PM
Did you add all the volumes to the Spotlight preference pane's Privacy tab?

01-08-2016, 07:47 PM
OMG, I think I only added mine - Duh!!! will try again and let you know. Sorry for the omission, I bet you're right....:eek:

01-08-2016, 07:55 PM
you're correct - I only added my SD clone not his, my thinking was since I only use his SD clone on his, I shouldn't add it to mine. DUH!!!!:D

Will try the whole thing again....I bet thats the answer....now thinking about that, I will have to add both "toasts" to his iMac as well, not just his SD clone. Will try both and let you know. Thanks for your patience....

Happy New Year ;)

01-09-2016, 02:59 PM
you're right as usual, Dave. that did it - adding both SD clones to Spotlight Privacy took care of the problem. thinking about that though, I do have another question - why do I have to "eject" manually when I have set SD to "eject" after backup is complete? I've always had to do this....shouldn't they "eject" by themselves from the application since I've set it that way?

01-09-2016, 03:01 PM
Only a volume you've pointed at will be ejected by SuperDuper.

01-09-2016, 04:31 PM
Not to belabor that point but I don't think that's ever happened.

My clone is SD - Clone 1, after the copying is finished, the Voyager drive with SD - 1, and SD - 2 (the "toast" in it), still shows on the desktop, it doesn't disappear until I rt. click on the "toast" icon, and choose "eject" - then I'm asked if I want to eject only SD-1 or both of them....

01-09-2016, 06:47 PM
Well - it certainly happens here. But only if you've set it up to do that, of course...