PDA

View Full Version : Drive won't eject after cloning


DavidCB
12-14-2015, 03:53 PM
With OS X 10.11.2 (just updated from 10.10.5), after cloning to an external FireWire drive, the drive won't eject.

The drive is excluded from Spotlight and Intego VirusBarrier Real-Time Scanning is off.

Any suggestions? Is using Force Eject harmful?

Thank you,

David

dnanian
12-14-2015, 05:23 PM
Don't force eject. If it wasn't potentially harmful, it wouldn't be a "force" operation.

We're not doing anything that would keep a drive busy. When we finish, we have nothing "active" on the drive. The only thing that makes sense is either Spotlight or Antivirus.

You can try to check, if you're comfortable with Terminal, using the "lsof" command. You'd run


sudo lsof | grep "The Backup Volume"


substituting appropriately for "The Backup Volume" (retain the quotes). That would give a list of all the files open on that volume, and the processes keeping them open...

DavidCB
12-14-2015, 06:07 PM
Thank you--I appreciate your help.

Here are the running processes I found for the external drive:

mds 62 root 12r DIR 1,7 1088 2 /Volumes/FW 15A MBPn3 2015-12-13
notifyd 106 root 55r DIR 1,7 1088 2 /Volumes/FW 15A MBPn3 2015-12-13
mds_store 1108 root txt REG 1,7 0 1783951 /Volumes/FW 15A MBPn3 2015-12-13/.Spotlight-V100/Store-V2/709A057C-E1E1-4C75-92B0-5F87DABC257A/live.6.indexTermIds
mds_store 1108 root txt REG 1,7 0 1783953 /Volumes/FW 15A MBPn3 2015-12-13/.Spotlight-V100/Store-V2/709A057C-E1E1-4C75-92B0-5F87DABC257A/live.6.indexPositionTable

What is the next step?

dnanian
12-14-2015, 08:48 PM
Well, that's Spotlight. Add the drive to the Spotlight preference pane's "Privacy" tab.

DavidCB
12-14-2015, 08:50 PM
Well, that's Spotlight. Add the drive to the Spotlight preference pane's "Privacy" tab.

It's already there--

David

dnanian
12-15-2015, 07:46 AM
Not sure what to tell you, David. You can see what actually has files open, and it's spotlight ("mds") and notifyd.

DavidCB
12-16-2015, 09:22 PM
Yes--somehow Spotlight still keeps hold of the drive even though it is in the Spotlight Privacy pane.

I didn't have that happen with 10.10, so I can only assume it is a bug in 10.11. I'll send feedback to Apple.

David

dnanian
12-17-2015, 11:38 AM
It also doesn't happen for most users (I have no problem here, for example).