PDA

View Full Version : Can't create a sparsebundle on a network drive


johncarn
11-10-2015, 01:19 PM
Running v2.6 v96, so have the latest version.

I recently moved to a new house. In the last place, my backups all ran to a networked drive in a different location.

Since moving, I have setup the networked drive the same as it was in the old location. I can map a drive to it, and I can create directories on the drive itself. This drive is a shared drive using TonidoPlug and is a 3TB raid drive.

I noticed my previous backups were sparseimages. I see that sparsebundle is recommended, so I deleted the scheduled backup and tried to create a new backup using sparsebundles (multiple times). But every time I try to run the backup, it fails with the following error when it tries to mount the image:

Failed to mount daily

| 12:16:29 PM | Info | Finished verify/repair permissions on disk0s2 Macintosh HD
| 12:16:29 PM | Info | ...ACTION: Mounting daily
| 12:16:29 PM | Info | ......COMMAND => Preparing daily
| 12:17:40 PM | Info | hdiutil: create failed - Operation not supported
| 12:17:40 PM | Error | ****FAILED****: result=256 errno=0 (Undefined error: 0)

I'm connected to the TonidoPlug as root, and have verified (I think) that it's not a permission issue. I even tried to increase my network speed (I had gb ethernet in the last location, not so here).

Not sure what else to try. When googling it, all I can find is delete and recreate the backup job, but that's not working.

Any other suggestions?
jc

Forgot to add. This is happening from my mac pro as well as macbook pros. Same error on all of the devices.

dnanian
11-10-2015, 03:53 PM
You're trying to create a Sparse Bundle on a device that doesn't support it. Bundles needs to be on AFP volumes that support absolutely up-to-date AFP. Sparse Images can be on SMB volumes.

johncarn
11-10-2015, 04:13 PM
Thanks, Dave. I guess maybe that's why my old backups were sparse images.

Appreciate the quick response.
Cheers.
jc