PDA

View Full Version : SuperDuper! and Folder Actions


d.r.h.
04-24-2012, 06:28 AM
Dave ....

Do you know of any reason SD might hang upon launch when folder actions are enabled? Here's the story. I've been using Macs for some 25 years now and have never encountered a virus/trojan (even in the Hypercard trojan days). However, with recent events of Flashback and other malware, I decided to test out enabling folder actions and attaching new item alert scripts to my launch agent and launch daemon folders. Here is my system info: Mac Mini (2.53 C2D, 10.6.8, 8GB RAM, very fast 7200 WD Scorpio Black HD). Immediately after setting up the folder actions, launching SD would result in a hang of 11 - 12 seconds (normally, SD launches immediately and is ready to use). After smart update is completed, if I just quit .... SD quits immediately. If, however, I click on the OK button after completion, there would be another hang. Removing the folder action scripts and disabling folder actions and everything is back to normal. There was nothing in the logs to explain this. While not a major problem, as this did not affect (as far as I can tell) back-up functioning .... I can't figure out the hang.

dnanian
04-24-2012, 08:56 AM
Our "Backup on connect" feature uses a launch agent. Do you have that feature turned on for any scheduled copies?

d.r.h.
04-24-2012, 10:46 AM
Our "Backup on connect" feature uses a launch agent. Do you have that feature turned on for any scheduled copies?

That's the strange thing. I don't use any special/scheduled SD features. I maintain 3 different back-up/clones (nightly, weekly and monthly on 3 different external drives) and just the default smart-update. Therefore, there are no ShirtPocket launch agents in any of the launch agent folders (first thing I checked for). At first I wasn't sure what was causing this, as the only thing I installed prior to noticing this was the Apple issued Java security updates. I doubted that would have caused it. Since I had also enabled folder actions, that was the next thing I started checking out. After disabling folder actions and going so far as to remove the add item action scripts from all the launch agent/daemon folders ... things were back to normal. Like I indicated .... it was not a big problem as, except for the hang, everything worked as usual. For now, however, I am keeping folder actions disabled. While relatively short, waiting through an 11 second hang ... that shouldn't be there .... was just annoying for me! BTW ... I tested this out on another Mac (a newer C2D Mini ... the last model with the optical drive) and outcome was the same. Hang with the same folder actions .... no hang without them.

dnanian
04-24-2012, 05:41 PM
Sorry, I don't know why that would be. We're not doing anything funny/weird.