PDA

View Full Version : Scheduled settings getting corrupted


edwardaux
01-03-2012, 05:18 PM
Howdy,

I have seen some very odd behaviour from SD! in the past few days. Somehow SD has not only corrupted my scheduled backup settings, but also mixmatched settings between two different macs!

I have two macs that I am backing up: my wife's imac (called jude) and my macbook pro (called craig). Both get backed up to separate sparse bundles on my QNAP NAS called jude_backup.sparsebundle and craig_backup.sparsebundle. This has been working with no problems for some months now.

Not sure if it is relevant, but we recently had visitors sleeping in our study for a few days, so I turned off my NAS to avoid it chattering at 2:30 and 4:30 in the morning. I turned it back on a few days later, and at that point things started to go to custard.

Firstly, jude's backups... the first overnight backup was successful, but the second one tried to backup to /Volumes/SuperDuper/jude_backup.sparsebundle/bands/1936 (note that it thinks it is backing up to a band, not the bundle itself)!!

And even more weirdly, craig's backups on the first night tried to backup to the jude_backup.sparsebundle!! I have no idea how the settings for jude's machine somehow managed to find their way across into craig's machine.

All very odd... I have not made any modifications to the SD! settings for weeks now. Any thoughts? I have the log files for both machines if that helps.

--
Craig

dnanian
01-03-2012, 05:43 PM
We've seen unusual behavior with QNAP NAS devices, which do not properly support sparse bundles (that's why you weren't able to make one to the QNAP directly). Please change to using a sparse image.

(It seems that when an alias is resolved to the file on a QNAP NAS, it can sometimes resolve to a totally different file, which is weird and bad. We've had one or two other users find the same thing, always to QNAPs.)

edwardaux
01-03-2012, 05:54 PM
OK, I see. That would explain both symptoms I was seeing. I'll give it a shot. Thanks for the quick reply.