PDA

View Full Version : Backed up to sparse image on Airdisk, but now can't select it again


snoogly
11-03-2011, 03:06 AM
I followed the instructions for creating a sparse image and sucessfully backed up to an Airdisk. However, when I launch SD now I can't figure out how to access the Airdisk again. The instructions say SD should mount it automatically, but nothing happens for me.

dnanian
11-03-2011, 09:44 AM
Is the image file listed as the destination?

snoogly
11-03-2011, 04:52 PM
No, there is nothing showing as the destination - and the destination drop down list only shows the local disks on the computer.

dnanian
11-03-2011, 05:06 PM
Right, so you'll choose "Disk Image..." in the destination pop-up, then select the image in the standard file panel (even if it's grayed out)....

snoogly
11-03-2011, 05:20 PM
OK, I got it now. I had to drill down through several destination layers before seeing the destination image I needed, but I got there in the end.

I was just a bit confused, because the manual says SD would mount the destination automatically.

dnanian
11-03-2011, 05:24 PM
It should once it's been saved...

cbrandt
11-21-2011, 03:54 PM
I thought this thread had a solution for a problem I emailed you about in June of 2010 but I'm not sure that it is working properly.

My original problem was that I had to first use Finder to access the Time Capsule and then the external drive folder containing the sparse image to get SD to work. And often even that is not enough and I need to reboot the computer before I use the Finder trick. IF I don't the SD backup fails and I get the message: "failed to mount idisk backup".

I recently spent hours trying to teach myself automater to do the finder trick every night before backup time, but even though it would work if run manually, I could never get it to run as a ICal entry.

So I just found and tried the solution in this thread for my idisk backup which normally backs up in less than 1 minute. Now it takes over an hour. And in Finder I see an idisk backup.dmg file along with my idisk backup.sparseimage file. Fine, it worked. But when I repeated the backup it took another hour.

I saw that there was another forum thread about the sparseimage file being changed to a dmg file but that ended before any explanation as to what was happening.

So is my system supposed to create a dmg file each time and take an hour for each backup?

I just ran the idisk weekly the old way by just using COPY NOW and it worked perfectly (in 15 seconds) without the Finder trick. But that might be because SD just ran the 1 hour version of idisk backup so it already knows where the sparse image is located. :(

dnanian
11-21-2011, 04:10 PM
Sounds like you selected a read-only image in the destination pop-up, rather than a sparse image or bundle.

cbrandt
11-21-2011, 04:36 PM
Now I'm not sure what I did the second time when it took an hour, but I just tried using COPY NOW from the scheduled copies page and it worked perfectly without the FINDER trick. I see in the FINDER that the dmg files have not had their modified dates changed while the sparse image files have so maybe it is working fine now.

So do I keep these DMG files? I have one for my idisk backup which is scheduled to run daily and another for my idisk monthly.THey were created when I used the solution in this thread. THe idisk weekly worked the old way, directly from the scheduled copies COPY NOW without creating a dmg file. THe dmg files are 1.75GB each for a small idisk file. I can't imagine how big the files will be when I backup my 280GB Macbook pro which is what takes the most space on the external disk attached to the time capsule. I'll try that one overnight.

dnanian
11-21-2011, 05:19 PM
The DMG is because you have a read-only image - assuming you didn't accidentally turn on the "Image" option in the Advanced tab.

cbrandt
11-21-2011, 05:36 PM
Here is exactly what I did:
I already found my idisk name in the "copy" field so I clicked on the selection bar(can't remember what else it is called) in the empty "to" field and selected Disk Image.
THat opened up a save dialog box showing me all the different files on my TC external disk. Even though all the sparse image files are greyed out I selected the idisk backup.sparseimage file which showed that it was a read only disk image.

AHHA Now I see what you are talking about. I should have changed it to either a read/write sparse bundle or image. BUt which one? you didn't mention this step in your instructions in the beginning of this thread.

GReat, so now do I want a bundle or an image? ANd can I delete the dmg files?

dnanian
11-21-2011, 05:57 PM
No, it didn't "show" it was a read-only image, you had read-only selected. You need to switch it to a read/write image (which is what you had before). That should work.

cbrandt
11-30-2011, 02:11 PM
I am going to continue this here since I am still having problems with my SD backups to sparse image files on an external drive connected to my Time Capsule.

I have had so many problems with SD in the past week that I decided to start over with the external drive attached directly to my imac. I erased the drive, even renamed the single partition and used the directions above to recreate the sparse image files. I have 3 sparse images to backup my idisk; "idisk daily backup.sparseimage", and one for weekly and monthly. I also have a sparse image file for my mbp but it takes so long to backup to it that the idisk ones are great for solving this problem.

I used to call my idisk daily backup "idisk backup" and that still appears as a destination for my SD backups even though there is no file with that name anymore.

WHen I reboot and try to COPY NOW from the scheduled copies page and run smart update idisk daily backup from my idisk I get "failed to mount idisk daily backup"
HERe is the log:
| 12:39:08 PM | Info | SuperDuper!, 2.6.4 (89), path: /Applications/SuperDuper!.app, Mac OS 10.7.2 build 11C74 (i386)
| 12:39:08 PM | Info | Started on Wed, Nov 30, 2011 at 12:39 PM
| 12:39:08 PM | Info | Source Volume: cwbrandt, mount: /Volumes/cwbrandt, device: /dev/disk2s2, media: Apple sparse bundle disk image, interconnect: File Virtual Interface, file system: "Case-sensitive Journaled HFS+", OS: N/A, capacity: 10.77 GB, used: 1.76 GB, directories: 322, files: 1629, ejectable: YES, ACLs: Enabled
| 12:39:08 PM | Info | Target Image: /Volumes/mbp superduper2 backup via TC/idisk daily backup.sparseimage, name: idisk daily backup
| 12:39:08 PM | Info | Copy Mode : Smart Update
| 12:39:08 PM | Info | Copy Script : Backup - all files.dset
| 12:39:08 PM | Info | Transcript : BuildTranscript.plist
| 12:39:08 PM | Info | PHASE: 1. Prepare to Copy Files
| 12:39:08 PM | Info | ...ACTION: Preparing cwbrandt
| 12:39:08 PM | Info | ......COMMAND => Verifying the integrity of volinfo.database
| 12:39:08 PM | Info | volinfo.database OK
| 12:39:09 PM | Info | ......COMMAND => Enabling permissions on cwbrandt
| 12:39:10 PM | Info | File system user/group ownership enabled
| 12:39:10 PM | Info | ......COMMAND => Verifying that permissions are enabled for cwbrandt
| 12:39:10 PM | Info | Permissions on '/Volumes/cwbrandt' are enabled.
| 12:39:10 PM | Info | ...ACTION: Mounting idisk daily backup
| 12:39:10 PM | Info | ......COMMAND => Preparing idisk daily backup
| 12:39:12 PM | Info | hdiutil: create failed - No such file or directory
| 12:39:12 PM | Error | ****FAILED****: result=256 errno=0 (Undefined error: 0)


I can a get it to work only if I then open time capsule and click on the external drive to show the file names of the various sparse image files. ANd sometimes that doesn't even work and I need to reboot and start over. Needless to say that most of my overnight backups do not work because of this problem.

I emailed you in July 2010 about this problem but you couldn't help me with it then and I have just been getting more and more frustrated with it. I tried creating an automater workflow as a calendar item to run every night before SD would run but even though I could get it to work within automater, it never worked at night for me. THis was my first automater workflow so I probably didn't do it right.

ANyway, I can't believe I am the only one who has this problem and I am hoping you can tell me what to do.

dnanian
11-30-2011, 02:14 PM
The host volume for the image is mounted by resolving an alias to the file. The system should mount that image, using credentials in your keychain.

Note, though, that Lion sometimes looks for those credentials in the system keychain, rather than your user keychain. If you copy them using Keychain Access, from your login keychain to the system keychain, that may resolve the problem.

But if you have to reboot to get a mount to be recognized, there's something more significant going on - perhaps your mount is failing, or mounting to a different location?

cbrandt
11-30-2011, 03:04 PM
no luck. I copied from login keychains to system keychains 4 lines called cindy's Time capsule which were airport disk passwords and 1 also called cindy's Time Capsule but it was an airport base station password. I rebooted and it still didn't work until in Finder I opened cindy's time capsule and then opened MBP superduper2 backup via TC to show the sparse images.

Is it possible that I need to partition the MBP superduper2 backup via TC drive so each sparse image is in a separate partition?

dnanian
11-30-2011, 03:56 PM
Definitely not a partition issue, no.

Mount the image and point to the volume, rather than the image file. Does *that* work?

cbrandt
11-30-2011, 07:12 PM
Mount the image and point to the volume, rather than the image file. Does *that* work?

Sorry, not sure what you mean. Do you mean in SD to select "disk image" as the destination, and then, in the Save pop up select the ext drive name without opening it to see the sparse image files? THat can't be because save is greyed out and the save as field has that leftover "idisk backup" that is no longer used and I can't seem to remove. And if I open the ext drive that contains the sparse image files until I select one of them I still have that "idisk backup" in the save as field. So I decided to let it go to idisk backup instead of selecting one of the ones I already had. It just created a new idisk backup sparse image file on the external drive along with the daily, weekly and monthly ones.

I know it does work when I do this the way you mentioned in the earlier posts on this thread. I open my time capsule, then open the drive, then click on the greyed out sparse image file I want, select read/write "sparse image" and save. THis is how I created the sparse image files. IF I do it this way, I even have the name of the sparse image file I just updated still in the choices for destination on the copy page. ANd the "idisk backup" choice is gone. But something happens to it, maybe after I do other backups, always after rebooting, when I lose the other sparse image files and only have "idisk backup" as a choice for destination along with any directly connected external drives, my idisk name and disk image.

I've been trying different things. If I launch the backup from the scheduled copies page, as soon as the backup to my daily, weekly or monthly idisk sparse images are done the destination field in the copy page changes back to "idisk backup".

Right now it is working every time I manually run the scheduled pages COPY NOW. It still doesn't work after rebooting and I won't know if it works for the scheduled copies in the middle of the night until tomorrow.
Any other suggestions?

dnanian
11-30-2011, 07:56 PM
Are you saving the settings for the different images? I'm confused about the problem you're having, since you originally basically said it won't mount the Time Capsule, but now you're saying it's not even remembering the image.

Try saving the different image choices (grayed, I know) with File > Save, then load them with File > Load and see if that works.

cbrandt
11-30-2011, 09:56 PM
So I tried saving the SuperDuper! copy/to dialog which I saved as idisk "daily backup run" in Saved Settings. Now when I restart SuperDuper it opens that dialog but after rebooting it still doesn't work.

I wonder if this is the problem.
SuperDuper is no longer opening at Login and now when it opens I am getting a message box :
"THere was a problem connecting to the server "cindy's Time Capsule".
The share does not exist on the server. Please check the share name, and then try again. OK"

Could this be the problem? I used to get this all the time but haven't gotten it today until after rebooting and restarting. I thought it had something to do with my Time Machine backup which works fine.

dnanian
11-30-2011, 10:01 PM
Well, is that the name of the share? It must have been at some point...

cbrandt
11-30-2011, 10:18 PM
THat is the name of the time capsule which appears in my
Finder under SHARED. THere is also another item called cindys-time-cap which comes and goes. Clicking on it gets "Connection Failed". I have wondered about this but didn't know who or what to ask about it.

dnanian
11-30-2011, 10:35 PM
I don't know what that might be, Cindy. Certainly, if you tell SuperDuper! to not remember drives (preferences) it won't prompt for that at startup.

You don't get that when loading settings, right?

cbrandt
11-30-2011, 11:10 PM
You are correct. If you change the preference to not remember the drives it does not give me the error msg. BUt that doesn't solve my problem since the backup either from the scheduled copies dialog or loaded onto the SUperDuper! dialog still gets the "failed to mount idisk monthly backup" and doesn't work.

I will have to research this on apple's support site with the time capsule experts. I don't have any problem accessing any of my other external drives. I even now have my imac and air using another external drive connected to the TC for time machine so my MBP can have the whole TC 1TB for itself. I don't really care about the idisk backups anymore. I was just using them as a test to find the problem because they are so small and are finished backing up in 1 minutes or less. This mbp SD backup is the important backup and that can take an hour so it is hard to test that one.

It occurred to me that since I can get often this to work if I just do my Finder trick and open that external drive to show the sparse image files before I run SD, that maybe I could use a copy script or something to access the files at the start of the scheduled backup. I have 0 experience with scripts but would this work? THat is what I unsuccessfully tried to do with automater.

dnanian
11-30-2011, 11:21 PM
Try pointing to the *mounted* (open) volume instead, rather to the image file.

cbrandt
11-30-2011, 11:57 PM
It might be because it is late and I am tired, but I don't know what you mean.

cbrandt
12-01-2011, 12:42 AM
I don't know if this is what you meant, but I tried just opening cindy's Time Capsule which shows all the attached ext drives but not opening the actual drive to show the image files and that made no difference. WHen I did open the ext drive to show the sparse images it did work. I do notice that the cindys-time-cap is not there either time so maybe this doesn't matter.

I also just ran SD on my mbp for the full SD backup and it failed the first time until I did my Finder trick and showed the sparse image files.

dnanian
12-01-2011, 09:28 AM
No. What I mean is that, in Finder, double-click the image so it opens. That will show a volume (the 'virtual disk' from the image) in Finder (and in SuperDuper). Select that as the destination for the backup rather than the image file.

cbrandt
12-01-2011, 11:14 AM
Opened sparse image and saw destination under devices. SD does work and after daily backup, monthly and weekly work too.


THe strange thing is if I do what I used to do to make it work, just accessing sparse image in Finder without opening it, idisk daily now got quick failure, just a wink and it is over without the countdown or any message but with the log shown below. BUt then the monthly and weekly backups worked fine while daily continued to just blink and fail. THat is a new wrinkle but it doesn't happen when I open the sparse image so it might not matter to me, but I thought you should know about it.


Hopefully the destination will stay open in the Finder devices list and if I remember to do this whenever I reboot it will work overnight. I'll let you know.

dnanian
12-01-2011, 11:30 AM
It should automatically mount. You should set the "after copy" action to "eject".

cbrandt
12-06-2011, 02:30 PM
I thought it worked for at least 1 day but I rebooted the imac and now it doesn't work. Same error messages. I thought that the eject option selected would stay with the scheduled copy but it doesn't. when I open ON SUCCESSFUL COMPLETION I see "do nothing". I have the same problem with the mbp which goes to work with me so when I return it has lost the "volume (the 'virtual disk' from the image) in Finder" and I have to go back and open the sparse image to access it again.
ANy other suggestions?

dnanian
12-06-2011, 02:41 PM
I don't see how you could have the same error messages if you switched to pointing at the volumes, rather than the image files - and you can't check "On successful completion" in a scheduled copy, because you're not looking at the schedule...

cbrandt
12-06-2011, 04:14 PM
here is what I did. I will repeat everything one more time to see if it makes a difference this time.
In Finder I opened the sparse image file so that "idisk daily backup" is listed under DEVICES.
I deleted the old scheduled backup for idisk dailybackup and created a new one scheduling it every night with the option to eject idisk daily backup "on successful completion".
I ran copy which it did successfully.
I then ran the weekly and monthly backups successfully as well since they usually run if another of the sparse image files was opened previously, probably because Finder is still showing their sparse image files. I did not change their option to eject because their sparse image volume wasn't listed on the choices of what I could eject "on successful completion.

rebooted
Tried to run idisk daily backup from scheduled copies and got same "failed to boot idisk daily backup" preceded with the same error message; "there was a problem connecting to the server"cindy's time capsule the share does not exist……."

I have the same problem on my mbp but that backup takes over 30 minutes so it is not as easy to test and retest quickly. But that is the backup I really care about since I take that computer back and forth every day and sometimes forget to plugin the external drive or to access the sparse image before I go to sleep.

dnanian
12-06-2011, 04:30 PM
I'm afraid I don't have any other suggestions. Since the OS seems to be unable to remount the share, it's hard for us to proceed with the backup.

Perhaps you can set up a login item to mount the share when you log in?

cbrandt
12-09-2011, 11:35 AM
login item doesn't work. Time capsule and ext disk name are greyed out. It allows me to add the sparse image but when I restart I get the same "there was a problem connecting to the server"cindy's time capsule the share does not exist……." and the kind listed in the login items list changes to unknown.
ANy other ideas? I tried the Automater route as a calendar item to open every night at midnight, but that didn't work. I will try to see if there was something wrong with my Automater instructions.

dnanian
12-09-2011, 12:29 PM
It's curious that both Apple's own code and our attempt to mount the Time Capsule don't work, Cindy - that confirms that this seems to be an Apple problem.

Do you have a password set for the share?

cbrandt
12-23-2011, 10:38 PM
No I do not have a password.

I have been waiting for some help from the apple discussions list however there have been 0 replies after 68 views so far to my question.
And I have been trying to get Automator to work for me to handle this but I've had no luck so far.

I have written a simple automator workflow to open the sparse image file. It works when I first create it and run it within automator but fails if I save it as an ical event, or save it as an application and run it later, or even if I save it as a workflow and run it with Automator runner. Actually the only time it works is when I first create the workflow. It even fails if I keep the same workflow in Automator open and try to run the next night. I think just setting up the "Get specified Finder items" works and so when I first run it I get a successful run but not the next day. All other times the sparse image is not loaded into DEVICES and when I try to run the SuperDuper backup I get that same blasted error message:

"There was a problem connecting to the server"…....'s Time capsule". The share does not exist on the server. Please check the share name, and then try again."

So I am unable to find any help with Automator and don't know anything about Apple Script so I guess I have to give up.

THank you for your help. I may try to call Apple and get help but I am not very optimistic about that happening either.