PDA

View Full Version : Could not locate the Destination volume


CrashDavis
09-17-2011, 01:19 PM
I create a clone in an encrypted sparsebundle on a NAS daily. Since I've upgraded to Lion, the SuperDuper schedule runs, but it says it can't find the destination volume.

For some reason, it can't find the sparsebundle on the NAS. Strangely, this is only the case with encrypted sparsebundles. Testing with an unencrypted sparsebundle works perfectly.

I've been using SuperDuper since Leopard with this exact setup. Same bundles, same schedules, same NAS. It has worked great! But there seems to be some issue now, and I can't figure it out.

Hopefully you guys can offer some advice. :-)

Thanks.

dnanian
09-17-2011, 02:02 PM
Please send the log showing the error in using the "Send to shirt pocket" button. Thanks.

CrashDavis
09-17-2011, 02:08 PM
There isn't much in the log:

| 11:10:08 AM | Info | SuperDuper!, 2.6.4 (89), path: /Applications/SuperDuper!.app, Mac OS 10.7.1 build 11B26 (i386)

| 11:10:08 AM | Info | Started on Sat, Sep 17, 2011 at 11:10 AM

| 11:10:08 AM | Error | The automatic copy aborted because SuperDuper! could not locate the Destination volume named Cosmos1.

dnanian
09-17-2011, 02:13 PM
Well - have you tried deleting and recreating the schedule? This isn't talking about the NAS, but rather the actual volume it's copying to (which seems like it was already mounted when you set up the schedule).

CrashDavis
09-17-2011, 02:32 PM
Yes, I've deleted and recreated the schedule. I actually did that several times last night and then again this morning. I usually mount the destination volume to setup the schedule, and then it mounts it when it runs. But not in this case.

Just for grins, I've also rebooted the NAS, re-mounted the volumes where the sparsebundles live, checked the cron jobs, and completely removed and reinstalled SuperDuper and all related files.

dnanian
09-17-2011, 02:35 PM
Why aren't you selecting the bundle file, vs. its mounted volume?

CrashDavis
09-17-2011, 02:53 PM
I am selecting the bundle file. The bundle is named Cosmos1. It's on a volume named Backup which resides on the NAS.

CrashDavis
09-17-2011, 02:54 PM
Wait, I see what you're saying. Give me a second to try that. :-)

dnanian
09-17-2011, 03:02 PM
Also - what NAS is this? If it's not an Apple NAS, it's unlikely that it properly supports sparse bundles. I assume that creating a bundle directly on that NAS failed? If so - you should be using a sparse image, not a bundle.

CrashDavis
09-17-2011, 03:04 PM
Hmm...how do I select a bundle? Clicking disk image in the destination dropdown only allows me to create a new bundle, not select one.

CrashDavis
09-17-2011, 03:06 PM
It's a Readynas NV+. I've had it for years. Works great with sparsebundles. Creating bundles works perfectly. The only problem I've ever had is this one. But I suspect it's user error of some sort.

dnanian
09-17-2011, 03:10 PM
Even though the bundle is dimmed you can pick it. Make sure you've selected the sparse bundle type in the drop-down.

CrashDavis
09-17-2011, 04:00 PM
Thanks, that seems to mostly work. The only issue is that every other time it hangs when trying to mount the bundle under (1. Prepare to copy files). It'll sit there forever if I don't stop it.

dnanian
09-17-2011, 04:05 PM
Sounds like you need to ensure the password is in the keychain.

CrashDavis
09-18-2011, 01:27 AM
The password is in the keychain. I even deleted it and added it back by manually opening the bundle. Plus, it will mount if I run push the Copy Now button manually. It just won't mount if I run the same job with the scheduler. Just hangs on that step.

dnanian
09-18-2011, 03:35 PM
Try adding the password to the system and user keychains. (I'm certain it's stuck on the password prompt... that's the only reason it'd hang there.)

CrashDavis
09-18-2011, 03:46 PM
Adding it to the system keychain seems to have made it work. Would anyone using this computer have access to that now?

dnanian
09-18-2011, 04:09 PM
That's a good question - not without being able to unlock that keychain, I don't think.