PDA

View Full Version : Failed clone: "type 8 due to error 28"


TXCiclista
09-14-2011, 11:15 AM
It's becoming something of a common thing to find online reports of SuperDuper! kicked back the type 8, error 28 message, and I've had it myself.

"| 09:06:31 AM | Error | SDCopy: Error copying /Applications/iPhoto.app/Contents/Resources/TellusMapVectors.db to /Volumes/Cara's iMac Clone/Applications/iPhoto.app/Contents/Resources/TellusMapVectors.db of type 8 due to error 28: No space left on device"

And no, it's not damage to the source volume, as I've run repair disk from the local recovery partition as well as from install disks. Even DiskWarrior checks out fine. CCC has no problems handling this, so I'm beginning to think the problem is not with Apple, but with SP.

Anyway, just thought I'd post and see if I can get some kind of troubleshooting advice that's NOT "the problem's with your computer or Apple's OS, not our software." It's obviously an import-enough file that I won't be deleting it or excluding it from backups.

dnanian
09-14-2011, 01:32 PM
Please send your log in with the "Send to shirt pocket" button. Almost always the problem with Lion is that it has returned an invalid error code (which comes back as "No space"), but the real problem can be determined to be a damaged file on the source or an error writing to the destination.

If you send in your log I'll be able to determine which it is.

rwross
10-01-2011, 11:56 PM
I have gotten this same error and have submitted my error log...

I've even erased my target drive and tried again with the same problem.

Hope you can help me figure this out...

Ward
10-23-2011, 06:12 PM
I just sent my log file to Shirt Pocket with this description:

My nightly Smart Update of my 1 TB boot drive to an external 1 TB drive failed last night due to "error 28: No space left on device."

The source drive has 59.72 GB free. But the clone volume currently has only 1.58 GB free. In addition, on the clone volume, my home/Documents folder has only 1 PDF file. On the source volume, the corresponding Documents folder is 264.91 GB. This looks serious.

The error occurred attempting to copy an 81 GB VMware Fusion virtual machine file. I've been having problems with that XP Pro virtual machine since upgrading from Fusion 3 to 4 two days ago. SuperDuper! didn't complain the first night after the upgrade.

-- Ward

dnanian
10-23-2011, 07:05 PM
Ward, your drive is quite likely actually filling, but I'll have to review the log.

Ward
10-23-2011, 08:15 PM
Ward, your drive is quite likely actually filling, but I'll have to review the log.
Thanks, Dave, for your super speedy (better yet, SuperSpeedy!) response.

Since both drives are the same size, and the nearly full clone drive is missing 265 GB of files, it would appear the clone has lost space.

After posting my report, I ran DiskWarrior on the clone to see if a repair would free up any space. Available increased slightly from 1.58 to 1.83 GB. Hmmm.

When I encountered this problem, my first thought was to do a fresh, full backup. I'm holding off in case there's something to be learned from this failure.

-- Ward

dnanian
10-23-2011, 10:16 PM
Yes, the drive really did fill, Ward:

Oct 23 06:10:56 Papa-Bear /3rd party/Utilities/SuperDuper! 2.6/SuperDuper!.app/Contents/MacOS/SDCopy[26835]: writing to output file got error: No space left on device
Oct 23 06:10:56 Papa-Bear /3rd party/Utilities/SuperDuper! 2.6/SuperDuper!.app/Contents/MacOS/SDCopy[26835]: error processing data: No space left on device

The problem is as explained in the Troubleshooting section of the User's Guide: you're running with < 10% free space on the drive, and you made a series of changes that Smart Update couldn't reconcile given the amount of working space present.

Ward
10-24-2011, 01:25 AM
Thanks, Dave, for checking into my Smart Update failure and pointing out the Troubleshooting tip. Too often I forget to RTFM. Sigh. :o

I've freed 10% of my boot drive and launched a full backup onto my clone drive.

-- Ward

astrodog
11-01-2011, 05:56 PM
I had a backup fail with the same error the other night - I reformatted the destination drive, and tried to do a manual drag-drop copy of the folder it choked on.... the same file that stopped SD! stopped the copy, with an error saying the file had data that couldn't be read or written. So I assume a corrupted file can lead to this error too.

Is it possible to make SD! try and continue the clone in this situation - and perhaps show a warning that x files could not be copied??

dnanian
11-01-2011, 10:09 PM
No, we always stop on error. I explain why in the "I/O Error Recovery" post at the Shirt Pocket blog.

Ward
11-01-2011, 11:54 PM
No, we always stop on error. I explain why in the "I/O Error Recovery" post at the Shirt Pocket blog.

Here's a direct link to Dave's excellent blog post: "I/O Error Recovery" (http://www.shirt-pocket.com/blog/index.php/comments/i_o_error_recovery/)

I especially like his concluding paragraph.

-- Ward

dnanian
11-02-2011, 11:50 AM
I'm glad you enjoyed it, Ward - and hope astrodog did as well.