PDA

View Full Version : SD Error copying /.MobileBackups


fq360
07-24-2011, 06:33 PM
I've just upgraded to osx lion and have updated SD to 2.6.4

whenever i try to backup it gives the following error :

Error copying /.MobileBackups/Computer/2011-07-22-210007/Volume/Users/simon-cooper/.Trash/Install Mac OS X Lion.app/Contents/SharedSupport/InstallESD.dmg to /Volumes/superduper boot image/.MobileBackups/Computer/2011-07-22-210007/Volume/Users/simon-cooper/.Trash/Install Mac OS X Lion.app/Contents/SharedSupport/InstallESD.dmg of type 8 due to error 28
| 10:20:54 PM | Error | SDCopy: Error copying /.MobileBackups/Computer/2011-07-22-210007/Volume/Users/simon-cooper/.Trash/Install Mac OS X Lion.app/Contents/SharedSupport/InstallESD.dmg to /Volumes/superduper boot image/.MobileBackups/Computer/2011-07-22-210007/Volume/Users/simon-cooper/.Trash/Install Mac OS X Lion.app/Contents/SharedSupport/InstallESD.dmg of type 8 due to error 28: No space left on device

dnanian
07-24-2011, 06:58 PM
This is damage to the source volume. Boot to your recovery volume, use Disk Utility to repair the source (internal) drive with the right-hand repair button (not repair permissions), then boot back and give it another try.

fq360
07-24-2011, 08:31 PM
how can this be problem with source volume. my MacBook is only 1 week old! has new install of osx lion?
I normally save my SD backup on same volume as time machine. I thought this may be the issue so I plugged external drive into time machine but still same issue
I know lion has backup feature which runs along side time machine to backup whilst on the move, and then copy back to time machine once connected at home again. could this be the issue?

fq360
07-24-2011, 09:56 PM
Also why is SD trying to copy my trash?

dnanian
07-24-2011, 11:25 PM
Trust me. Do the repair as suggested. :)

We're not copying your trash in this situation, as such. We're copying your snapshot, and Time Machine copied your trash.

fq360
07-25-2011, 07:48 AM
ok will do so. I thought SD was supposed to not copy the mobilebackups

dnanian
07-25-2011, 10:04 AM
Why would we not copy that folder? I thought it was probably a good idea to copy the folder, since it's where local snapshots are stored...

fq360
07-25-2011, 10:52 AM
I have done repair as advised but still same. been into local apple store spk with genius who advised issue with SD diagnostics showed drive ok

dnanian
07-25-2011, 03:10 PM
The genius is wrong. We've had a number of people report this issue, and a repair with Disk Utility has fixed it.

Unfortunately, under Lion, some of the file copy calls are always returning an invalid error when they encounter problems. That error is interpreted as "Disk Full", even when it's not. We reported this to Apple, but we don't know when they're going to fix it.

But if you repair the drive - not permissions, and not verify, but repair with the right-hand buttons - this file should be fixed. If not, you can exclude .MobileBackups if you'd like, using the the steps in the User's Guide. (But that shouldn't be necessary.)

fq360
07-25-2011, 04:00 PM
i switched off time machine and proceeded to backup which completed successfully, i have now switched it back on and will try another backup later this week to test, i didn't need the backups so wasn't bothered about losing them, but at least now i have a complete backup.

what is the best way to test the backup to see if it boots ok

thanks

fq360
07-25-2011, 04:23 PM
forgot to post after i repaired the disk this was the outcome:

Verifying and repairing partition map for “TOSHIBA MK5065GSXF Media”
Checking prerequisites
Checking the partition list
Checking for an EFI system partition
Checking the EFI system partition’s size
Checking the EFI system partition’s file system
Checking all HFS data partition loader spaces
Reviewing boot support loaders
Checking Core Storage Physical Volume partitions
Updating Windows boot.ini files as required
The partition map appears to be OK

but still i had the error in copying

dnanian
07-25-2011, 04:49 PM
That looks like a verify, not a repair. Did you start up from the recovery partition and actually repair?

fq360
07-25-2011, 05:05 PM
no repair from the disk utility

fq360
07-25-2011, 05:17 PM
i booted into recovery partition and repaired using disk until, it came back as bit block error 104.... should be 105.... so repaired orphaned file or something, also my backup didn't show as bootable, it wasn't selectable as bootable image,

I've checked my time machine partition which is showing as mac os journaled, case sensitive, could that be the issue with the image not showing as bootable as my image is stored alongside my TM

thanks again

dnanian
07-25-2011, 05:25 PM
OK. So now you have done what I suggested and it did find an error. Good. Did you repeat the copy successfully? Does it show up as bootable in the startup disk preference pane?

fq360
07-25-2011, 05:35 PM
i haven't tried to recopy as yet, startup disk shows no bootable image apart from internal disk, what am i doing wrong?

dnanian
07-25-2011, 06:16 PM
You need to re-copy: your backup hasn't been fully updated. (Also, the backup drive has to be properly partitioned, which I'm assuming you've done but I don't know - it's covered in Help > Frequently Asked Questions, top question.)

fq360
07-25-2011, 06:24 PM
ok will try now and recopy and post back

thanks for help so far really appreciated :)

i have time machine connected via wifi which is formatted mac os journaled (case sensitive) and also another drive connected to time machine via usb which is mac os journaled (guid)

fq360
07-25-2011, 08:39 PM
ok so i connected my external hard drive to my laptop recopied over the existing backup and still no start up disk showing in pref panes,

the disk is formatted correctly using mac os journaled(guid) not sure whats going wrong, although at least this time the backup finished correctly without turning time machine off so at least thats working now, just can't get it to show up as startup disk

dnanian
07-25-2011, 08:45 PM
Please send your last log into support using the send to shirt pocket button (and error during copy as the issue type). Thanks.

fq360
07-26-2011, 05:52 AM
I don't have a last log as the copy finished correctly. it just won't show as a startup disk?
thanks

dnanian
07-26-2011, 07:52 AM
Sure you do. Window > Show Log.

freestef
07-26-2011, 08:06 AM
Hello, although this thread is from March, I just bought a new MacBook Air (with Lion installed) and tried to clone it twice with an SD error. That's the reason why I looked for thread on this subject.
Anyway, my SSD is fine according to Disk Utility.

In despair, I tried to clone it with CCC and I got no error and the clone is indeed bootable.

So why SuperDuper can't do it ???

Moreover, I tried the "Send report to ShirtPocket" but could not activate the send button. There is an "Account" field in which I tried to paste my forum account, email address and serial number with no success!

Please, understand my frustration.
Cheers, Stéphane

fq360
07-26-2011, 09:45 AM
my bad - i have sent log

thanks again

dnanian
07-26-2011, 10:38 AM
Please send in your log by copying and pasting and sending to support -at- shirt-pocket.com, Stephane.

fq360
07-26-2011, 10:43 AM
hi thanks for the reply email but i don't understand the difference between bundle and drive?

the image is stored on a drive? or am i just being thick!!:)

dnanian
07-26-2011, 10:54 AM
A bundle is a disk image file. It's a virtual drive, and won't be bootable.

A real drive is a physical partition on an actual drive connected to your mac.

You can't boot from a bundle, because it's not real - it's not "visible" at startup time, because it's a 'simulated' drive.

If you want a bootable volume, you have to write it directly to a properly partitioned drive. That will erase other things on that partition, so be aware: you should dedicate that volume (partition) to the backup.

fq360
07-26-2011, 11:24 AM
ah i got you now, so if i connect my external drive directly to MBP it will create a bootable disk

if i create a backup over network to Time machine this would be virtual image and only be able to restore via disk utility from recovery disk.

therefore is it wise to do a bootable copy and virtual image on both external drive and time machine incase one backup fails?

thanks again for your patience really appreciated :D

dnanian
07-26-2011, 11:26 AM
No, not just connect. You have to back up directly to it as well, not to an image. And correct: you can only boot from an image once you've restored it.

fq360
07-26-2011, 11:39 AM
managed to complete successfully and booted up from backup.

great many thanks:)

loopkid
11-01-2011, 06:14 PM
Just a little follow-up on this topic for anyone experiencing the "type 8 due to error 28: No space left on device" error message.

Trust Dave, he knows what he's talking about. I've also had the error when doing a Backup with SuperDuper. As there where >30 GB left on the target volume I figured it had to be an erroneous error message. I tried a backup with CCC which didn't abort, but resulted in the following output:

11/01 05:22:37 rsync: send_directory: readdir("/Library/Dictionaries/Shogakukan Progressive English-Japanese Japanese-English Dictionary.dictionary/Contents/image"): Input/output error (5)
11/01 05:22:44 IO error encountered -- skipping file deletion (10001)
11/01 09:34:54 Detected input/output error
11/01 09:34:57 rsync: send_files: read errors mapping "/Users/stefan/Library/Mail/*********/194023.partial.emlx": Input/output error (5)
11/01 09:35:27 rsync: send_files: read errors mapping "/Users/stefan/Library/Mail/*********/194023.partial.emlx": Input/output error (5)
11/01 09:35:35 ERROR: "/Volumes/Backup HD/Users/stefan/Library/Mail/*********/194023.partial.emlx" failed verification -- update discarded. (10001)


Then as Dave suggested I booted from another volume and tried a disk repair. Unfortunately the source volume was so fucked up that it wouldn't even mount anymore after rebooting.

Here's what the Disk Utility GUI said:

2011-11-01 14:44:56 +0100: Disk Utility started.
2011-11-01 14:45:14 +0100: Verify and Repair volume “MacBook Pro HD”
2011-11-01 14:45:14 +0100: Starting repair tool:
2011-11-01 14:45:16 +0100: Checking file system2011-11-01 14:45:16 +0100: Checking Journaled HFS Plus volume.
2011-11-01 14:45:17 +0100: Checking extents overflow file.
2011-11-01 14:45:17 +0100: Checking catalog file.
2011-11-01 14:46:45 +0100: Invalid node structure
2011-11-01 14:46:45 +0100: The volume MacBook Pro HD could not be verified completely.
2011-11-01 14:46:45 +0100: Volume repair complete.2011-11-01 14:46:45 +0100: Updating boot support partitions for the volume as required.2011-11-01 14:46:46 +0100: Error: Disk Utility can’t repair this disk. Back up as many of your files as possible, reformat the disk, and restore your backed-up files.2011-11-01 14:46:46 +0100:
2011-11-01 14:46:46 +0100: Disk Utility stopped repairing “MacBook Pro HD”: Disk Utility can’t repair this disk. Back up as many of your files as possible, reformat the disk, and restore your backed-up files.


Here's what the Disk Utility CLI said:

$ diskutil repairVolume disk0s2
Started file system repair on disk0s2 MacBook Pro HD
Checking file system
Checking Journaled HFS Plus volume
Checking extents overflow file
Checking catalog file
Invalid node structure
The volume MacBook Pro HD could not be verified completely
Volume repair complete
Updating boot support partitions for the volume as required
Error: -69845: File system verify or repair failed
Underlying error: 8: POSIX reports: Exec format error


I tried DiskWarrior, but it gave me a "The new directory cannot replace the original directory because of a disk malfunction". I then did a surface test with Tech Tools Pro and it found 3 defect blocks. I strongly suspect that these defect blocks caused the SuperDuper backup to fail.

Stefan

mmurray
11-01-2011, 09:37 PM
Just another data point. I had the same problem and the recommended repair fixed it. Thank you very much.

A note for those using File Vault under Lion. If you boot from the Recovery Disk and go to Disk Utilities your internal HD is greyed and you can't repair it. This was a bit scary when I first saw it but on the tool bar above where it normally says "Mount" there is an "Unlock" icon. Click that and you get to enter your File Vault password.

Michael

drmoss_ca
11-03-2011, 05:31 PM
I had the same problem today doing my daily SD backup of a MBP with an internal SSD. Same Trash file - in /.MobileBackups/Computer/ and same error about the disk being full (the backup disk is 1TB and the internal SSD is 150GB). It must be something corrupted in the local snapshot, but I am unable to delete the damaged file, even if I log in as root. I made a script for SD to ignore that folder and the backup completed fine. Some thoughts:
- can you have a bad block in an SSD?
- I thought portable Macs only did the local snapshot thing when their TM disk was unavailable. This one lives plugged into a FW disk for TM.

Chris

dnanian
11-03-2011, 05:36 PM
Yes, I'd just ignore the folder if you're having trouble (but if you temporarily turn Time Machine off using its preference pane, it'll clean up .MobileBackups).

SSDs can have bad blocks, but that's not necessarily what's going on here.

I don't think we really know when TM does its local snapshots. It's clearly not just when the TM drive is unavailable, though.

drmoss_ca
11-03-2011, 05:40 PM
I'll try turning off TM tomorrow when I go back to the office, and then try a full SD backup. If it works, I guess I'll just have to remember to do it each time the local backups get corrupted or whatever it is that is happening. It doesn't fill me with confidence that the local snapshots will do any good if they contain errors, but then again, I've got a proper TM backup on the FW disk, and my trusty SD clone, so perhaps it doesn't matter!

Chris

mmurray
11-03-2011, 07:39 PM
There in info here

http://web.me.com/pondini/Time_Machine/30.html

about how to turn snapshots off from the command line. I've no idea how safe that is. I haven't tried it.

Michael

drmoss_ca
11-04-2011, 06:58 AM
I used the command

sudo tmutil disablelocal

in Terminal and a full smart backup works fine now.

Chris