PDA

View Full Version : SuperDuper! not loading on Lion


southwos
07-21-2011, 10:00 AM
Just updated to Lion and when I try to run SuperDuper! it starts to load then just goes away, no message, no error box. Any suggestions?

dnanian
07-21-2011, 10:26 AM
Make sure you've updated to the current release, 2.6.4 (downloadable from the SuperDuper! page).

southwos
07-22-2011, 10:18 PM
Make sure you've updated to the current release, 2.6.4 (downloadable from the SuperDuper! page).

I have downloaded 2.6.4 and it does load now. However now I cannot select other drives. Let me explain, let's say I have a drive named drive1 as my main HD and drive2 as my backup. I select drive1 as my source drive and the drop down shows all my other drives, but the only one that is available to select is drive1 all the other available drives are greyed out.

dnanian
07-22-2011, 11:22 PM
Sounds like they're not formatted for the Mac (HFS+) but are rather formatted for Windows.

southwos
07-22-2011, 11:30 PM
Sounds like they're not formatted for the Mac (HFS+) but are rather formatted for Windows.

No Sir, they are HFS+ drives, I have been using SuperDuper! for at least 4 years and have had no problems. I'm not suggesting this is a Shirt Pocket problem, but maybe a Mac Lion issue. these are two drobo boxes that have been working without issue for the past two years with SuperDuper! Since my upgrade to Lion I have had this issue. I'm just wondering if anyone else has had an issue. I'm willing to try anything to get SuperDuper! to work. I can see and use both Drobo's with Lion, I just cannot select source and target drives like I use to with Snow Leopard.

dnanian
07-22-2011, 11:36 PM
We only disable drives if they:

- Are read-only
- You're running from them (disabled as a destination)
- They're not formatted as HFS+

Otherwise, perhaps you need to try to restart your Mac? That's what I'd try.

southwos
07-22-2011, 11:42 PM
We only disable drives if they:

- Are read-only
- You're running from them (disabled as a destination)
- They're not formatted as HFS+

Otherwise, perhaps you need to try to restart your Mac? That's what I'd try.

How can I check if they have been labeled as read only? I'm running from mac mini built in HD. The two Drobo's are external USB. They must be HFS+ as I have been using them for several years with SuperDuper! One is main drive the other is a backup. Again, no finger pointing, I think this is directly related to the recent upgrade to Lion.

plink53
07-23-2011, 12:53 AM
One quick thing to check. Do a GetInfo on the drive and see if you've checked the Ignore ownership box. I've found that Lion is much stricter on this.

I am running SuperDuper! just fine under Lion with external disks and it sees them all fine. I'm not running Drobo disks however.

southwos
07-23-2011, 01:18 AM
One quick thing to check. Do a GetInfo on the drive and see if you've checked the Ignore ownership box. I've found that Lion is much stricter on this.

I am running SuperDuper! just fine under Lion with external disks and it sees them all fine. I'm not running Drobo disks however.

BINGO, this worked for me. Now everything is back to normal. I never would have thought to look in that area. Thank you so much for your input and involvement in helping me find the answer I needed. Also thank you all for your input. It's a great community that helps everyone.

dnanian
07-23-2011, 08:18 AM
Um, no - we actually require ownership to be on, and turn it on after we run. Perhaps the drive were set up to be read-only for your user?

plink53
07-23-2011, 12:09 PM
Um, no - we actually require ownership to be on, and turn it on after we run. Perhaps the drive were set up to be read-only for your user?

That's what unchecking the ownership box does. "Ignore ownership on this volume" Checking it means to ignore, unchecking is what I believe SuperDuper! used to do under 10.6.8 but it looks like things have changed in Lion. This might be something for you to check and confirm.

I discovered this when installing Lion on an external drive. It installed fine under 10.6.8 but I couldn't boot it under Lion, if fact my Lion computer would not even see the drive when connected by Firewire. It would when connected by USB. I sent the drive back to OWC and they said it was fine. I tested my drive in another housing that I knew worked and it wouldn't see it. I finally saw the ownership checkbox, unchecked it and everything is fine. Under 10.6.8, it didn't seem to matter. I could boot off a backup drive that had Ignore ownership checked but not with Lion. Of course, I could be going crazy but I think this is one of those things that's changed in Lion.

dnanian
07-23-2011, 12:11 PM
Sorry, reversed the sense of your comments. Weird, though - will check. But we don't block volumes for having ownership off (unless that causes that volume to be excluded for the reasons I already listed).

plink53
07-23-2011, 01:04 PM
It is weird and that's what caught me off guard. I can check my other backups running under 10.6.8 and see if they will boot when ownership is checked (ignore). If it does, then I'm pretty sure it won't under Lion.

dnanian
07-23-2011, 01:34 PM
But his issue wasn't whether he could boot from it. It was whether or not it was available in SuperDuper! itself.

plink53
07-23-2011, 02:29 PM
Southwos, Were you able to see the disks on your desktop in Lion? (Depends on how your Finder prefs are set up whether it shows them of not.) If so, please run the following command:

diskutil list

What does your computer see? Try checking the ignore box again and see if the problem returns (SuperDuper! not seeing the drives). If it does, run the command again and compare them. Any differences?

Dnanian, I know Lion is handling disks differently, especially when encrypting them. I have not seen southwos' problem, I seem to always see the drive but I've been using SuperDuper! for so long I might have missed some things. I also wonder if Drobos make any difference with Lion. I hear NAS drives are having some problems.

---just tried checking the ignore ownership box on my backup drive. Unmounted then remounted it. SD still sees it just fine. Unchecked the box to put it back to where it was. The external drive is encrypted and it still asked for the unlock password so once these things work, it might not make any difference if that box is checked (might be ignored).

dnanian
07-23-2011, 03:04 PM
I've got Drobos that I test with, so no, it's not drobos. And I've done these tests too without seeing disabled drives. So I'm not quite sure what's going on here other than what I said before.

southwos
07-24-2011, 08:32 PM
Southwos, Were you able to see the disks on your desktop in Lion? (Depends on how your Finder prefs are set up whether it shows them of not.) If so, please run the following command:

diskutil list

What does your computer see? Try checking the ignore box again and see if the problem returns (SuperDuper! not seeing the drives). If it does, run the command again and compare them. Any differences?

I am able to see and access the drives in finder. I was also able to select ANY source in SD, it's just when I went to select a target I could only select the same drive as the source, the other drives where in the target list, but not selectable.

I tried checking the ignore boxes and SD seems to now have no problems, so I guess everything is back to normal. Should I keep the ignore checked or unchecked?

Lew
08-13-2011, 12:56 PM
I've got Drobos that I test with, so no, it's not drobos.Dave...

I have a Drobo S 2nd generation and I have been advised by Data Robotics support not to use SD! until new firmware is available and installed.

Also, they have a new procedure for setting up Time Machine on Drobo, Drobo S, DroboPro and Drobo B800i outlined here (http://support.drobo.com/app/answers/detail/a_id/610/kw/time%20machine). I'm hoping this is a temporary fix until the new firmware is available, since it reduces Time Machine's functionality by about 90% IMHO.

Lew

dnanian
08-13-2011, 02:01 PM
Um, I think that may be a representative who doesn't know what they're talking about. SuperDuper! works just fine with the Drobo under Lion. We don't interact with their firmware in any unusual way, and the simple fact is we're simply copying files.

If the Drobo doesn't work when you copy files to it, it has very fundamental problems that are exceptionally unlikely.

Note, though, that the iSCSI initiator shipping with the current Dashboard is not fully Lion compatible, and does fail. The ATTO initiator (XTend SAN) works fine though.

Lew
08-13-2011, 03:22 PM
Um, I think that may be a representative who doesn't know what they're talking about. SuperDuper! works just fine with the Drobo under Lion. We don't interact with their firmware in any unusual way, and the simple fact is we're simply copying files.Thanks Dave...

On that note, I'm going to go ahead and begin using SD! again with my Drobo S

Lew

pstoddard61
09-17-2011, 06:20 PM
I have a different problem from the one Southwos described above, but it does fall under the general heading "SuperDuper! not loading on Lion" so I will include it here instead of starting a new thread.

I am running MacOSX 10.7.1 Lion on a 15" PowerBook with a 750 GB Toshiba MK7559GSXF hard drive. I back up to a 500 GB LaCie connected by FireWire (I don't know the actual disk it has in it).

My problem is that when I install SD 2.6.4 and then start it up, everything is greyed out. I cannot access source or target drives. I can access the preferences, but when I try to register the software, I get some text about how it is good to pay etc, but there is no "Buy Now" link to press.

I have used SD with Lion on a 13" MacBook but the problem is only on this 15." I have installed all upgrades including the most recent firmware upgrade (MacBook Pro EFI Firmware Update v. 2.2).

I have tried all the things suggested for Southwos, including restarting. I also repaired permissions. Can anyone suggest other things I can try?

dnanian
09-17-2011, 06:28 PM
Delete the "Saved Settings" folder in Library/Application Support/SuperDuper! (off your Home folder), restart your mac, then try again.

pstoddard61
09-17-2011, 07:02 PM
That was it. Thanks Dave.;) :D