PDA

View Full Version : Some newb questions to get me started


rberry88
08-26-2005, 09:23 PM
I have a 250GB Lacie external FW HD that I want to basically back all the stuff on my main HD up to so I can do a clean install. My questions:

1. I cleared the external HD but would still like to use it in the future to store stuff along with my backups (I plan to do the Smart Update).

A. Should I partition the external HD so one partition is used for backup(s) and the other partition used how I want?

2. When I do a backup and then a clean install, can I just drag and drop folders and applications back to my new clean install? Or can I do a restore so I don't have to take forever dragging and dropping?

3. I don't want to lose any of my email messages that are currently in Microsoft Entourage and Mac Mail, when I back up the drive before the clean install, is there anything special I should do to make sure my emails don't disappear?

Thanks in advance for any help, looking forward to getting on the backup (for ease of mind) path.

dnanian
08-26-2005, 10:07 PM
OK, a few things.

I can't tell what OS you're going to install -- you didn't say -- but I'm going to assume Tiger, mostly because that's the current one. If I'm wrong, please let me know, because some of this advice will be different.

First, why do a clean install? An archive-and-install is awfully close to a clean install, and is a lot easier to recover from. There's usually little reason to do so.

But, let's continue.

If you want to store data as well as your backup, I definitely suggest partitioning the drive into a "backup" and a "storage" partition. That'll keep things nice and separate, avoid errors, and let you use Smart Update.

If you choose to "clean install", you can definitely NOT drag and drop applications back, unless they were drag-and-drop installs in the first place. Your user files can be copied, yes, but apps often have files they've installed in other locations, and it's unlikely you'll find them all.

So... if you *must* clean install, and it's Tiger, let me suggest that -- after you do the backup -- you tell Tiger's automatic migration assistant that you want to migrate, and then point it at the backup drive. All your user settings and applications will be transferred to the new install automatically.

Regarding Entourage: we always suggest that you log out (not shut down) and log back in with Shift down, to prevent login items -- including the Microsoft Database Daemon -- from running. Also, make sure you name the new drive the same as the old one, so that when Entourage runs, everything is located properly.

Hopefully that'll get you going. Let me know.

rberry88
08-26-2005, 10:25 PM
Hmm, sorry, seems I did forget some pertinent info but assumed correctly. I currently have Tiger 10.4.2 installed and an archive and restore would be what I want to do.

I partitioned the external HD to "Backups" and "Storage". I logged out and logged back in while holding the Shift key, no problems thus far. Since I am going to be doing an "archive and install", when I run SuperDuper, do I select "backup all files" or "backup user files"? I'm assuming "backup all files"? but not sure since I'm doing an archive and install.

Thanks for the fast response and sorry if this seems like menial questions, I'm just the type of person that has to know ahead of time, not a big trial-n-error type of person when it comes to all my data.

dnanian
08-26-2005, 10:29 PM
Regardless of how you're going to install, I'd suggest "Backup - all files".

And don't worry about asking questions: they're all worth answering.

rberry88
08-28-2005, 08:40 PM
Okay, I formatted/partitioned the external drive into two partitions (one called storage and the other backups). The backups partition is 110GB, I logged out and logged in holding the shift key down, then I started SuperDuper to backup my main internal drive (Backup - All files) which is 35GB of files. SuperDuper starts just fine but in the top status bar it is just a sliver and the bottom status bar is halfway, It has stayed like this now for 4 1/2 hours, is this normal?

I'm on a G4 iMac 1.25GHz (lamp shade) with 1GB RAM, 80GB internal HDD, SuperDrive.

dnanian
08-28-2005, 09:25 PM
No, that's definitely not normal. Try running the following command in Terminal, and then sending the output to me at the support email address (copy and paste it):

sudo lsof | grep "SVUClone"

At the end, press Return if necessary, and enter your password, then press Return (it won't echo).

Thanks.

rberry88
08-28-2005, 09:55 PM
Should I stop SuperDuper before I type that in the terminal, or do it while SuperDuper is still running?

dnanian
08-28-2005, 09:56 PM
While it's still running.

rberry88
08-28-2005, 10:14 PM
Ok, I typed it in and then my password and it just sits there (for 5 minutes now). I did notice that when I started the backup, it tried to repair permissions on my source drive and it said "error no info found for ./user/share/SC info" or something close to that.

dnanian
08-28-2005, 10:22 PM
And you pressed Return after entering your password? Sounds like your I/O subsystem is quite unhappy, if so.

Are you running anything like anti-virus on this machine?

rberry88
08-28-2005, 10:29 PM
No anti-virus installed, I did an archive and install last night (yes, before the backup) and everything is working fine, even feels a little bit more snappier than before the archive and install. I've checked and made sure the Software Update was run and all updates have been installed. Not sure what to do now.

*edit, sorry, didn't fully answer your question.

I opened up Terminal, typed

sudo lsof | grep "SVUClone"

--hit enter--

typed password

--hit enter--

and the curor sits on the next blank line after password, nothing on the line and nothing follows.

dnanian
08-28-2005, 10:32 PM
Well, I'd stop SuperDuper!and reboot the machine, then try it again. You are backing up directly to the Lacie, right?

rberry88
08-28-2005, 10:41 PM
Yep, trying to backup directly to the "backups" volume on the 250GB (110GB partition) Lacie external Firewire HDD.

Should I try do the backup without logging holding the shift key?

dnanian
08-28-2005, 10:50 PM
No, that should be done: it stops login items from running.

Something's definitely going on here. But, restart and see if it fails again

rberry88
08-29-2005, 01:04 AM
Okay, rebooted and logged in holding down shift, SuperDuper started and got about 2% done according to the top statusbar and was stuck/stopped on the /user/rickb/mydownloads which only contains two files and they are text documents that are 2kb and 8kb big. It was stuck/stopped here for about 2 hours before I just stopped it.

Any advice? I purchased this due to the reviews and am really interested in the SmartUpdate feature.

dnanian
08-29-2005, 09:22 AM
Here's the thing: it's likely not stuck on the folder it's showing you. Rather, it's stuck on a file somewhere else, and that command I send before --

sudo lsof | grep "SVUClone"

Is what will tell us what that is.

That command is a very basic part of the OS, and if it won't produce output, it's very hard for me to diagnose what's going on.

I'm sorry I wasn't still there when you tried this again so I could give you immediate feedback (it was after midnight in these parts), but if you can get it to the point where you're sure it's stuck, and then try the above again, hopefully we'll get some results, which will tell us what's going on.

(By the way, after you stopped it, you should be able to look at the files that were actually copied, and I think you'll find that the folder being listed was copied in full.)

One more thing: you might want to open up the Console application and check both the System and Console logs, to see if something's writing frantically to them. If so, that constant I/O to a file will cause a problem, and could be what's going on. The name of the program that's writing is one of the first things on the line, so if that's happening, *that* program is having a serious issue -- and fixing *that* is the key to getting this to work.

rberry88
08-31-2005, 09:28 PM
Okay, sorry for the delay in getting back to you, went to the Cubs game last couple days, woot.

Anyway, I started Console and found a ton of errors being reported, mainly from programs that are no longer installed. I went through most of them and got them taken care of, I tried SuperDuper again and it gets about half way through the backup (according to the top statusbar) and then just hangs (I left it for about an hour and it didn't move anymore).

I tried the SVUClone command and it returned nothing, after typing it, the cursor remains on a blank line for about a minute and then returns to the normal prompt.

Note: Any recommendations of programs that might help me clean up those errors that are reported in Console? I use Cocktail and let that run with all relevant options enabled and it finishes but I'm not sure if that would even clean up these errors.

dnanian
08-31-2005, 10:30 PM
Well, a few things...

If the lsof command returns nothing, that likely means it's crashing... something I've not seen happen. Do you have an SVUClone crash log in /Library/Logs/Crash Reporter or in the same folder off your Home?

Not sure what would help with the errors...I'd check each app's support site for uninstall instructions.

rberry88
09-04-2005, 03:21 PM
WOOT, got the bad apps/errors cleaned up and ran SuperDuper. Took about 1 hour to do a full backup yesterday. Did a smart update today just to make sure it worked and it went flawlessly and finished in about 10 minutes.

I'm sold, I now have a top notch backup routine, thanks for the help.

dnanian
09-04-2005, 03:30 PM
Great! And, you've got a cleaner system to boot, which is even better! :)

rberry88
09-04-2005, 11:30 PM
Yep, a cleaner system and I learned a lot about how to keep it clean too, whew.

Thanks again.

dnanian
09-05-2005, 12:14 AM
Yikes, the dreaded "learning experience"! ;)