View Full Version : Please help fix my scheduler which hasn't worked in years

09-22-2010, 03:26 PM
Hi dnanian,

I've been using SD for a really long time on many computers and client's systems. But, for my personal setup, I've been having and working with scheduling problems for what seems like years. On my Mini it's never worked perfectly with 8 schedules setup to run every night (this computer never sleeps). For the past year, the scheduler runs maybe once a week. I tend to check it once a week at this point, and almost always I need to manually "copy now" in scheduled copies just so I have the data backed up (which always works).

I'm guessing this goes back to me messing with cron or other sh*t in an attempt to fix scheduling problems about 1.5-2 years ago. Now I'm ready to tackle this problem again and get this solved once and for all. I really need my scheduled backup to work without needing to check on them.

So, my question is this:

Can you please provide instructions to uninstall/erase/clear any and all settings (superduper and anything else you can think of) that might mess with superduper's scheduler?

Thank you very much!

09-22-2010, 05:28 PM
Delete all your existing schedules, open Terminal and empty the crontab with

crontab -r

then recreate the schedules. That should be it.

09-22-2010, 06:51 PM
thanks, trying all that now. also converting sparseimage to sparsebundle -- not sure if that's really much different or not. will report back.

09-22-2010, 08:58 PM
also converting sparseimage to sparsebundle -- not sure if that's really much different or not.
One advantage is that compacting a sparse bundle (using "hdiutil compact ") is much faster.

09-25-2010, 01:40 PM
this morning woke up to the all too familar "copy job" window that can't be closed (needs to be forced quit). Of the 5 drives that were supposed to backup early this morning, none did. This is exactly the same problem I've been having for years. So much so that I have an applescript to force quit the copy job window for me. This is a major issue with superduper imo and unless you know what is causing this, may cause me to completely abandon it and search for something more reliable. I hope you know what's wrong. *No log file available in console or SD, from what i can tell.

09-25-2010, 01:49 PM
What exactly does the copy job window say? I run a lot more than 5 scheduled copies a day, every day, and just haven't seen anything like this, Brian... at least not without some other basic problem with the OS or system.

09-25-2010, 02:51 PM
Nothing else is wrong with the system. I'll write down the "copy job" window text next time (tomorrow morning if everything is still as it was previously) and post back. Thanks!!

BTW... When this happens, after force quitting copy job window, I can always manually run the scheduled copies and they always work. After that, they may work as scheduled for a day or so, then "copy job" again, and no.

09-25-2010, 06:19 PM
Well, something is certainly weird about the system, since for you it hasn't been working "for years", but we're not hearing that from others. Whether or not it's "wrong", it's something "different"...

09-26-2010, 02:51 PM
...worked fine last night -- 5 schedules executed as expected no problems. I'll check back in next failure.

09-28-2010, 12:25 PM
Screenshot of "copy job" dialog box and schedules and log grayed out.

Note that "quit" and "run" on copy job window don't work. It needs to be force quit to disappear.

Haven't closed or touched anything on problem computer, so let me know if you want me to check anything else.

Any ideas appreciated.

09-28-2010, 01:09 PM
OK. So, if you're getting prompted to run the script like this, there's something wrong with your system.

Here's the deal: we compile the script "driver" one time, when you schedule. That script is compiled so that it won't prompt on run - it's supposed to act like a regular program. And, as you previously indicated, that's how it acts most of the time.

We don't change anything, obviously, between runs. The schedule driver is exactly the same. But, you're getting different behavior - that is, the *system* is prompting when cron tries to run the schedule driver.

That shouldn't happen. The schedule driver hasn't changed (and as you've indicated previously, when you restart your Mac it often 'fixes' itself) and is not even *running* at that point. So - since the scheduler hasn't changed, and isn't running, the problem is with something *external* to the scheduler. Perhaps some maintenance tool you're running, or some other problem with your system.... but it's not the scheduler itself.