View Full Version : unmount before script?

08-22-2010, 05:51 AM
Is it possible to tell SD to unmount the sparsebundle before executing the final shell script? If not, is it ok for the shell script to unmount it?

08-22-2010, 10:46 AM
Sorry, no - you can't do either...

08-22-2010, 04:11 PM
If I launch my script in the background and have it sleep for a while before unmounting, will that be ok? It will wait while SD finishes up.

08-22-2010, 07:14 PM
We're going to automatically unmount the bundle when we're done, so you certainly don't need to do it "for" us (assuming you selected the bundle, and not the bundle's mounted volume, in the destination pop-up).

08-22-2010, 08:55 PM
For some reason, whenever I try to run a backup directly, its not unmounting the image after its done. yes I'm making sure to backup to a bundle, not any mounted volume. When I start it is either not existing or not mounted already either. The backup runs and when its done I see the last action on the list in SD is to unmount, and it checks it off the list as one, but the volume is still mounted.


Also, when i try to setup SD to QUIT when done, it doesn't quit. It also shows up on the SD window as the last action item and checks it off...but still SD is left running at the end...

Maybe that only works when its scheduled?

08-22-2010, 11:44 PM
I don't know why it wouldn't unmount unless something was preventing it from doing so, and a sleep-then-unmount wouldn't change that. We certainly requested the eject if it was checked.

Quit, on schedule, will happen unless SD! was running when the schedule fired.

08-23-2010, 12:00 AM
I'm more confused now.

Let me try again..

In SD there is a pulldown menu there for "On completion" with a list of things that SD can do when it completes. These include things like Shutdown, quit SD, etc. The one that says "eject" is greyed out, I don't know why.

I tried to start a job(not scheduled) that has quit on completion selected. It did not, however, quit.

I realize that SD is supposed to always unmount, but its not unmounting and I'm not doing anything else with it. I can easily eject the mounted volume with the mouse and nothing stops me from doing it, so why isn't SD doing it.

You said that when its scheduled, SD will quit at the end IF it wasn't running before. I assume that is the default behavior, but I want to know what happens if I have selected the "quit on completion" behavior. shouldn't it always quit on completion in that case regardless of whether its a scheduled copy or not?

At any rate, I still have no idea how to make CD eject or unmount this volume when its done, unless that feature only works when the back is scheduled and does not unmount (or quit either) when running the copy directly?

08-23-2010, 12:12 AM
I don't know what was happening before, but now its quiting on completion. I think the settings had to be saved into a file maybe for it to remember to do it, I dunno.

Nonethless, the drive is still not unmounting for some reason, even after SD quits.

Any ideas how I can figure out why?

08-23-2010, 08:53 AM
You could look at the system log and see if there are any explicit reasons why. Or send the log in with the send to shirt pocket button (use 'error during copy' as the issue type) so I can take a look.

08-23-2010, 04:42 PM
This is all I get:

| 08:01:20 PM | Info | ......COMMAND => Unmounting '/Volumes/BigExt/Backup/SuperDuperNightly/mbp-dewd-10-6-latest.sparsebundle'
| 08:01:24 PM | Info | hdiutil: couldn't unmount "disk5" - Resource busy

I have no idea why it would be busy. I'm certainly not doing anything to it directly.

08-23-2010, 04:50 PM
Try adding its mounted volume to the spotlight preference pane's privacy tab.

08-23-2010, 04:53 PM
Good idea.

Do you know if there is a way to generally make Spotlight ignore usb/firewire drives, network drives and mounted sparsebundles?

08-23-2010, 04:55 PM
I don't know of any documented way, no.