PDA

View Full Version : SD does not close and eject disk properly


fdwlaw
08-17-2010, 10:59 AM
I have SD setup to Smart Update, and Eject disk after SD quits (Scheduled). However SD doesn't quit. After a few minutes of waiting nothing happens and I hit OK in SD and close SD, then the disk ejects. Don't know what's changed but every thing use to be automatic...meaning SD would quit and the disk would eject automatically. What's going on and how do I fix this problem?

Thanks

dnanian
08-17-2010, 11:04 AM
SD! will only quit if it wasn't running when the schedule fired. Was it running when the schedule launched?

fdwlaw
08-17-2010, 11:07 AM
No. The scheduler fired and ran the backup fine but nothing happen afterwards

dnanian
08-17-2010, 11:09 AM
Maybe try using Onyx/Cocktail to empty user and system caches and rebuild launch services - I can't think of any obvious reason why it wouldn't quit.

fdwlaw
08-17-2010, 11:13 AM
Another thing. After hitting OK and closing SD and the disk ejects the disk, the disk still spins. Normally the disk will quite spinning and go into a sleep mode, but that's not happening either. Normally this occurs.
That's why I have the Scheduler do all the work. I have a silent working environment and a current working clone.

dnanian
08-17-2010, 11:14 AM
Can't help you with that. We unmount the drive. What the drive does once that happens is sort of up to the drive.

fdwlaw
08-17-2010, 12:23 PM
Maybe try using Onyx/Cocktail to empty user and system caches and rebuild launch services - I can't think of any obvious reason why it wouldn't quit.

I used the Automation tab in Onyx (never used Onyx before) and that seems to have done the trick everything works fine now........so what happen?

dnanian
08-17-2010, 12:30 PM
Ask the OSX gods. They can work in mysterious ways.