PDA

View Full Version : superduper crashing


camner
08-17-2005, 11:54 PM
I haven't run SD in a while. I booted off of my main partition so I could recreate a safety clone (actually, I had installed 10.4.2 on the clone and didn't like what it was doing, so I wanted to "reclone" the clone from my 10.4.1 partition). After selecting "smart update", I clicked "start copying", then "OK", and Super Duper crashed without a trace...the window just disappeared.

I tried repairing permissions and the problem persists. I also tried rebooting.

There doesn't seem to be any SuperDuper or Shirt Pocket crash log.

Any hints about how I might go about restoring SD to full functionality?

I'm running SD 1.5.5 (v74).

dnanian
08-18-2005, 08:01 AM
Try clicking the lock in the main window to lock, and then re-unlock, the application. I think that'll resolve the problem.

camner
08-18-2005, 09:29 PM
That did the trick, thank you!

dnanian
08-18-2005, 09:56 PM
My pleasure. If you remove the SuperDuper! receipt from /Library/Receipts, this won't happen when you repair permissions.

camner
08-19-2005, 01:57 AM
Well, there doesn't seem to be a SuperDuper! receipt, either in /Library/Receipts or ~/Library/Receipts! I checked both on the original drive and the safety clone.

dnanian
08-19-2005, 08:37 AM
Interesting. If you've ever auto-upgraded, there should be a receipt there. That's the reason -- after repairing permissions -- the lock state gets messed up: the permissions for the files we "unlock" are different inside the receipt, and repair permissions "kindly" (?) changes them back on us.

But, if it's not there, I'm not sure why it happened to you. Please let me know if it happens again, would you?

camner
08-19-2005, 11:12 AM
I don't recall whether I've ever autoupgraded or just redownloaded. If it happens again (I do repair permissions weekly via Macaroni), I'll let you know. But now I have a fix! :)

dnanian
08-19-2005, 11:17 AM
Which is always a good thing! :)