PDA

View Full Version : Slow Restore via USB


strathglass
04-03-2010, 09:12 AM
I have two external firewire/USB drives that I use for my regular SuperDuper backups (using firewire): both are partitioned and I use one 500GB partition on each to backup my iMAC internal 500GB drive.

Since my iMac won't boot from these drives when connected via firewire, I have to use USB when I want to boot from the backup.

I am now doing a restore:
I've booted from one of these backup drive partitions, connected using USB,
and I am using smart update to "backup" (restore) to my internal iMac hard drive (which I first erased).

However as I speak it has been 6.5 hours and only 6700 files out of 708k files (25GB out of 263GB) have been copied, for an effective copy rate of 0.98MB/s.

At this rate it will be several days to complete the restore!!
What could the issue be?
-Strathglass
PS: I am using a 2008 24" iMAC (4GB, 3.06GHz) w/ 10.6.3
No other USB drive is connected at this point.

strathglass
04-03-2010, 09:28 AM
Would it be any quicker to do it via erase, then copy? (Will that be bootable?)
-strathglass

dnanian
04-03-2010, 04:25 PM
That sounds like your USB drive is running in USB 1.0 'mode'. Plugged directly into the Mac?

strathglass
04-04-2010, 09:35 AM
Dave - Yes, it is plugged DIRECTLY into an iMAC USB port.

But operations seem normal otherwise, not excessively slow to start apps etc.

Any ideas?
Any way to test your hypothesis?

-strathglass

dnanian
04-04-2010, 09:39 AM
Perhaps an AntiVirus program? We don't access the hardware at all, so any low speed problems are going to be due to generally slow I/O to the source/destination (hardware, ports, cables, etc), or 3rd party interference (e.g. AntiVirus)...

strathglass
04-04-2010, 11:19 PM
I don't have any antivirus program, so that is not it.

Maybe the drives I have just aren't very good for a Mac?!?!?
I will try next time using one of my name-brand WD external drives.
(The slow one is a Seagate drive in a 3rd party firewire/USB enclosure.)

At least the restore is working. Based on progress to date it looks like it will indeed take 3 full days (i.e. 1 more day)!

Regards,
Strathglass.