PDA

View Full Version : "ignore owner" disappears


thomasx
02-08-2010, 09:59 AM
I am having a problem, that I am not able to figure out.

The Setting:
MacMini, 10.5.8, external HDD 1TB, File sharing enabled for some Macs locally, "ignore owner" is ticked in the apple-i-dialogue, so that every user has access to all files on this HDD, regardless who put them there.

SuperDuper is to SMartBackup those files, that have been altered, over the internet to a distant volume for offsite-backup.

every time the smartbackup runs, the "ignore owner" gets unticked. I have to tick it again each time, mostly when a local user informs me that he cannot access a file or write to a specific folder. he then has to disconnect/connect from/to the macmini again.

I have no idea, why this happens, but furthermore: HOW to STOP that from happening. I'd like to leave it ticked at all times.

Any ideas?

dnanian
02-08-2010, 12:10 PM
We always turn ownership on for a volume, Thomas, since it's the only way to ensure that the ownership attributes are properly copied. You can create a small shell script to turn it off if you must (although I think you'd be better off leaving it on and configuring ownership to allow access to the users who need it).

thomasx
02-08-2010, 12:52 PM
I would, if writing and reading from and to the volume worked in the way we need it.

Although I added all the users that log on through afp to the Volume, giving them read&write access, the problem with not being able to read or write files from other people persists, until i have the ignore ownership button on.

Maybe that would be an idea to have a script ready to reset it to how we need it afterwards.

My most favourite solution would be to not use the ignore ownership button. But I think that might be not the right forum for that here, since this is about superduper.

Maybe (if someone encountered that problem before and knows where I did something I should do differently) someone might have an idea about that for me.

But the main question seems to be then for me: how do I set that button in a script so that it can be called from superduper after an automatic run?
I have never created a script before.

dnanian
02-08-2010, 12:55 PM
What you'd usually do is assign a read/write/create allow all ACL, inherited, to the parent folder. That would work for all users... you can do that with chmod (see 'man chmod' for the ACL syntax)...

thomasx
02-08-2010, 01:08 PM
Uh, before I try that I would have to be really sure what I am doing there... Which right now I am not.

I have uploaded this picture, showing the part with all the users allowed read&write access. even "everyone" has read&write access to that volume.
still, after using superduper, with losing the button, nothing of that works.

It looks to me as if my setting are not widely used, but rather seldom, since no one ever did ask about that before or wanted to have that button reclicked after the automatic backup.

dnanian
02-08-2010, 01:20 PM
That's why you want to assign an ACL here, though, Thomas. So you can leave ownership on, and the permissions will be applied automatically to files in that folder (and below) if done right.

thomasx
02-08-2010, 01:25 PM
okay. thanks so far.
from reading the man chmod I do not know what to do. I think I have to find someone who did something like that before.
I have never been assigning an acl in terminal before myself.

another question that pops up here: If I assigned an ACL correctly, would that only count for the files that are now on the Volume or would that also work for all files that will be put there in the future (or would I have to reset their rights over and over after each new file)?

dnanian
02-08-2010, 06:52 PM
An inherited ACL (which you would apply, the first time, recursively with the -R option) will automatically get applied to everything created under the folder where you attached the ACL. That's the neat thing about it - you do it right the first time, and you're golden.

thomasx
02-09-2010, 07:01 AM
I really do not know what to do here. Do you? If so - can you post me the line I need to enter to make a volume the way it should be in order to have the right rights even after Superduper was active?

I have the feeling you know the answer but don't want to tell.
I have never used ACL before. This is completely new to me.

dnanian
02-09-2010, 10:25 AM
That's why I pointed you at the manual for chmod - open Terminal and type "man chmod" followed by Return. There are many examples of how to use ACLs in there.

Yes, I know I could give you the exact answer here, and I haven't, but that's mostly because it's important to understand what you're doing in this area rather than just running what I give you... that way, you'll learn something that'll prove useful as you move forward. I'm sorry if that's a bit annoying.

sjk
02-09-2010, 02:44 PM
open Terminal and type "man chmod" followed by Return.
Or, view the page in a web browser:

chmod(1) Mac OS X Manual Page (http://developer.apple.com/mac/library/documentation/Darwin/Reference/ManPages/man1/chmod.1.html)

You can select the OS version.