PDA

View Full Version : New build (389) posted - all reported problems fixed.


dnanian
08-06-2002, 02:53 AM
I've just posted a new build of B1 (v1.0B1(389)) that fixes the three reported problems with B1, including the rather bad Thousands of colors bug.

Make certain you *stop* the server and *quit* the preference panes application before updating the server. If you're updating the client, please make sure it's not running.

Issues corrected include:

- Thousands of color support corrected and re-tested. Various Thousands and Millions configurations were checked, including:

- A straight 16-bit display.
- Both a 16 and 32-bit display on the same machine
- iTunes (original, on server) straddling both the 16 and 32-bit display (so part of it is in 16-bit space, and part in 32-bit)

All these cases now work properly. If you were experiencing a "blank" display, download the new build and update the client and server.

- An un-writable "Home" directory (when the installer is authenticated -- this can happen if your home directory is a network volume) now causes the netTunes.prefPane to be installed in /Library/PreferencePanes rather than in ~/Library/PreferencePanes.

- Changing your machine name in System Preferences didn't update the displayed value in the netTunes server preference pane until you quit and re-entered System Preferences, even though the new value was used for the server name. The new name is now displayed properly when you return to the prefence pane, without having to quit System Preferences.

Thanks to Paul B. and Dave H. for the bug reports, and to everyone for the great comments and feedback. Keep them coming!