PDA

View Full Version : Backup successful - unable to boot


kahmedsid
11-11-2009, 06:06 PM
On a brand new mid-2009 15" MBP, installed Snow Leopard and applied all updates as of last night (11/10/09). This morning, connected an external drive in enclosure via USB and performed a full backup. Success!

Turned the system off and rebooted off of the external USB drive. Success!

Swapped the external drive with the internal drive, disconnected everything except power and rebooted. See the Apple logo and the spinning progress indicator, unable to boot.

Did everything mentioned above twice with exact same results.

Any pointers?

dnanian
11-11-2009, 06:28 PM
Are you sure you were running from the USB drive?

kahmedsid
11-11-2009, 06:51 PM
The first time I did it, I didn't even remember to boot with the drive still in the USB enclosure. Next time, I was like I am not going through the hassle of opening up the system, replacing drives, etc. so let me boot off of the USB drive first. And, it booted off perfectly fine. I breathed a sigh of relief and swapped the drive and crossed my fingers that life is going to be good. But it wasn't.

Btw, the drive is named the same, Macintosh HD. If you can suggest looking at any log files, etc. I can boot off of the original drive as USB and look at files in the problematic ones.

Appreciate your help.

dnanian
11-11-2009, 07:05 PM
If it boots with USB it should certainly work internally. Try starting up while holding down Shift to see if "Safe Boot" works.

kahmedsid
11-11-2009, 07:15 PM
Turned off, pressed the start button and immediately held down the SHIFT button until I saw the apple logo, the spinning progress indicator and an additional bar type progress indicator just underneath it. The bar went almost about 1/4th of the way and then disappeared leaving behind just the apple logo and the spinning indicator. It's sitting at that ....

dnanian
11-11-2009, 07:16 PM
A bar type indicator? That's usually an indication of a firmware update. How long have you left it at the spinner?

kahmedsid
11-11-2009, 07:21 PM
Yeah, I was surprised to see the additional bar indicator too but it went away both the times I tried safe mode at the exact same time (1/4th of the way). I haven't turned off on the 2nd attempt and it's probably sitting on the spinning indicator for anywhere between 5-10 minutes.

dnanian
11-11-2009, 07:26 PM
Are you sure the drive was properly partitioned as GUID before you copied to it?

kahmedsid
11-11-2009, 07:32 PM
I used the Disk Utility to partition the drive and from Options made sure I selected GUID (the last one was selected by default, forget the name but it was for windows and dos type os's).

Should I just re-install on this drive using the Snow Leopard CD or is there still hope? There is NO DATA at all on it yet, just a vanilla OS-X install with all updates. I think I have tried doing that on another macbook before and it said go re-partition using GUID, and the disk utility failed to re-partition becuase the disk was 320GB and internal. When it's external, it has no issues (not sure why).

kahmedsid
11-11-2009, 08:16 PM
I booted off of the OSX CD and selected to re-install on the same drive. It is working on it now with 42 minutes remaining. I'll update later.

kahmedsid
11-11-2009, 08:24 PM
Oh well, the attempt to install OS-X failed shortly after my last update, saying not possible to install OS-X, please contact provider or try again. Arghhh ...

I'll try running repair, permissions, etc ... on disk and if all fails, probably re-format it tomorrow.

Btw, I double checked, partition table map was indeed GUID.

dnanian
11-11-2009, 09:38 PM
This really sounds like a drive that's not properly partitioned. I can't think of any other reason why it would refuse to install.

kahmedsid
11-12-2009, 12:31 PM
Since last night, I've re-formatted the drive writing zeros to every possible bit (took over 3 hours). This morning, I tried installing using the Snow Leopard CD, it recognized the drive as healthy and started installing but hung immediately (maybe one of the bad snow leopard install disks, I don't know).

So, I replaced disks, booted off of the one that has a healthy Snow Leopard installation, re-formatted the external drive. This time used CarbonCopyCloner to clone the drive. Clone went flawlessly. Booted up with the drive still external via USB, Success!

Swapped drives, booted up, held down Option key to select internal drive (just to be safe) - but it's back to the same behavior. The spinning indicator is spinning away :)

I've used superduper in the past and never had issues, I am beginning to suspect something with the new macbook pro with 10.6.2 on it.

The drive in question is a Hitachi 320GB 7200 SATA.

Is there a location that would have logs related to the unsuccessful bootup?

dnanian
11-12-2009, 01:21 PM
So, didn't work with SD! or CCC, but a clean installation with SL worked fine.

It's possible that the system.log on the failed boot drive (e.g. /Volumes/the-internal-drive/private/var/log/system.log) may indicate what's failing here.

kahmedsid
11-12-2009, 11:11 PM
Wanted to provide an update:

Today was spent doing several things involving re-format, re-partition, re-install, re-clone, etc. and everything led to the same conclusion; the drive boots only when it is external.

By the way, the firmware of this computer was updated by the most recent security updates so that could be a contributing factor (not validated though).

Spent over an hour with a real smart guy at the Genius Bar, he tried everything I had tried and he was also pretty confused. The fact that the drive works flawlessly when external but fails when placed internally is pretty strange.

He's offered to replace the laptop - considering it ...

dnanian
11-12-2009, 11:15 PM
I have to say it's a pretty unusual problem - just not something I've heard of before. It really should boot either way! If anything it's much harder for it to boot externally than internally...

kahmedsid
11-13-2009, 12:09 PM
I can't agree with you more, Dave. This is exactly why we're pretty :confused:

I think I am going to get the laptop replaced and if the drive fails on the new one too, we'll probably blame the Hitachi Travelstar 320 GB 7200 RPM disk.

dnanian
11-13-2009, 06:05 PM
But the drive did work when you just installed Snow Leopard to it, no? So... I just don't get it.

kahmedsid
11-13-2009, 09:39 PM
The drive when placed inside the computer acts weird in many ways:
- does not let disk utility erase/partition it (hangs and sometimes errors)
- does not let the OS-X installer install to it (hangs after a minute)
- does not boot up even if it has a fresh copy of OS-X

The same drive when placed outside using USB or Firewire does everything normally.

dnanian
11-13-2009, 10:21 PM
Interesting. OK - yeah, sounds like a drive issue. Very weird!

kahmedsid
11-16-2009, 03:40 PM
I did get a laptop replacement and after putting in the Hitachi Travelstar 320GB 7200RPM drive in it, the same behavior was observed. I have concluded that the problem is with the drive when placed internally on the Macbook Pro.

The same drive works just fine with the Black Macbook which I am upgrading from.

Dave, thanks for your help!

dnanian
11-16-2009, 04:16 PM
It doesn't surprise me that the replacement MBP showed the same behavior - that was a bit of a hail mary pass on the part of the AppleCare guy. Very strange that the drive seems incompatible, though! Maybe it's just that one sample?