PDA

View Full Version : Can't select a pre-run shell script


RobLewis
10-08-2009, 03:58 AM
Under Advanced Options, I check the "Run shell script before copy starts" box. Then I click Choose... and navigate to my script, called MountBackupVol.sh (a simple 1-line script: diskutil mount MyBackupVol)

I select the script, the file dialog goes away, and yet the data field next to the "Choose..." button remains empty.

Why can't I select this script? It's in ~/Library/Application Support/SuperDuper!/Aux Scripts/

dnanian
10-08-2009, 09:03 AM
A good question, Rob - it certainly should. Try quitting SD, then remove the "Saved Settings" folder in ~/Library/Application Support/SuperDuper!, then start it and configure again.

RobLewis
10-08-2009, 03:46 PM
That did the trick, thanks:).

Suggestion: expand the "What's going to happen" section to include things like:

"First, the shell script <script name> will be run."

and

"Finally, the volume <volume name> will be ejected."

RobLewis
10-08-2009, 03:57 PM
In the immortal words of Emily Litella, "Never mind."

I guess it was due to the earlier problem that I wasn't seeing all the scheduled operations. Now they're there.

dnanian
10-08-2009, 04:10 PM
Glad to hear it. :)