PDA

View Full Version : dyld: shared cached file error


earl0101
10-02-2009, 06:08 PM
Hi Dave,

I'm getting the "Failed to enable ownership on" error. Specifically stp occurs with "dyld: shared cached file was build against a different libSystem.dylib" this seems different from other similar posts on this forum. I'm using version 2.6.1 (v86).

I just upgraded to Snow Leopard and was creating a disk image on another drive. I tried restarting but the error still occurs. This had worked for me before so I'm not sure what the change is.

Earl

| 01:52:55 PM | Info | SuperDuper!, 2.6.1 (86), path: /Applications/π> Program Files/SuperDuper! 2.6.1.app, Mac OS 10.6.1 build 10B504 (i386)
| 01:52:55 PM | Info | Started on Fri, Oct 2, 2009 at 1:52 PM
| 01:52:55 PM | Info | Source Volume: Startup, mount: /, device: /dev/disk1s2, media: WDC WD3200AAJS-41VWA0, interconnect: Internal SATA, file system: "Journaled HFS+", OS: 10.6.1 (10B504), capacity: 297.77 GB, used: 13.04 GB, directories: 91027, files: 303313, ejectable: NO, ACLs: Enabled
| 01:52:55 PM | Info | Target Image: /Volumes/Startup on 2009.08.22/5MacPro 3> 10.6.1+ basic apps.sparseimage, name: 5MacPro 3> 10.6.1+ basic apps
| 01:52:55 PM | Info | Copy Mode : Erase, then copy files
| 01:52:55 PM | Info | Copy Script : Backup - all files.dset
| 01:52:55 PM | Info | Transcript : BuildTranscript.plist
| 01:52:55 PM | Info | PHASE: 1. Prepare to Copy Files
| 01:52:55 PM | Info | ...ACTION: Preparing Startup
| 01:52:55 PM | Info | ......COMMAND => Verifying the integrity of volinfo.database
| 01:52:55 PM | Error | dyld: shared cached file was build against a different libSystem.dylib, ignoring cache

dnanian
10-02-2009, 07:04 PM
Hi, Earl. Your system has some subtle damage we can fix (welcome to a new OS version with its own unique "quirks"). Please open the Terminal application. Copy the following to the clipboard:

sudo update_dyld_shared_cache -force

Paste that into Terminal. Press Return at the end and, when prompted, enter your password (it'll be invisible). When it's completed and the "%" prompt returns, quit Terminal and restart your Mac.

Then, give SD! another try: it should work.

earl0101
10-02-2009, 07:42 PM
Thanks Dave, as always fantastic support from Shirt Pocket. That solved the problem.

It's interesting to note that the disk image I booted from and tried to image is about as clean an install as possible. I used Superduper! to re image the drive with the *original* system install (much faster than pulling out the original disks). After booting up with the new image I applied the snow leopard update, then ran all the recommended updates (including update to 10.6.1). The only other thing I added (besides Superduper!) was two printer drivers! Also, I did run Disk Utility's Repair disk permission function.

What's also interesting is that Superduper! did work a few times before this error (I update images at each successful step of a fresh system install). So it appears that 10.6 did something in the background. Hopefully this is just a one time "quirk" or it can be fixed in a future update. Again, thanks.