PDA

View Full Version : disk problems


KevinBBG
08-17-2009, 10:17 PM
The drive I was using for my back up went bad, got an error message and it couldn't be repaired. So I zeroed out the drive and tried backing up with SD again. It erased the disk, called Backup (I know, clever name), but the next line says "Failed to enable ownership on Backup" all in red letters. and there it stopped. Here is from the log file, this is everything after it said it Repaired Permissions on the original drive:

| 05:53:25 PM | Info | ...ACTION: Erasing Backup
| 05:53:25 PM | Info | ......COMMAND => Preserving Backup UUID
| 05:53:25 PM | Info | 23962C9C5056BB51
| 05:53:25 PM | Info | ......COMMAND => Preserving spotlight indexing state
| 05:53:25 PM | Info | ......COMMAND => Erasing Backup
| 05:53:59 PM | Info | Could not unmount Backup for fast disk erase, defaulting to slower directory-by-directory erase...
| 05:53:59 PM | Info | ......COMMAND => Restoring Backup UUID (23962C9C5056BB51)
| 05:53:59 PM | Info | 23962C9C5056BB51
| 05:53:59 PM | Info | ......COMMAND => Restoring Spotlight search indexing state on Backup
| 05:53:59 PM | Info | ...ACTION: Preparing Backup
| 05:53:59 PM | Info | ......COMMAND => Enabling permissions on Backup
| 05:53:59 PM | Info | Refreshing Disk Arbitration ...
| 05:54:00 PM | Info | ......COMMAND => Verifying that permissions are enabled for Backup
| 05:54:00 PM | Info | Permissions on '/Volumes/Backup' are enabled.
| 05:54:00 PM | Info | ......COMMAND => Verifying that Backup ACL support matches Macintosh HD
| 05:54:00 PM | Info | error (22) from /Volumes/Backup. (Invalid argument)
| 05:54:00 PM | Error | ****FAILED****: result=5632 errno=22 (Unknown error: 0)

That last line is in red. I have the latest version of SD and running the very latest version of Leopard.

Has the hard drive just bitten the dust? It has another partition on it that looks fine.:eek:

dnanian
08-17-2009, 10:40 PM
Try powering off your Mac and your backup drive, wait a few, then power back up and try again, Kevin.

KevinBBG
08-18-2009, 12:28 PM
Did that, didn't help. I got an error message when starting up to eject or initialize the disk. This time both partitions were bad. I tried to partition, erase and zero out the drive but all failed immediately.

Is the drive just dead? Don't know what else I could do to fix it anyway.:(

dnanian
08-18-2009, 02:44 PM
Certainly sounds like the drive is either bad or communication with it is failing: try a different cable, perhaps? Make sure you power cycle the drive...