PDA

View Full Version : FileVault not copying


jondear
08-17-2009, 01:12 PM
Hi,
I've enabled FileVault and tried to clone my entire hard disk, however my (FileVault) encrypted home folder doesn't copy at all. I read that SuperDuper doesn't create sparse bundles, but it can copy to them, but I don't quite see how to do that.

At the moment I have a cloned HD which shows an empty Home folder.

If I point SuperDuper at my (FileVault) encrypted home folder as source, how do I tell it to copy newer (or in this case ALL) files to the correct location? I only have the entire backup HD showing up as Destination. The empty Home folder on that backup HD doesnt show up in SuperDuper.

Ok, found something that's helped me a little on the way:

To create a sparsebundle:
In Disk Utility, choose File > New > Blank Disk Image.
Fill in the filename, location, volume name, and maximum size; leave the format as Mac OS Extended (Journaled).
Choose either 128-bit or 256-bit AES encryption from the Encryption pop-up menu. Leave Partitions set as it is.
From the Image Format pop-up menu, choose Sparse Bundle Disk Image.
Click Create. Enter and verify a password and click OK.

But I still have a couple of questions:

1. My original home folder doesn't show a size anymore, just zero k. Can I just go ahead and choose any size for the sparsebundle I'm going to create, and it'll automatically expand to fit my contents?
2. What location do I use for the new sparsebundle (assuming this is what I do), besides the currently empty backed up home folder? And what name? Same as my home folder?

This might be completely wrong, so I still need some pointers please.

dnanian
08-17-2009, 01:14 PM
It's copying the files, but they're hidden and encrypted on the backup, jondear. That's what FileVault does, after all...

jondear
08-17-2009, 01:28 PM
Hi,

Sorry I cross posted, not thinking you'd have replied so quickly.

You mean I don't have to create a sparesebundle? If I boot from this backup the user folder will appear?

Sorry for my confusion. I expected an encrypted sparsebundle file, not an invisible one. My mistake.

---

Ok, I rebooted from the backed up HD and the home folder is copied and working fine, exactly as you said.

I can now also look at my original internal HD and see the ".sparsebundle" home folder. 65.4Gb sitting there. So the backup's worked, even though it doesn't appear after the process has completed. Confusing (to me) but logical.

And as I understand SuperDuper will incrementally backup just the changed bits (layers?) of that original sparsebundle file?

I'll test that now.

Thanks

jon

jondear
08-17-2009, 01:49 PM
Hi

One more thing. Once I've rebooted form the original HD, I can now see the sparsebundle image on the backedup HD, which I couldn't see immediately after SuperDuper had backed up and I'd restarted. However there is a (growing) list of duplicate home folders,

home folder, home folder 1, home folder 2 etc

All the numbered folders are (appear to be) empty. Any idea what this is? Can I dump the dupe folders?

dnanian
08-17-2009, 02:28 PM
Sounds like you're backing up when you're logged into the FileVault account, which you should not do (see the User's Guide)...

jondear
08-17-2009, 02:41 PM
Ah yes, I'd read that, but forgotten...

If youíre using FileVault, your home folder and all its data is stored in a
single, large file thatís open and active when youíre logged in. Because
of this, you should create a non-FileVault account for use with
SuperDuper! Then, log out of your FileVaulted account, into this new
account, and run SuperDuper! from there. This ensures that the
special FileVault volume is put away and backed up cleanly.

Can I log into a second (non-FileVault admin) account and back up over my existing backup? Or is that likely to cause problems?

So I should trash my "unclean" backup because I've created it while logged into FileVault, login to my second (non-FileVault admin) account and backup from scratch using that?