View Full Version : Trying to restore my sparse image to new Hard Drive

07-27-2009, 04:31 PM
I have just put a brand new hard drive in my iBook. When I tried to use Disk Utility from my OS 10.5 install DVD to restore the previous HD's sparse image copy from my Drobo, that and all other sparse images on the Drobo are greyed out.

I have done a search on this issue, but all I can find is a previous thread in this discussion board saying that this is a problem with the intel Mac install DVDs. One solution that was suggested was to use the terminal to use the "ars" command.

I could not "man ars" from the terminal. When I tried to run the "ars" command, I received a "command not found" message. I was able to eventually find the "ars" command after doing an "ls -al" command, but never got that command to work.

I have also been searching the web for more information on this problem but have not been able to resolve it.

What good is having a backup if I can't restore from it?

07-27-2009, 05:29 PM
Presumably you mean the asr(8) (http://developer.apple.com/documentation/Darwin/Reference/Manpages/man8/asr.8.html) command.

07-27-2009, 05:49 PM
Yes, I did mean the "asr" command. "ars" is what I feel like.

Thank you. This is what I was looking for.

07-27-2009, 10:54 PM
Still no luck using the "asr" command in the terminal application on the OS 10.5 install DVD.

The "sudo" command is not recognized, and using "asr" without "sudo" did not work.

Very frustrating.

07-27-2009, 11:32 PM
OK. I don't have any information about what didn't work, but perhaps it would be easier to install a basic OS X install to a USB memory stick, start up from that, and use SUperDuper! to restore?

07-28-2009, 09:25 AM
Dave -- doesn't the Drobo require proprietary drivers to be installed on the startup disk (the 10.5 install DVD)?

07-28-2009, 09:28 AM
No: the Drobo acts like a regular FireWire or USB drive...

07-28-2009, 09:42 AM
Disk Utility just doesn't seem to like .sparseimage, so I am using Disk Utility to convert it to a .dmg. Then I will try to restore from that .dmg image.

If this works, well.... I don't want to count my chickens just yet.

07-28-2009, 09:54 AM
But you don't restore the .sparseimage directly. You open it, then use ASR to copy from its mounted volume, not from the file. You don't need to convert to a DMG.

07-28-2009, 09:43 PM
Please assume that I am a complete idiot that can't make even the smallest move without having my hand held. This shouldn't be too hard to do.

Next, please tell me what is wrong with what I have been doing.

1. Start my iBook from my OS 10.5.4 installer.

2. Open the Terminal app from the Tools menu.

3. type the following command:

ars restore --source /Volumes/Drobo/DanibookHDcopy.sparseimage --target /Volumes/Dan iBook HD --verbose

I really would appreciate any help on this...please.

07-28-2009, 11:29 PM
OK. The problem with Disk Utility is not with the 10.5 discs, it's with the 10.4 discs. So you should be able to follow the instructions provided in the User's Guide (with screen shots)... you use "File > Open Image..." to open the image, then restore from the mounted image volume, not from the "file".

07-29-2009, 10:15 AM

I followed the instructions exactly as in the user guide: I opened the sparse image from the file menu, and it put the opened disk image into the field on the left off the disk utility screen (just as in the example). But it would not drag into the source field and stick.

Any ideas on what I should try next?


07-29-2009, 10:21 AM
It should drag into the source field, Dan, if you're using a Leopard DVD: I've verified it here, and their bug was fixed. Very strange.

Well, you can use the asr command, but you'll use

asr restore --source /Volumes/the-mounted-image-volume-name-not-the-file --target /Volumes/Dan iBook HD --verbose

07-29-2009, 10:29 PM

I wanted to try using Disk Utility one more time before trying asr. This time I control-clicked the opened source disk image in the left hand field. This popped up a menu asking -- among other things -- if I wanted to set that disk as the source. Eureka...it is copying as I type.

Has anyone heard of this before?

Thank you,

07-29-2009, 11:12 PM
Not something I've heard of before, no. Very strange.