PDA

View Full Version : Unable to unmount primary OS drive when booted to external firewire drive backup.


TelexStar
06-30-2009, 02:51 PM
As the title says, I've backed up my main MBP hard drive using the "Backup - All Files" script to an external Firewire drive partition. I can boot to the backup drive without a problem but I can't unmount the primary drive. When I try I get the message 'The disk "Macintosh HD" could not be unmounted. Make sure that all applications and files are closed on this disk.'

I've tried searching the forum and the only similar problem I could find was here:- http://www.shirt-pocket.com/forums/showthread.php?t=3013&highlight=unmount+hard+drive Someone who was backing up to an image (which I'm not doing) and was told to rename the image backup to the same as the primary drive. That's not an easy option for me, without re-formating my backup drive partition.

Any ideas what is causing this and how I can fix to unmount my main drive?

dnanian
06-30-2009, 02:54 PM
Yes. Rename the backup drive to "Macintosh HD" and then start up from it.

TelexStar
06-30-2009, 03:08 PM
By "Macintosh HD" do you mean whatever my primary drive is called ("HAL") ?

dnanian
06-30-2009, 03:16 PM
Well, you had indicated above it was called "Macintosh HD". Is that not the case? You don't have to reformat, you simply have to rename.

TelexStar
06-30-2009, 03:21 PM
Well, you had indicated above it was called "Macintosh HD". Is that not the case? You don't have to reformat, you simply have to rename.

Apologies - that was a typo on my part as I copied and pasted the error from another topic.

In any case. I've renamed the backup drive to the same as that of my primary drive and when I boot to the backup I still get the same error.

dnanian
06-30-2009, 03:22 PM
I don't know why that'd be; something -- perhaps Spotlight? -- must have files open on that drive...

TelexStar
06-30-2009, 03:27 PM
I don't have anything open - It's a fresh boot-up.

I have set spotlight to *NOT* check either of my external Firewire partitions but I can't seem to find where to disable it for the primary drive.

dnanian
06-30-2009, 03:30 PM
Understood, but something has a file open there. Since the volumes are named the same, assuming that's what you've done, it must be something that's actively looking for drives to make "active"... have you tried adding the volume to the Spotlight Preference Pane's "Privacy" tab?

TelexStar
06-30-2009, 03:39 PM
Ok, while booted into my backup drive I tried adding my primary drive to the privacy list in Spotlight but it wouldn't accept it. I booted back to my primary drive, added the primary drive to the privacy list in spotlight and it did accept it. I then booted back to my backup drive, checked that my primary drive was still listed in Spotlight>Privacy, which it was, and now Disk Utility lets me unmount the primary drive.

I just need to remember to remove my main drive from the spotlight privacy list.

It might be worth adding something to your FAQ perhaps?

As an aside though, I'm concerned about the scenario where the main drive is unbootable and I'm unable to perform the actions above in order to unmount the main disk.

dnanian
06-30-2009, 03:42 PM
It's not something that happens much, actually. I don't know why Spotlight was being so active for you, but certainly booting in "Safe Boot" will prevent Spotlight from running, which would allow you to unmount...