PDA

View Full Version : Failure to restore from sparse image


dradovsky
06-28-2009, 11:45 AM
I attempted to restore my hard drive from its sparse image made by SuperDuper using Smart Update and stored on a USB Drobo.

I used Disk Utility from my OSX 10.5.4 installation disc.

In Disk Utility I mounted the sparse image, dragged it to the Source box, dragged the target drive to the Destination box, and then clicked on "Restore" to start the process. I did not check the "Erase" box.

When I checked this morning to see if the restore worked, I found a message stating that "Restore Failed -- No Directory".

Yikes.

Did I do something wrong?

dnanian
06-28-2009, 12:38 PM
Assuming that -- hopefully -- your Drobo was properly formatted for the Mac, and supports large files -- try checking the checkbox. It's quite possible that Disk Utility had a problem hitting a folder that was there already.

dradovsky
06-28-2009, 02:04 PM
Do you mean checking the "erase" box?

dradovsky
06-28-2009, 06:57 PM
Interesting...as you suggested I did check the "erase" box on the Disk Utility Restore page...and it worked. It also took much less time to copy the mounted sparse image onto the destination drive...

But I am puzzled as to why my newly restored hard drive is showing it holding only 72 gig or so of data when the sparse image that it was restored from was around 120 gig?

dnanian
06-28-2009, 07:23 PM
The internal size of the image was likely 72GB, while the external size included some free space, etc.