PDA

View Full Version : SD "An error occurred that halted execution"


falk
07-07-2005, 05:38 PM
Hi,
I wanted to "backup all files" (Tiger 10.4.1) on an external firewire drive, which went smoothly under 10.3.9. Execution halts, the log says:

[***] Thursday, July 07, 2005 10:26:41 PM Europe/Berlin
|10:26:41 PM|Info| SuperDuper!, version 74, path: /Applications/SuperDuper!.app, OS: 10.4.1 (8B15)
|10:26:41 PM|Info| Source Drive: /, name: 60GB, device: /dev/disk0s10 type: hfs, OS: 10.4.1 (8B15), capacity: 55.76 GB, used: 34.87 GB, directories: 94288, files: 515967
|10:26:41 PM|Info| Target Drive: /Volumes/120GB, name: 120GB, device: /dev/disk1s2 type: hfs, OS: 10.3.9 (7W98), capacity: 115.04 GB, used: 30.74 GB, directories: 81073, files: 497015
|10:26:41 PM|Info| Copy Mode : Erase, then copy files
|10:26:41 PM|Info| Copy Script : Backup - all files.dset
|10:26:41 PM|Info| Transcript : BuildTranscript.plist
|10:26:41 PM|Info| PHASE: Volume Preparation
|10:26:41 PM|Info| ...ACTION: Erase 120GB
|10:26:41 PM|Info| ......COMMAND => Erasing 120GB
|10:26:41 PM|Error| grep: conflicting matchers specified

Any clue ?

Falk

dnanian
07-07-2005, 06:18 PM
That's quite strange! I've not seen it before, but let's try one thing: rename your external drive to something other than "120GB" to see if that makes a difference. Try "Backup - 120GB" or something. In the meantime, we'll try to reproduce the problem here.

dnanian
07-07-2005, 06:30 PM
You know, Falk, this is weird. The only thing going on there is a grep for the words "Could not unmount". I can't see how that would be a conflicting matcher.

Do you have an unusual or 3rd party grep installed?

If not, what happens if you run:

echo "foo" | grep -q -F "Could not unmount"

at the terminal? -q says "don't give an error or anything else" (and you're getting an error)... so something strange is wrong.

falk
07-07-2005, 07:05 PM
> echo "foo" | /usr/bin/grep -q -F "Could not unmount"
gives
> grep: conflicting matchers specified

I have to admit that there is something strange with my system anyway, e.g.
> man ls
gives
/usr/bin/groff: can't find `DESC' file
/usr/bin/groff:fatal error: invalid device `ascii'

Thats the reason why I wanted to backup the system onto the firewire, do another clean install of Tiger and get back bookmarks, mails, adresses a.s.o. using "MigrationAssistant" from the firewire (gasp - btw: does that work if my firewire (MomoBay) is one of those which are NOT bootable ??!).

PROMISE: if I get this job done I BUY SuperDuper !

I have renamed 120GB to B120GB and tried SD again, same result:
Jul 8 00:03:39 falks-powerbook-g4 authexec: executing /Applications/SuperDuper!.app/Contents/MacOS/SVUagent
2005-07-08 00:03:44.367 SuperDuper![445] ***ERROR OCCURRED: grep: conflicting matchers specified

Falk

dnanian
07-07-2005, 07:15 PM
OK, Falk. The thing to do is to Archive and Install the OS on top of what you've already got. You're not going to get it to work with things this messed up.

So: Archive and Installer Tiger (if that's what you're running). Once that's done, THEN back up with SuperDuper! onto the external drive. Make sure you use "Backup - all files". You won't be able to test the backup since you can't boot from it, so look carefully at it.

Then, you should be OK to install/migrate.

falk
07-08-2005, 04:48 AM
Thanks, that did the job. Proper system, SD running, SD purchased. Great product.

May I ask another one risking to spoil you gently ?

I managed to loose my Sent-Mail during upgrade to Tiger (initially, I did a firewire-backup using CarbonCopyCloner and an Erase/Install of Tiger. However, the MigrationAssistant refused to give me things back from the firewire claiming its not an "old computer". I could rescue adresses from my smartphone, bookmarks and programs from the firewire and retrieved mails from the mail server. Sent mails are still missing).

All these files are there (I assume) on my firewire, under
/Users/Name/Library/Mail/IMAPsomething/mail/sent-mail.imapmbox/CachedMessages

HOW CAN I IMPORT .imapmbox files into Mail ? I surfed the web for quite a while without avail. Anybody knows ???

Kind regards
Falk

dnanian
07-08-2005, 10:37 AM
Glad that worked, Falk.

Regarding your mail, since you're using IMAP, I'd boot from the external drive, create a new "on server" mailbox for the sent messages, and copy them in using Mail. Then, on the new install, they'll automatically sync down from the server, and you can copy them out normally.