PDA

View Full Version : user cant get to backup partition - consistently


niteboater
03-16-2009, 05:31 PM
helping a user with SuperDuper v2.5

they are using a external USB 2.0 drive

a. have been Smart Updating (seemingly ok) - no restore has been done to test the backup's yet

b. the backup partition is on "MBP BU" which is a 100 Gb partition in GUID that holds the clone of the user MBP drive

c. consistently - the destination drive will appear, but is greyed out

Tried:

remove and reinstall of SD client
remove "settings" folder

to no avail.

I do notice when I ls -al /Volumes that the MBP BU partition comes up as:

lrwxr-xr-x 1 root admin 1 Mar 16 12:05 MBP BU -> /

but Im not sure if this is just a broken symlink issue or not.

Any advice appreciated

dnanian
03-16-2009, 05:48 PM
Did you try restarting the Mac?

niteboater
03-16-2009, 06:47 PM
thanks for your quick reply. restarting has no effect.

OTOH, if DU is used to format the partition, SD will again see it. Of course, this defeats the idea of Smart Updating entirely.

dnanian
03-16-2009, 06:58 PM
OK. Try using Get Info to change the drive read/write ownership to allow read/write for all users.

niteboater
03-16-2009, 11:07 PM
ok, that worked for that session but after reboot the permissions survive ie, 755 but the destination drive is still greyed out.

Also, by using Get-Info or Terminal, when trying to:

sudo chmod 777 /Volumes/MPB\ BU

the write permission never gets written to Group or Other. Not sure why.
I see a symlink as the type of file the destination drive is, so its not clear how SD handles symlinks.

Also - Smart Update worked to completion, at least as far as I can tell, but the destination drive still doesnt boot the Mac.

Once upon a time, SD and Leopard and the external USB 2.0 drive all played nice.

dnanian
03-17-2009, 09:00 AM
Hm. Are you sure you're not running from the backup? It looks like, perhaps, you are.

niteboater
03-17-2009, 01:03 PM
sorry mate, not clear about what you might mean from this short phrase.

a. buy SD
b. use it to make a bootable clone backup of any Mac HD
c. check it worked by booting from the clone

this is the loop.

What fails is step c. At step c. I see the external drive if I hold down Option key during startup - but the external clone never loads. I would know which drive booted my Mac because I can see the icon in the upper right of screen - it will not be the regular Macintosh HD icon (grey) but an orange and white icon.

What are you referring to specifically ?

dnanian
03-17-2009, 01:09 PM
No, that's not how you tell the startup drive. For example, when you looked in volumes before, you sent this:

lrwxr-xr-x 1 root admin 1 Mar 16 12:05 MBP BU -> /

You're running from the backup at that point. You can check it more readily by looking in the "About This Mac" panel. But the drive position on the desktop is not a reliable way of knowing what the startup drive is, as you've seen.

niteboater
03-17-2009, 02:00 PM
looks like I had a duh moment. Sorry to waste your time. All your help is deeply appreciated just the same. In fact the About window does state the MBP BU disk as the startup disk.

You gotta love SD and its tech support !