View Full Version : Intel Mac boots on Apple Partition but not GUID?!?!

02-28-2009, 09:38 PM
I have Leopard on my computer. I have used SD for years and even have had it save my bacon. My original SD backup external HDD was/is a Lacie d2 (250GB, same size as iMac internal HDD). It is partitioned as an Apple Partition Map and will boot up off of it.

I recently got 2 more Lacie drives that are larger than my internal HDD and I have partitioned them using GUID Partition Map with partitions for a SD backup as well. However these SD backups will not boot up Leopard. I have Erased, Partitioned, reback-uped, everything and they will not reboot. Does anyone have any suggestions?

I don't know why the Apple Partition Map will boot, but the GUID will not. I don't think an Intel Mac is even supposed to boot from an Apple Partition. I actually ran my Mac off the Lacie d2 for a week on my wife's laptop while my iMac HDD was being repaired so I know it works and works reliably.

03-01-2009, 01:51 AM
GUID should certainly boot if APM does. Are you sure they're not bootable? Does the drive show up in the Startup Disk Preference Pane?

03-01-2009, 08:40 AM
Yes, the disks always show up in the Startup Disk preference pane.

Last night I Erased (one pass with 0's) the Rugged Lacie and partitioned to APM then let SD run through the night and back up the computer. This morning, everything was complete so I selected it as the Startup Disk and Restarted ... nothing. It just went to the white screen with the Apple and stops, there is no revolving wheel showing that the computer is thinking, etc.

I just don't know what to do with these new disks. :confused: The only difference in the new disks and the original backup is they are partitioned down to a smaller size to match the internal HDD. Is there some reason that since there is other stuff on the external HDD (albeit in other partitions) that I can't boot from those drives?

03-01-2009, 09:35 AM
are you doing an erase and clone, or smart updating to a new volume?

03-01-2009, 10:29 AM
So if you take this same drive and partition as APM it boots fine?

03-01-2009, 10:30 AM
(It doesn't matter which of those he's using, fishmonkey, since he manually erased the drive first.)

03-01-2009, 10:36 AM
(It doesn't matter which of those he's using, fishmonkey, since he manually erased the drive first.)

i was wondering if maybe he had "ignore permissions on this volume" set after erasing, and then had SD do the clone without erasing...

that could possibly explain why the volumes don't boot properly...

03-01-2009, 10:37 AM
So if you take this same drive and partition as APM it boots fine?

he tried that and it didn't work either...

03-01-2009, 10:41 AM
Sorry, missed somehow that you did partition as APM. I'm happy that it didn't make a difference, at least, since it would not have made sense otherwise.

OK, so... do you have multiple drives attached to the Mac? Have you tried simplifying as much as possible, using just, say, FW400?

03-01-2009, 05:23 PM
Actually the "Ignore ownership on this volume" is checked under the drive info on one of the drives that doesn't boot, but is unchecked on another one that doesn't boot. How would this matter?

03-01-2009, 05:46 PM
That checkbox would always be unchecked when SD! worked with the drive. Plus, the startup drive *always* has ownership on.

03-01-2009, 06:02 PM
Here is as much information I can supply that I think matters ....

MacIntosh HD (250GB)
Capacity: 232.57GB

LaCie Big Disk Extreme Triple (2TB) - WILL NOT BOOT
Capacity: 250GB on the partition with the SD clone
4 GUID Partitions
"Ignore Ownership on this Volume" = unchecked
You have access = system, admin, everyone

LaCie d2 (250GB) - WILL BOOT
Capacity: 232.86GB on the partition with the SD clone
1 APM Partition
"Ignore Ownership on this Volume" = unchecked
You have access = system, admin, everyone
Note: This is the original LaCie that I had that has worked and saved my bacon. I probably had a clone of my internal HDD before Leopard came out and it just continued to update itself though the weekly updates. It was probably a little over 1.5 years ago when I got the HDD and set it up, but I don't remember doing much if anything special because I was new to a Mac so probably I plugged it in via FW800 and then opened SD and said START!

Lacie Rugged HDD (500GB)
2 APM Partitions - WILL NOT BOOT
Capacity: 232.88GB on the partition with the SD clone
2 GUID Partitions - WILL NOT BOOT
Capacity: 250GB on the partition with the SD clone
You have access = Gagel (Me), (unknown), everyone - why wouldn't system and admin not be in the list for this drive ... or does it matter?
Note: After the test this morning when the Rugged would not boot I decided to do another Zero out Data Erase and haven't done anything else to that drive right now. Currently "Ignore Ownership on this Volume" is checked ... can't be sure about it before but I do remember unchecking it one time before, but don't know when it was in all of my attempts. Actually, I just unchecked the "Ignore..." split the drive into 2 APMs and when I clicked on Get Info on the new partitions the "Ignore..." was checked. Then I did the same thing with 2 GUIDs and the "Ignore..." was checked. Not sure why the default is "Ignore..." being checked when I Erase or Partition.

All the HDDs are connected in series through FW800 in the order I have listed on this post (not that I think it matters). The d2 used to be next to the iMac, now it is after the Extreme and will boot up in either location.

As a reply to a previous post I have not tried to go down to FW400, would that matter?

03-01-2009, 06:06 PM
Please do try to simplify to just a single drive, connected to FW400, and see if it boots.

03-01-2009, 09:21 PM
With the Lacie Rugged that I had Zero out Data Erased, I partitioned by GUID into 2 partitions, then I went into Get Info on the drive and unchecked "ignore..." After that I ran SD on the drive (using FW800). I tried to reboot with FW800 and nothing.

I checked the Forum, saw dnanian's suggestion so I ejected and unplugged all FW800 drives and plugged the rugged in directly to the iMac with FW400 ... and nothing on the reboot :mad:

Now I am going to Zero out Data Erase the Rugged, partition as APM, uncheck "Ignore...", run SD and see what happens. That would make the drive identical to all properties of the LaCie d2 that I can reboot from.

I'm still open to suggestions...

03-01-2009, 09:24 PM
If you Option+Startup, get to the boot menu, THEN plug the drive in and refresh, does the drive actually show up as a possible drive to boot from?

03-01-2009, 09:41 PM
I have not tried that so I will do that the next time along with the other methods. How do I refresh in the Boot Menu once I attach the drive?

I have done the Restart from the System Preferences as well as restarting the computer and holding down Option until the attached boot devices are shown and have clicked on the different boot drives but still get the same results.

03-01-2009, 09:45 PM
And when you switched to FW400, you unplugged/disconnected from the Mac ALL the other drives?

03-01-2009, 10:56 PM
Yes, I ejected all external HDDs, I pulled the FW800 cable out from the back of the Mac, then I plugged in the Rugged with FW400 straight to the Mac. I went to the System Preferences selected to boot up off of the Rugged, restarted and nothing ... just the white screen with an Apple and no indication (like the thinking wheel) that the computer was doing anything ... I leave it like that for a couple minutes before I turn off the computer, disconnect the external HDD then turn the computer on to startup off the internal HDD.

03-01-2009, 11:21 PM
I really don't know what's going on here, unfortunately. It certainly should be working, and if the drive's showing up in the Startup Disk preference pane, it has an intact OS, is properly blessed, isn't disallowed by the OS (wrong partitioning, drive, etc) and should work.

I assume that you've tried starting up in Safe Boot (Shift) and Verbose (Cmd+Opt+v) to see if you get any diagnostics, yes? And you've applied the "All apps crash" 'fix' at the top of the forum? (I didn't mention either before because you indicated it was booting previously.)

03-02-2009, 06:20 AM
I have not tried to startup in Safe Mode yet ... will try with my new copy.

Also, did not apply the "All apps crash" but have downloaded and have that as an After script ... will this script bother the copying that is performed by the LaCie drive that does actually work or should I remove it from that scheduled backup?

03-02-2009, 09:10 AM
The script shouldn't bother anything.

03-02-2009, 07:53 PM
Well, I just finished trying everything I could think of after I reformatted to APM ...
Restart with FW800 = X
Plugged in FW400 and restarted = X
Selected Disk on Startup w/ FW400 = X
Restart from preferences w/ & w/o other drives hooked up w/ FW400 and FW800 = X
Startup in Safe Mode = X ... it won't even go to Safe Mode

My last ditch effort is to make the drive a single GUID partition and run SD on it effectively wasting 1/2 of the drive space. Has anyone ever heard of reboots not working on a drive with multiple partitions? That is my only other guess.

Has anyone ever heard that the portable LaCie Rugged Drives can not create reboot drives or are not configured as such?

03-02-2009, 08:06 PM
I've got a lot of users who have no problem starting up from the Rugged drive.

03-02-2009, 11:29 PM
Well, I just tried my last ditch attempt of using the Rugged partitioned as 1 GUID drive and nothing. It is weird, I can feel the Rugged drive running through the reboot until the gray apple gets on the screen and then it just stops. I can also watch some indicator lights on a USB port and they are on until the gray apple comes on the screen and all the lights go out at the same time as the drive stops running.

03-02-2009, 11:37 PM

Keypoint ... you have to have power supplied to the Rugged when you are using it to boot from (at least I did). I used the supplied power cord which plugs into a USB opening on the iMac, restarted and it booted right up!

03-03-2009, 09:26 AM
Ah-hah! A drive POWER problem?!? Wow.

But -- why wasn't it working with FireWire? Lots more power on FireWire...

03-04-2009, 07:17 AM
Yep. That is a good question because that was my understanding also. So I confirmed and reconfirmed yesterday several times and using FW800 AND the power cord (cable plugged into a USB port) it worked every single time .... interesting ....

03-04-2009, 09:24 AM
Bizarre. But glad you're working.

Take away lesson for all: if it comes with a wall wart, use it.