View Full Version : nervous newbie - restoring drive after format

02-19-2009, 01:13 AM
I've used sd for a while now to clone my system HD. and now the time has come to use it!
my system has become more buggy over time and now, after i've buggered completely by meddling, I've decided to reformat the drive and start again.
my SD backup was updated every week or so, so contains a few of the niggles but is workable. Rather than copy the buggy OS back over, I want to reinstall a fresh copy of the OS and then restore my settings, files and applications from the SD clone. Can i do this, or is it all or nothing?

02-19-2009, 11:18 AM
What I'd do is CHECK YOUR BACKUP FIRST (start up from it). If you're happy with it, in general, then clean install Leopard (assumed) or Tiger to the internal. It'll prompt you to "copy from another Mac" during the install. Point that at the backup volume and it'll bring in your applications and data, leaving the fresh OS in place.

Alternatively, have you tried an 'archive and install'? It's very unusual to have a system get "more buggy over time" like this, and often it's best to diagnose what's wrong rather than toss the whole thing.

02-20-2009, 02:25 PM
I've had sleep issues for a while, and now trouble syncing my iPhone. I rebooted from my clone and everything was fine (I'm running off that now).
I tried restoring from my clone to the main HD, but the sync problem continued. I did an archive and install but now the phone isnt recognised at all.
Now I'd sooner just wipe the HD and start again, I just want to make sure if I restored from my clone to a fresh OS I wouldn't be copying bugs back over.

02-20-2009, 03:56 PM
Well, actually, it doesn't make much sense that it's working on the backup but, when you copy the copy back, it's failing. Perhaps your internal drive is failing?

02-20-2009, 06:34 PM
I didn't reformat the drive, just did a restore from backup. The dialogue did say that certain system and kernel files would be left untouched.

02-21-2009, 12:18 AM
Yes, but those are the same files that wouldn't be copied when the backup was made. Still doesn't make sense.

02-21-2009, 12:44 AM
how woul i test the HD then - everything else works fine. I've had this ejecting problem with every ipod i've owned in the last two years (since i've had the mac pro)

02-21-2009, 08:23 AM
Well, what I'd do is use "lsof" (lower case LSOF) to see what has a file open on the iPod. Basically something like:

sudo lsof | grep "the-ipod-volume-name"

02-28-2009, 03:48 PM
sudo lsof | grep "the-ipod-volume-name"

oo, what does this do then? i've no idea about any of this -- i type this into the terminal with the ipod connected i take it. what kind of result am i looking for?

thanks for all the help so far btw

02-28-2009, 04:03 PM
It'll tell you what files are open on the volume you specify (well, it'll show you all files with the word(s) you type in the quotes in their path).

02-28-2009, 04:51 PM
what can i learn from this? the ipod disconnects of it's own accord after a few seconds (anything from 2 to 20)

03-01-2009, 01:49 AM
That you have a bad port or iPod?

03-27-2009, 12:12 PM
i ended up buying a sonnet usb card. that seems to have fixed the problem.

i couldn't get anywhere with the code.

thanks for the help :)

03-27-2009, 12:20 PM
Ah, so it was a bad port... glad you've found an effective solution!

03-27-2009, 12:25 PM
well, im not sure.. i still plug the iphone into the front ports, just as i've always done. i'm assuming with the extra card more power is being distributed evenly; and not all being sucked into the integrated ports on the back..