PDA

View Full Version : Help! Can't boot from SD clone and my HD is about to die


TyTy
01-15-2009, 11:58 AM
Really desperate here. I cloned my hard drive after my system started locking up, and I started getting scraping sounds coming from it, and disk utility started warning about fatal hardware errors. The clone was fine and I booted from it to check everything was alright then found I had the application quitting problem.

I came here and found the script to fix it, so I ran SD again after deleting the first clone with disk utility.

I now find that when I try to boot from the clone it doesn't get past the grey start up screen with the Apple logo.

I really need to sort this out as my internal drive is about to bite the dust. It could happen anytime.

Please Help!!!

dnanian
01-15-2009, 12:00 PM
Can you boot in "Safe" boot (hold down Shift during startup)?

TyTy
01-15-2009, 12:03 PM
Thanks for quick response. I'll try that and get back to you.

TyTy
01-15-2009, 12:34 PM
Just tried Safe Boot and got the same result. I had looked in the Startup Disk system preference and the clone is showing up a valid startup disk.

dnanian
01-15-2009, 12:55 PM
Perhaps try examining what's going on by booting in 'verbose' mode -- Cmd+Opt+v while starting from the backup.

TyTy
01-15-2009, 03:15 PM
I tried booting in verbose mode and there seem to be several things failing.

What I managed to catch were a couple that said:

mDNSResponder[number]<Error>:ERROR :ndsserver_init: Bad file descriptor

mDNSResponder[number]<Error>:Daemon start :ndsserver_init failed

failed to add 192.168.2.1 to fw0, Device not configured

The above, amongst other messages seemed to keep repeating themselves.

All Chinese to me.

dnanian
01-15-2009, 03:32 PM
Hm. It almost sounds like the firewire drive itself is having problems (assuming it's FIreWire). Is it? Only device on FW or USB?

TyTy
01-15-2009, 03:43 PM
It is a firewire drive. Actually a partition on a 1TB Lacie D2 Quadra. It is fairly new and has not shown any signs of problems at all. The other partition holds a 600GB iTunes library and iTunes has never had any problems with the library. I also use it for backing up a few files and folders and it has always performed flawlessly.

It is daisy chained with another Lacie firewire drive (all connections are firewire 800) so I suppose the next step is to try to boot with it connected directly.

dnanian
01-15-2009, 03:57 PM
Absolutely. Simplify as much as you possibly can. Even step down to FW400.

TyTy
01-15-2009, 04:04 PM
Ok, here goes. I'll report back as soon as I've tried it. It strange though that I had no problems booting the clone before I cloned with the application crash fix script (for want of a better term!)

I think firewire has some issues anyway. I had a drive that stopped mounting when connected with firewire but had no problem mounting via USB.

Back soon. Fingers crossed.

TyTy
01-15-2009, 04:44 PM
Well, I tried all the connections I have from the drive, FW800, FW400 and USB2. The same result in each case.

I think I have to try to clone all over again without the script at the end and see what happens unless you can come up with something else.

Thanks for all your help so far.

dnanian
01-15-2009, 04:46 PM
Try Smart Updating over what you have. Don't erase.

TyTy
01-15-2009, 04:50 PM
That was the first thing I tried and when I couldn't boot after that I decided to erase. I'll try it again and let you know what happens.

Do I add the script to run after the update is done or not?

TyTy
01-15-2009, 04:51 PM
I even tried applying the 10.5.6 combo update to the clone but that failed.

dnanian
01-15-2009, 05:00 PM
Wait. That FAILED? How?

TyTy
01-15-2009, 05:06 PM
It went through the process. Prepared the disk etc. Then it failed when it started writing the files.

dnanian
01-15-2009, 05:34 PM
That would imply that the FireWire drive itself is having problems, which would agree with what we're seeing in the verbose boot, too...

TyTy
01-15-2009, 06:06 PM
Could the problem be just with the partition? It would be a real pain to have to rip nearly 1000 CDs again?

dnanian
01-16-2009, 12:43 AM
Could be. Hard to tell, unfortunately.

TyTy
01-19-2009, 01:56 PM
Been away for a couple of days. I fixed my issue. :)

What I did was use iPartition to delete the partition I was cloning to and then create a new partition. I then tried cloning to this new partition and everything seems to be working as expected. All apps launch alright and all the bits and bobs appear to be in the right places.

I think the problem I was having had something to do with permissions that couldn't be fixed the normal way, even by the almighty DiskWarrior.

dnanian
01-19-2009, 02:49 PM
That doesn't seem likely, but as long as it's working it's hard to argue with success.

TyTy
01-19-2009, 03:07 PM
Well, in Disk Utility I could verify the disk alright but when I tried to verify or repair permissions I kept getting the "failure on exit" error, so it seemed to me that the problem lay in the permissions table of the partition.

Disk Warrior did find several problems with the table and attempted to rebuild it but I kept getting the same issue when trying to boot into the clone, so I thought I'd just delete the partition and its table with it. I have no problem booting into the clone now and all works just fine.

dnanian
01-19-2009, 03:15 PM
It sounds more like the drive was damaged under the data, and deleting/recreating the partition moved things around a bit.