PDA

View Full Version : SD Stalls in the middle of copy


wasted4hours
09-05-2008, 02:44 PM
Using SuperDuper I was able to make an image of the internal HD of my MBP to an external drive before. But last night I tried to dupe to a new HD that I bought for my Mac (I was trying to upgrade from a 120GB drive to an 320GB drive) and it stalled near the end, twice. Hence my username, sorry I do not mean to so negative, but I was very disappointed at the time :o

At first attempt, it stalled after about 81GB copied and did not recover for 45 minutes (it appeared to be working, but only the elapsed time was being updated, nothing else, for 45 minutes). So I stopped it and thought it was caused by me browsing the web during the copy.

So I started it again and but this time I left it alone. When I got back to it, I noticed it had got stuck around 81GB again. It did not move from there for 45 minutes. I tried to get an strace of the SDCopy thread. I am not that familiar with strace (or rather ktrace) on the Mac so I could not tell if SDCopy was trying to copy the same thing over and over, or not. So I gave up on it.

I downloaded Carbon Copy Cloner and left it copying over night. In the morning I noticed it had copied without errors and I was able to boot from my new HD. Now my Mac has it's new HD installed :cool:

I cannot help debug this issue, but I wanted to write here give feedback. Seems to me that SuperDuper needs some kind of a "stall check" built in so it can detect such a problem and perhaps with user intervention fix it (well it would be nice if it did not stall at all, but...)

I want to also note that I'll keep SD as a tool and will consider registering it. But I'd like to know that this issue will be addressed.

dnanian
09-05-2008, 07:25 PM
I don't really have much information to go on, and if you're not willing to run it again I'm not sure how I'd know what was wrong to fix it.

It's likely it was either copying a large file or a file on your drive was being actively updated while we were copying it. There is a command -- lsof -- that will tell you what's happening... you'd use "sudo lsof | grep SDCopy" to see what's being copied at any given time...

wasted4hours
09-06-2008, 04:44 PM
Well I did not want to wait to figure out the problem before I upgrade my HD. So I can try to debug it next time I need to upgrade. But may be then the problem will not be there... But if I see it again I'll try that command. But like I said the second time the machine was left alone completely, no apps. other than SD was running on it.

I still have the original drive as is, of course the OS is not running from it anymore. But I can try to dupe it (in a SATA to USB adtaper) to see if it gets stuck again. I'll see if I can try that later.

As I was trying to suggest in my original post, it seems to me that SD needs some kind of a check built in to detect these stall issues. Even if it only generated some kind of a report that we can share with you, so you can figure out what the problem is.

dnanian
09-06-2008, 05:14 PM
Understood and thanks for the suggestion.

wasted4hours
09-13-2008, 01:10 AM
So I did test it but forgot to update this thread. It worked this time, but three differences, 1) this time the the OS was not running from the source drive and 2) the source drive was USB mounted and 3) the destination was a sparse image on my Mac HD.