PDA

View Full Version : High CPU Usage


davpel
08-27-2008, 06:51 PM
I'm running SuperDuper on a Mac Mini Intel with Leopard. I have two backups scheduled to run overnight. Normally, I have no issue. However, if I happen to shut down my Mac before going to bed (thereby preventing the overnight backups), when I log on the next morning SuperDuper causes my CPU to go crazy. In the activity monitor, the SD applet is at the top of the list and solely responsible for 2/3 or more of the CPU.

Besides never shutting down the Mac at night, any ideas on how to prevent this from occurring?

dnanian
08-27-2008, 07:31 PM
That's weird, because those cron jobs shouldn't run if the time had passed -- are you running something that "forces" cron tasks to execute when skipped?

davpel
08-28-2008, 12:19 AM
That's weird, because those cron jobs shouldn't run if the time had passed -- are you running something that "forces" cron tasks to execute when skipped?

Not that I'm aware of. I do run Macaroni . . . could this be the culprit?

I just noticed another thread which seems to involve the same (or a similar) issue: http://www.shirt-pocket.com/forums/showthread.php?t=3837

Was the but referred to in that thread ever resolved?

dnanian
08-28-2008, 10:54 AM
That's different, actually, because those were scheduled to run and the user was logged out at that time, not off.

Maybe Macaroni has settings that do this?

davpel
08-28-2008, 04:44 PM
That's different, actually, because those were scheduled to run and the user was logged out at that time, not off.

Maybe Macaroni has settings that do this?

There's nothing readily apparent in the Macaroni settings, but I'll contact the Macaroni developer and report back. Unfortunately, my past experience with Macaroni's customer support does not make me hopeful that I will get an answer anytime soon!

dnanian
08-28-2008, 04:51 PM
It may list it as "perform system scheduled maintenance tasks" or something like that.

rcrcr
09-28-2008, 03:02 PM
I am seeing the same CPU usage issue with Leopard Server 10.5.5.

Basically, if I run top -du, I can see applet hogging about 98% CPU usage all of the time.

Can a bugfix be expected? Any other advice?

dnanian
09-28-2008, 03:24 PM
You need the user who has scheduled the copy to be logged in and in front or this will happen. It should be fixed in the next update of SD (but the same restrictions apply - you just won't get the CPU use).

intheblacklodge
09-29-2008, 05:01 PM
I'm seeing this problem too. However, in my case, the user who has the backup scheduled (and is not an administrator) is logged in, and the backups seem to occur, but the administrator account I used to unlock the backup is running the applet at 100% cpu.

dnanian
09-29-2008, 06:00 PM
I think you must have a schedule for that user, actually: the schedule drivers runs as the user you schedule as, not as the authenticated user.

intheblacklodge
09-30-2008, 11:45 AM
Weird, you were right. I don't have any idea how a backup got scheduled for that user though. For the exact same time of day nonetheless. Could be I just have amnesia though.

dnanian
09-30-2008, 11:46 AM
Glad that explained it. Or sort of explained it. :)